]> git.pld-linux.org Git - packages/audacious.git/blobdiff - audacious-home_etc.patch
- up to 1.4.6
[packages/audacious.git] / audacious-home_etc.patch
index ac2d0b15140841146de3721c6965b115fade3b09..0d2702c3a965680cc679feb48d074b6f160b71c6 100644 (file)
@@ -1,70 +1,60 @@
-diff -aurN audacious-0.1.2.orig/audacious/main.c audacious-0.1.2/audacious/main.c
---- audacious-0.1.2.orig/audacious/main.c      2005-12-04 18:29:14.000000000 +0100
-+++ audacious-0.1.2/audacious/main.c   2005-12-16 12:31:16.000000000 +0100
-@@ -77,7 +77,6 @@
- #include "pixmaps.h"
- #include "images/audacious_player.xpm"
--
- /* Translatable string for beep.desktop's comment field */
- const gchar *desktop_comment = N_("Audacious");
-@@ -408,7 +407,7 @@
- static void
- bmp_init_paths(void)
- {
--    bmp_paths[BMP_PATH_USER_DIR] = g_build_filename(g_get_home_dir(), BMP_RCPATH, NULL);
-+    bmp_paths[BMP_PATH_USER_DIR] = g_build_filename(_HEdir, BMP_RCPATH, NULL);
-     bmp_paths[BMP_PATH_USER_PLUGIN_DIR] = USER_PATH(BMP_USER_PLUGIN_DIR_BASENAME);
-     bmp_paths[BMP_PATH_USER_SKIN_DIR] = USER_PATH(BMP_SKIN_DIR_BASENAME);
-diff -aurN audacious-0.1.2.orig/audacious/Makefile.am audacious-0.1.2/audacious/Makefile.am
---- audacious-0.1.2.orig/audacious/Makefile.am 2005-11-16 05:21:50.000000000 +0100
-+++ audacious-0.1.2/audacious/Makefile.am      2005-12-16 12:30:08.000000000 +0100
-@@ -10,7 +10,8 @@
-       $(GTK_LIBS)      \
-       $(LIBGLADE_LIBS) \
-       $(LTLIBINTL)     \
--      $(top_builddir)/libaudacious/libaudacious.la
-+      $(top_builddir)/libaudacious/libaudacious.la \
+--- audacious-1.4.0/src/audacious/Makefile     2007-01-26 18:58:10.000000000 +0100
++++ audacious-1.4.0/src/audacious/Makefile     2007-01-26 18:59:45.000000000 +0100
+@@ -189,7 +189,8 @@
+       ${MOWGLI_LIBS}          \
+       ${LIBMCS_LIBS}          \
+       ${LIBGLADE_LIBS}        \
+-      ${REGEX_LIBS}
++      ${REGEX_LIBS}           \
 +      -lhome_etc
  
- audacious_CFLAGS = \
-       $(X_CFLAGS)        \
-diff -aurN audacious-0.1.2.orig/libaudacious/configdb.h audacious-0.1.2/libaudacious/configdb.h
---- audacious-0.1.2.orig/libaudacious/configdb.h       2005-10-24 12:06:47.000000000 +0200
-+++ audacious-0.1.2/libaudacious/configdb.h    2005-12-16 12:30:48.000000000 +0100
-@@ -2,7 +2,7 @@
+ LDFLAGS += ${PROG_IMPLIB_LDFLAGS}
+--- audacious-1.3.0/src/audacious/configdb.h   2007-01-26 18:58:10.000000000 +0100
++++ audacious-1.3.0/src/audacious/configdb.h   2007-01-26 19:01:51.000000000 +0100
+@@ -2,6 +2,7 @@
  #define CONFIGDB_H
  
  #include <glib.h>
--
 +#include <home_etc.h>
  
- typedef struct _ConfigDb ConfigDb;
+ /**
+  * ConfigDb:
+--- audacious-1.3.0/src/audacious/main.c       2007-01-23 03:21:22.000000000 +0100
++++ audacious-1.3.0/src/audacious/main.c       2007-01-26 19:08:25.000000000 +0100
+@@ -490,13 +490,13 @@
+     char *xdg_cache_home;
+     xdg_config_home = (getenv("XDG_CONFIG_HOME") == NULL
+-        ? g_build_filename(g_get_home_dir(), ".config", NULL)
++        ? g_build_filename(_HEdir, ".config", NULL)
+         : g_strdup(getenv("XDG_CONFIG_HOME")));
+     xdg_data_home = (getenv("XDG_DATA_HOME") == NULL
+-        ? g_build_filename(g_get_home_dir(), ".local", "share", NULL)
++        ? g_build_filename(_HEdir, ".local", "share", NULL)
+         : g_strdup(getenv("XDG_DATA_HOME")));
+     xdg_cache_home = (getenv("XDG_CACHE_HOME") == NULL
+-        ? g_build_filename(g_get_home_dir(), ".cache", NULL)
++        ? g_build_filename(_HEdir, ".cache", NULL)
+         : g_strdup(getenv("XDG_CACHE_HOME")));
+     bmp_paths[BMP_PATH_USER_DIR] =
+--- audacious-1.3.0/src/audacious/util.c       2007-01-27 14:01:55.000000000 +0100
++++ audacious-1.3.0/src/audacious/util.c       2007-02-05 22:48:12.000000000 +0100
+@@ -29,6 +29,7 @@
+ #include "util.h"
  
-diff -aurN audacious-0.1.2.orig/libaudacious/configdb_rcfile.c audacious-0.1.2/libaudacious/configdb_rcfile.c
---- audacious-0.1.2.orig/libaudacious/configdb_rcfile.c        2005-10-24 12:06:47.000000000 +0200
-+++ audacious-0.1.2/libaudacious/configdb_rcfile.c     2005-12-16 12:30:08.000000000 +0100
-@@ -40,7 +40,7 @@
-     ConfigDb *db;
-     db = g_new(ConfigDb, 1);
--    db->filename = g_build_filename(g_get_home_dir(), BMP_RCPATH, 
-+    db->filename = g_build_filename(_HEdir, BMP_RCPATH, 
-                                     "config", NULL);
-     db->file = bmp_rcfile_open(db->filename);
-     if (!db->file)
-diff -aurN audacious-0.1.2.orig/libaudacious/Makefile.am audacious-0.1.2/libaudacious/Makefile.am
---- audacious-0.1.2.orig/libaudacious/Makefile.am      2005-10-24 12:06:47.000000000 +0200
-+++ audacious-0.1.2/libaudacious/Makefile.am   2005-12-16 12:30:08.000000000 +0100
-@@ -10,7 +10,8 @@
- libaudacious_la_LIBADD = \
-       $(GTK_LIBS)      \
-       $(GCONF_LIBS)    \
--      $(GNOMEVFS_LIBS)
-+      $(GNOMEVFS_LIBS) \
-+      -lhome_etc
+ #include <glib.h>
++#include <home_etc.h>
+ #include <glib/gi18n.h>
+ #include <glade/glade.h>
+ #include <gtk/gtk.h>
+@@ -1011,7 +1012,7 @@
+   gchar *tmp;
+   if ( (tmp = getenv("XDG_CONFIG_HOME")) == NULL )
+-    datadir = g_build_filename( g_get_home_dir() , ".config" , "audacious" ,  NULL );
++    datadir = g_build_filename( _HEdir , ".config" , "audacious" ,  NULL );
+   else
+     datadir = g_build_filename( tmp , "audacious" , NULL );
  
- INCLUDES = \
-       $(GTK_CFLAGS)        \
This page took 0.063495 seconds and 4 git commands to generate.