]> git.pld-linux.org Git - packages/audacious.git/blob - audacious.spec
67309ee97c7b40ca7e619f029a2bc485ae1e3f36
[packages/audacious.git] / audacious.spec
1 #
2 # TODO
3 # - exclude audtool to separate package
4 #
5 # Conditional build:
6 %bcond_with     gconf           # build without gconf support
7 #
8
9 %define _dr     dr1
10
11 Summary:        Sound player with the WinAmp GUI, for Unix-based systems for GTK+2
12 Summary(pl.UTF-8):      Odtwarzacz dźwięku z interfejsem WinAmpa dla GTK+2
13 Name:           audacious
14 Version:        1.4.0
15 Release:        0.%{_dr}.1
16 License:        GPL
17 Group:          X11/Applications/Sound
18 Source0:        http://static.audacious-media-player.org/release/%{name}-%{version}-%{_dr}.tgz
19 # Source0-md5:  dcc25e836194e3ed351a8fff79d61cf9
20 Source1:        mp3license
21 Patch0:         %{name}-desktop.patch
22 Patch1:         %{name}-home_etc.patch
23 URL:            http://audacious-media-player.org/
24 %{?with_gconf:BuildRequires:    GConf2-devel >= 2.6.0}
25 BuildRequires:  autoconf >= 2.59
26 BuildRequires:  automake
27 BuildRequires:  dbus-devel >= 0.60
28 BuildRequires:  dbus-glib-devel >= 0.60
29 BuildRequires:  gettext-devel
30 BuildRequires:  gtk+2-devel >= 2:2.6.0
31 BuildRequires:  home-etc-devel
32 BuildRequires:  libglade2-devel >= 2.3.1
33 BuildRequires:  libstdc++-devel
34 BuildRequires:  mcs-devel
35 BuildRequires:  pkgconfig
36 BuildRequires:  rpmbuild(macros) >= 1.198
37 Requires(post,postun):  desktop-file-utils
38 Requires:       %{name}-libs = %{version}-%{release}
39 Requires:       audacious-output-plugin
40 Obsoletes:      audacious-static
41 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43 %description
44 Audacious is a media player based on BMP. Since the development of the
45 former project had been terminated, this fork was created.
46
47 %description -l pl.UTF-8
48 Audacious to odtwarzacz mediów oparty na BMP. Powstał on ponieważ
49 rozwój pierwowzoru został zakończony.
50
51 %package libs
52 Summary:        Audacious media player library
53 Summary(pl.UTF-8):      Biblioteka odtwarzacza multimedialnego Audacious
54 Group:          X11/Applications/Sound
55
56 %description libs
57 Audacious media player library.
58
59 %description libs -l pl.UTF-8
60 Biblioteka odtwarzacza multimedialnego Audacious.
61
62 %package devel
63 Summary:        Header files for Audacious media player
64 Summary(pl.UTF-8):      Pliki nagłówkowe odtwarzacza multimedialnego Audacious
65 Group:          X11/Development/Libraries
66 Requires:       %{name}-libs = %{version}-%{release}
67 Requires:       gtk+2-devel >= 2:2.6.0
68 Requires:       home-etc-devel
69 Requires:       mcs-devel
70
71 %description devel
72 Header files required for compiling Audacious media player plugins.
73
74 %description devel -l pl.UTF-8
75 Pliki nagłówkowe potrzebne do kompilowania wtyczek odtwarzacza
76 multimedialnego Audacious.
77
78 %prep
79 %setup -q -n %{name}-%{version}-%{_dr}
80 %patch0 -p1
81 %patch1 -p1
82 # BUGFIX: http://bugs-meta.atheme-project.org/view.php?id=736
83 echo 'const char *svn_stamp = "release";\n' > src/audacious/build_stamp.c
84
85 %build
86 %{__aclocal} -I m4
87 %{__autoconf}
88 %{__autoheader}
89 %configure \
90         --%{?with_gconf:en}%{!?with_gconf:dis}able-gconf \
91         --enable-shared
92
93 %{__make}
94
95 %install
96 rm -rf $RPM_BUILD_ROOT
97 install -d $RPM_BUILD_ROOT%{_libdir}/audacious/{Container,Effect,General,Input,Output,Visualization}
98
99 %{__make} install \
100         DESTDIR=$RPM_BUILD_ROOT
101
102 %find_lang %{name}
103
104 %clean
105 rm -rf $RPM_BUILD_ROOT
106
107 %post
108 %banner %{name} -e << EOF
109 Remember to install appropriate input plugins for files
110 you want to play!
111 EOF
112
113 %update_desktop_database_post
114
115 %postun
116 %update_desktop_database_postun
117
118 %post   libs -p /sbin/ldconfig
119 %postun libs -p /sbin/ldconfig
120
121 %files -f %{name}.lang
122 %defattr(644,root,root,755)
123 %attr(755,root,root) %{_bindir}/audacious
124 %attr(755,root,root) %{_bindir}/audtool
125 %dir %{_libdir}/audacious
126 %dir %{_libdir}/audacious/Container
127 %dir %{_libdir}/audacious/Effect
128 %dir %{_libdir}/audacious/General
129 %dir %{_libdir}/audacious/Input
130 %dir %{_libdir}/audacious/Output
131 %dir %{_libdir}/audacious/Visualization
132
133 %{_mandir}/man*/*
134
135 %dir %{_datadir}/audacious
136 %{_datadir}/audacious/glade
137 %dir %{_datadir}/audacious/images
138 %{_datadir}/audacious/images/*
139 %{_datadir}/audacious/Skins
140 %{_datadir}/audacious/ui
141 %{_desktopdir}/*.desktop
142 %{_pixmapsdir}/*.png
143
144 %files libs
145 %defattr(644,root,root,755)
146 %attr(755,root,root) %{_libdir}/libaudclient.so.*.*.*
147 %ghost %attr(755,root,root) %{_libdir}/libaudclient.so.?
148 %dir %{_libdir}/audacious
149 %attr(755,root,root) %{_libdir}/audacious/libaudid3tag.so
150
151 %files devel
152 %defattr(644,root,root,755)
153 %attr(755,root,root) %{_libdir}/libaudclient.so
154 %{_includedir}/audacious
155 %{_pkgconfigdir}/audacious.pc
156 %{_pkgconfigdir}/audclient.pc
This page took 0.033883 seconds and 2 git commands to generate.