]> git.pld-linux.org Git - packages/aubio.git/blob - aubio.spec
- added python subpackage
[packages/aubio.git] / aubio.spec
1 # TODO:
2 #       - unpackaged /usr/share/sounds/aubio/woodblock.aiff
3 #       - python package NFY (_aubiowrapper.a in sitescriptdir?)
4 #       - create lash.spec (http://www.nongnu.org/lash) and
5 #         --enable-lash
6 #
7 # Conditional build:
8 %bcond_with     python  # build python bindings
9 #
10 Summary:        aubio is a library for audio labelling
11 Name:           aubio
12 Version:        0.3.2
13 Release:        0.1
14 License:        GPL v2+
15 Group:          Libraries
16 Source0:        http://aubio.piem.org/pub/%{name}-%{version}.tar.gz
17 # Source0-md5:  ffc3e5e4880fec67064f043252263a44
18 URL:            http://aubio.piem.org/
19 BuildRequires:  alsa-lib-devel
20 BuildRequires:  fftw3-single-devel
21 BuildRequires:  jack-audio-connection-kit-devel
22 BuildRequires:  libsamplerate-devel
23 BuildRequires:  libsndfile-devel
24 %if %{with python}
25 BuildRequires:  python-devel
26 BuildRequires:  swig-python
27 %endif
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 aubio is a library for audio labelling
32
33 %package devel
34 Summary:        Header files for aubio library
35 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki aubio
36 Group:          Development/Libraries
37 Requires:       %{name} = %{version}-%{release}
38
39 %description devel
40 Header files for aubio library.
41
42 %description devel -l pl.UTF-8
43 Pliki nagłówkowe biblioteki aubio.
44
45 %package static
46 Summary:        Static aubio library
47 Summary(pl.UTF-8):      Statyczna biblioteka aubio
48 Group:          Development/Libraries
49 Requires:       %{name}-devel = %{version}-%{release}
50
51 %description static
52 Static aubio library.
53
54 %description static -l pl.UTF-8
55 Statyczna biblioteka aubio.
56
57 %package progs
58 Summary:        Example applications using aubio library
59 Group:          Applications
60 Requires:       %{name} = %{version}-%{release}
61
62 %description progs
63 A few examples of applications using aubio library:
64 - aubioonset: outputs the onset detected
65 - aubionotes: uses both onset and pitch to extract symbolic music data
66     from an audio source and emit MIDI like data.
67 - aubiocut: a python script that takes an input sound and creates one
68     new sample at each detected onset or beat. The slices produced by
69     aubiocut are useful for use with a sequencer such as Hydrogen.
70 - aubiopitch: a python script to extract pitch tracks from sound files
71
72 %package -n python-aubio
73 Summary:        aubio python bindings
74 Group:          Libraries/Python
75 Requires:       %{name} = %{version}-%{release}
76
77 %description -n python-aubio
78 aubio python bindings.
79
80 %prep
81 %setup -q
82
83 %build
84 %configure \
85         --enable-alsa \
86         --enable-jack
87
88 %{__make}
89
90 %install
91 rm -rf $RPM_BUILD_ROOT
92
93 %{__make} install \
94         DESTDIR=$RPM_BUILD_ROOT
95
96 %clean
97 rm -rf $RPM_BUILD_ROOT
98
99 %post   -p /sbin/ldconfig
100 %postun -p /sbin/ldconfig
101
102 %files
103 %defattr(644,root,root,755)
104 %doc AUTHORS ChangeLog NEWS README THANKS TODO
105 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
106
107 %files devel
108 %defattr(644,root,root,755)
109 %attr(755,root,root) %{_libdir}/lib*.so
110 %{_libdir}/lib*.la
111 %{_includedir}/%{name}
112 %{_pkgconfigdir}/*.pc
113
114 %files static
115 %defattr(644,root,root,755)
116 %{_libdir}/lib*.a
117
118 %files progs
119 %defattr(644,root,root,755)
120 %attr(755,root,root) %{_bindir}/aubionotes
121 %attr(755,root,root) %{_bindir}/aubioonset
122 %attr(755,root,root) %{_bindir}/aubiotrack
123 %if %{with python}
124 %attr(755,root,root) %{_bindir}/aubiocut
125 %attr(755,root,root) %{_bindir}/aubiopitch
126 %endif
127
128 %files -n python-aubio
129 %defattr(644,root,root,755)
130 %{py_sitescriptdir}/aubio
This page took 0.22626 seconds and 4 git commands to generate.