]> git.pld-linux.org Git - packages/aubio.git/blob - aubio.spec
- more TODO
[packages/aubio.git] / aubio.spec
1 # TODO:
2 #       - unpackaged /usr/share/sounds/aubio/woodblock.aiff
3 #       - python package NFY (_aubiowrapper.a in sitescriptdir?)
4 #       - create lash.spec (http://www.nongnu.org/lash) and
5 #         --enable-lash
6 #       - package doc and create audacity-plugin
7 #
8 # Conditional build:
9 %bcond_with     python  # build python bindings
10 #
11 Summary:        aubio is a library for audio labelling
12 Name:           aubio
13 Version:        0.3.2
14 Release:        0.1
15 License:        GPL v2+
16 Group:          Libraries
17 Source0:        http://aubio.piem.org/pub/%{name}-%{version}.tar.gz
18 # Source0-md5:  ffc3e5e4880fec67064f043252263a44
19 URL:            http://aubio.piem.org/
20 BuildRequires:  alsa-lib-devel
21 BuildRequires:  fftw3-single-devel
22 BuildRequires:  jack-audio-connection-kit-devel
23 BuildRequires:  libsamplerate-devel
24 BuildRequires:  libsndfile-devel
25 %if %{with python}
26 BuildRequires:  python-devel
27 BuildRequires:  swig-python
28 %endif
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 aubio is a library for audio labelling
33
34 %package devel
35 Summary:        Header files for aubio library
36 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki aubio
37 Group:          Development/Libraries
38 Requires:       %{name} = %{version}-%{release}
39
40 %description devel
41 Header files for aubio library.
42
43 %description devel -l pl.UTF-8
44 Pliki nagłówkowe biblioteki aubio.
45
46 %package static
47 Summary:        Static aubio library
48 Summary(pl.UTF-8):      Statyczna biblioteka aubio
49 Group:          Development/Libraries
50 Requires:       %{name}-devel = %{version}-%{release}
51
52 %description static
53 Static aubio library.
54
55 %description static -l pl.UTF-8
56 Statyczna biblioteka aubio.
57
58 %package progs
59 Summary:        Example applications using aubio library
60 Group:          Applications
61 Requires:       %{name} = %{version}-%{release}
62
63 %description progs
64 A few examples of applications using aubio library:
65 - aubioonset: outputs the onset detected
66 - aubionotes: uses both onset and pitch to extract symbolic music data
67     from an audio source and emit MIDI like data.
68 - aubiocut: a python script that takes an input sound and creates one
69     new sample at each detected onset or beat. The slices produced by
70     aubiocut are useful for use with a sequencer such as Hydrogen.
71 - aubiopitch: a python script to extract pitch tracks from sound files
72
73 %package -n python-aubio
74 Summary:        aubio python bindings
75 Group:          Libraries/Python
76 Requires:       %{name} = %{version}-%{release}
77
78 %description -n python-aubio
79 aubio python bindings.
80
81 %prep
82 %setup -q
83
84 %build
85 %configure \
86         --enable-alsa \
87         --enable-jack
88
89 %{__make}
90
91 %install
92 rm -rf $RPM_BUILD_ROOT
93
94 %{__make} install \
95         DESTDIR=$RPM_BUILD_ROOT
96
97 %clean
98 rm -rf $RPM_BUILD_ROOT
99
100 %post   -p /sbin/ldconfig
101 %postun -p /sbin/ldconfig
102
103 %files
104 %defattr(644,root,root,755)
105 %doc AUTHORS ChangeLog NEWS README THANKS TODO
106 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
107
108 %files devel
109 %defattr(644,root,root,755)
110 %attr(755,root,root) %{_libdir}/lib*.so
111 %{_libdir}/lib*.la
112 %{_includedir}/%{name}
113 %{_pkgconfigdir}/*.pc
114
115 %files static
116 %defattr(644,root,root,755)
117 %{_libdir}/lib*.a
118
119 %files progs
120 %defattr(644,root,root,755)
121 %attr(755,root,root) %{_bindir}/aubionotes
122 %attr(755,root,root) %{_bindir}/aubioonset
123 %attr(755,root,root) %{_bindir}/aubiotrack
124 %if %{with python}
125 %attr(755,root,root) %{_bindir}/aubiocut
126 %attr(755,root,root) %{_bindir}/aubiopitch
127 %endif
128
129 %files -n python-aubio
130 %defattr(644,root,root,755)
131 %{py_sitescriptdir}/aubio
This page took 0.080041 seconds and 3 git commands to generate.