]> git.pld-linux.org Git - packages/aubio.git/blob - aubio.spec
- fix building with ffmpeg 4.0
[packages/aubio.git] / aubio.spec
1 #
2 # Conditional build:
3 %bcond_without  python2  # python bindings
4 %bcond_without  python3  # python bindings
5 #
6 Summary:        aubio - library for audio labelling
7 Summary(pl.UTF-8):      aubio - biblioteka do oznaczania dźwięku
8 Name:           aubio
9 Version:        0.4.3
10 Release:        3
11 License:        GPL v3+
12 Group:          Libraries
13 Source0:        http://aubio.piem.org/pub/%{name}-%{version}.tar.bz2
14 # Source0-md5:  52a960cfc8a3e3125f3a258545d1c7e5
15 Patch0:         ffmpeg4.patch
16 URL:            http://aubio.piem.org/
17 BuildRequires:  alsa-lib-devel >= 0.9.0
18 BuildRequires:  doxygen
19 BuildRequires:  ffmpeg-devel
20 BuildRequires:  fftw3-single-devel >= 3.0.0
21 BuildRequires:  jack-audio-connection-kit-devel >= 0.15.0
22 BuildRequires:  libsamplerate-devel >= 0.0.15
23 BuildRequires:  libsndfile-devel >= 1.0.4
24 BuildRequires:  pkgconfig
25 BuildRequires:  txt2man
26 %if %{with python2} || %{with python3}
27 BuildRequires:  rpm-pythonprov
28 BuildRequires:  rpmbuild(macros) >= 1.714
29 %endif
30 %if %{with python2}
31 BuildRequires:  python-devel
32 BuildRequires:  python-numpy-devel
33 BuildRequires:  python-setuptools
34 %endif
35 %if %{with python3}
36 BuildRequires:  python3-devel
37 BuildRequires:  python3-numpy-devel
38 BuildRequires:  python3-setuptools
39 %endif
40 BuildRequires:  sed >= 4.0
41 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43 %description
44 aubio is a library for audio labelling.
45
46 %description -l pl.UTF-8
47 aubio to biblioteka do oznaczania dźwięku.
48
49 %package devel
50 Summary:        Header files for aubio library
51 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki aubio
52 Group:          Development/Libraries
53 Requires:       %{name} = %{version}-%{release}
54 Requires:       fftw3-single-devel >= 3.0.0
55 Requires:       libsamplerate-devel >= 0.0.15
56 # for libaubioext:
57 # alsa-lib-devel >= 0.9.0
58 # jack-audio-connection-kit-devel >= 0.15.0
59 # libsndfile-devel >= 1.0.4
60
61 %description devel
62 Header files for aubio library.
63
64 %description devel -l pl.UTF-8
65 Pliki nagłówkowe biblioteki aubio.
66
67 %package static
68 Summary:        Static aubio library
69 Summary(pl.UTF-8):      Statyczna biblioteka aubio
70 Group:          Development/Libraries
71 Requires:       %{name}-devel = %{version}-%{release}
72
73 %description static
74 Static aubio library.
75
76 %description static -l pl.UTF-8
77 Statyczna biblioteka aubio.
78
79 %package progs
80 Summary:        Example applications using aubio library
81 Summary(pl.UTF-8):      Przykładowe programy korzystajace z biblioteki aubio
82 Group:          Applications/Sound
83 Requires:       %{name} = %{version}-%{release}
84
85 %description progs
86 A few examples of applications using aubio library:
87 - aubioonset: outputs the onset detected.
88 - aubionotes: uses both onset and pitch to extract symbolic music data
89   from an audio source and emit MIDI like data.
90 - aubiocut: a Python script that takes an input sound and creates one
91   new sample at each detected onset or beat. The slices produced by
92   aubiocut are useful for use with a sequencer such as Hydrogen.
93 - aubiopitch: a Python script to extract pitch tracks from sound
94   files.
95
96 %description progs -l pl.UTF-8
97 Kilka przykładowych aplikacji korzystających z biblioteki dubio:
98 - aubioonset - wypisuje wykryty początek.
99 - aubionotes - wykorzystuje początek i wysokość do wyciągnięcia
100   symbolicznych danych muzycznych ze źródła dźwięku i stworzenia danych
101   typu MIDI.
102 - aubiocut - skrypt Pythona pobierający dźwięk wejściowy i tworzący
103   nową próbkę dla każdego wykrytego początku lub taktu. Fragmenty
104   tworzone przez aubiocut są przydatne do wykorzystania przez sekwencer,
105   jak np. Hydrogen.
106 - aubiopitch - skrypt Pythona do wyciągania ścieżek wysokości z plików
107   dźwiękowych.
108
109 %package -n python-aubio
110 Summary:        aubio Python bindings
111 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki aubio
112 Group:          Libraries/Python
113 Requires:       %{name} = %{version}-%{release}
114
115 %description -n python-aubio
116 aubio Python bindings.
117
118 %description -n python-aubio -l pl.UTF-8
119 Wiązania Pythona do biblioteki aubio.
120
121 %package -n python3-aubio
122 Summary:        aubio Python bindings
123 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki aubio
124 Group:          Libraries/Python
125 Requires:       %{name} = %{version}-%{release}
126
127 %description -n python3-aubio
128 aubio Python bindings.
129
130 %description -n python3-aubio -l pl.UTF-8
131 Wiązania Pythona do biblioteki aubio.
132
133 %prep
134 %setup -q
135 %patch0 -p1
136
137 %build
138 export CC="%{__cc}"
139 export CXX="%{__cxx}"
140 export CFLAGS="%{rpmcflags}"
141 export CXXFLAGS="%{rpmcxxflags}"
142 export LDFLAGS="%{rpmldflags}"
143 ./waf configure \
144         --prefix=%{_prefix} \
145         --libdir=%{_libdir} \
146         --libexecdir=%{_libexecdir} \
147         --enable-fftw3f \
148         --enable-jack \
149         --enable-sndfile \
150         --enable-avcodec \
151         --enable-samplerate \
152         --disable-atlas \
153         --enable-docs
154
155 ./waf build -v
156
157 %if %{with python2}
158 %py_build %{?with_tests:test}
159 %endif
160
161 %if %{with python3}
162 %py3_build %{?with_tests:test}
163 %endif
164
165 %install
166 rm -rf $RPM_BUILD_ROOT
167
168 ./waf install -v \
169         --destdir=$RPM_BUILD_ROOT \
170         --libdir=%{_libdir} \
171         --prefix=%{_prefix} \
172         --libexecdir=%{_libexecdir}
173
174 %if %{with python2}
175 %py_install
176 %endif
177
178 %if %{with python3}
179 %py3_install
180 %endif
181
182 rm -r $RPM_BUILD_ROOT%{_docdir}/libaubio-doc
183
184 %clean
185 rm -rf $RPM_BUILD_ROOT
186
187 %post   -p /sbin/ldconfig
188 %postun -p /sbin/ldconfig
189
190 %files
191 %defattr(644,root,root,755)
192 %doc AUTHORS ChangeLog README.md
193 %attr(755,root,root) %{_libdir}/libaubio.so.5.*.*
194 %attr(755,root,root) %ghost %{_libdir}/libaubio.so.5
195
196 %files devel
197 %defattr(644,root,root,755)
198 %doc doc/web/html/*
199 %attr(755,root,root) %{_libdir}/libaubio.so
200 %{_includedir}/%{name}
201 %{_pkgconfigdir}/aubio.pc
202
203 %files progs
204 %defattr(644,root,root,755)
205 %attr(755,root,root) %{_bindir}/aubiomfcc
206 %attr(755,root,root) %{_bindir}/aubionotes
207 %attr(755,root,root) %{_bindir}/aubioonset
208 %attr(755,root,root) %{_bindir}/aubiopitch
209 %attr(755,root,root) %{_bindir}/aubioquiet
210 %attr(755,root,root) %{_bindir}/aubiotrack
211 %{_mandir}/man1/aubiomfcc.1*
212 %{_mandir}/man1/aubionotes.1*
213 %{_mandir}/man1/aubioonset.1*
214 %{_mandir}/man1/aubiopitch.1*
215 %{_mandir}/man1/aubioquiet.1*
216 %{_mandir}/man1/aubiotrack.1*
217
218 %if %{with python2}
219 %files -n python-aubio
220 %defattr(644,root,root,755)
221 %dir %{py_sitedir}/aubio
222 %{py_sitedir}/aubio/*.py*
223 %attr(755,root,root) %{py_sitedir}/aubio/_aubio.so
224 %{py_sitedir}/aubio*.egg-info
225 %if %{without python3}
226 %attr(755,root,root) %{_bindir}/aubiocut
227 %{_mandir}/man1/aubiocut.1*
228 %endif
229 %endif
230
231 %if %{with python3}
232 %files -n python3-aubio
233 %defattr(644,root,root,755)
234 %dir %{py3_sitedir}/aubio
235 %{py3_sitedir}/aubio/__pycache__
236 %{py3_sitedir}/aubio/*.py
237 %attr(755,root,root) %{py3_sitedir}/aubio/_aubio.*.so
238 %{py3_sitedir}/aubio*.egg-info
239 %attr(755,root,root) %{_bindir}/aubiocut
240 %{_mandir}/man1/aubiocut.1*
241 %endif
This page took 0.100468 seconds and 3 git commands to generate.