]> git.pld-linux.org Git - packages/aubio.git/blob - aubio.spec
5aaee34abcfca0550a2f71e082c9ff985e7c3fe7
[packages/aubio.git] / aubio.spec
1 # TODO:
2 #       - create lash.spec (http://www.nongnu.org/lash) and
3 #         --enable-lash
4 #       - package doc and create audacity-plugin
5 #
6 # Conditional build:
7 %bcond_without  python  # python bindings
8 #
9 Summary:        aubio - library for audio labelling
10 Summary(pl.UTF-8):      aubio - biblioteka do oznaczania dźwięku
11 Name:           aubio
12 Version:        0.3.2
13 Release:        0.1
14 License:        GPL v2+
15 Group:          Libraries
16 Source0:        http://aubio.piem.org/pub/%{name}-%{version}.tar.gz
17 # Source0-md5:  ffc3e5e4880fec67064f043252263a44
18 Patch0:         %{name}-python.patch
19 URL:            http://aubio.piem.org/
20 BuildRequires:  alsa-lib-devel >= 0.9.0
21 BuildRequires:  autoconf >= 2.50
22 BuildRequires:  automake
23 BuildRequires:  fftw3-single-devel >= 3.0.0
24 BuildRequires:  jack-audio-connection-kit-devel >= 0.15.0
25 #BuildRequires: lash-devel >= 0.5.0 (lash-1.0.pc)
26 BuildRequires:  libsamplerate-devel >= 0.0.15
27 BuildRequires:  libsndfile-devel >= 1.0.4
28 BuildRequires:  libtool
29 BuildRequires:  pkgconfig
30 #BuildRequires: puredata-devel (m_pd.h)
31 %if %{with python}
32 BuildRequires:  python-devel
33 BuildRequires:  rpm-pythonprov
34 BuildRequires:  rpmbuild(macros) >= 1.219
35 BuildRequires:  swig-python
36 %endif
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %description
40 aubio is a library for audio labelling.
41
42 %description -l pl.UTF-8
43 aubio to biblioteka do oznaczania dźwięku.
44
45 %package devel
46 Summary:        Header files for aubio library
47 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki aubio
48 Group:          Development/Libraries
49 Requires:       %{name} = %{version}-%{release}
50 Requires:       fftw3-single-devel >= 3.0.0
51 Requires:       libsamplerate-devel >= 0.0.15
52 # for libaubioext:
53 # alsa-lib-devel >= 0.9.0
54 # jack-audio-connection-kit-devel >= 0.15.0
55 # libsndfile-devel >= 1.0.4
56
57 %description devel
58 Header files for aubio library.
59
60 %description devel -l pl.UTF-8
61 Pliki nagłówkowe biblioteki aubio.
62
63 %package static
64 Summary:        Static aubio library
65 Summary(pl.UTF-8):      Statyczna biblioteka aubio
66 Group:          Development/Libraries
67 Requires:       %{name}-devel = %{version}-%{release}
68
69 %description static
70 Static aubio library.
71
72 %description static -l pl.UTF-8
73 Statyczna biblioteka aubio.
74
75 %package progs
76 Summary:        Example applications using aubio library
77 Summary(pl.UTF-8):      Przykładowe programy korzystajace z biblioteki aubio
78 Group:          Applications/Sound
79 Requires:       %{name} = %{version}-%{release}
80
81 %description progs
82 A few examples of applications using aubio library:
83 - aubioonset: outputs the onset detected.
84 - aubionotes: uses both onset and pitch to extract symbolic music data
85     from an audio source and emit MIDI like data.
86 - aubiocut: a Python script that takes an input sound and creates one
87     new sample at each detected onset or beat. The slices produced by
88     aubiocut are useful for use with a sequencer such as Hydrogen.
89 - aubiopitch: a Python script to extract pitch tracks from sound
90   files.
91
92 %description progs -l pl.UTF-8
93 Kilka przykładowych aplikacji korzystających z biblioteki dubio:
94 - aubioonset - wypisuje wykryty początek.
95 - aubionotes - wykorzystuje początek i wysokość do wyciągnięcia
96   symbolicznych danych muzycznych ze źródła dźwięku i stworzenia
97   danych typu MIDI.
98 - aubiocut - skrypt Pythona pobierający dźwięk wejściowy i tworzący
99   nową próbkę dla każdego wykrytego początku lub taktu. Fragmenty
100   tworzone przez aubiocut są przydatne do wykorzystania przez
101   sekwencer, jak np. Hydrogen.
102 - aubiopitch - skrypt Pythona do wyciągania ścieżek wysokości z
103   plików dźwiękowych.
104
105 %package -n python-aubio
106 Summary:        aubio Python bindings
107 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki aubio
108 Group:          Libraries/Python
109 Requires:       %{name} = %{version}-%{release}
110
111 %description -n python-aubio
112 aubio Python bindings.
113
114 %description -n python-aubio -l pl.UTF-8
115 Wiązania Pythona do biblioteki aubio.
116
117 %prep
118 %setup -q
119 %patch0 -p1
120
121 %build
122 %{__libtoolize}
123 %{__aclocal}
124 %{__autoconf}
125 %{__autoheader}
126 %{__automake}
127 %configure \
128         --enable-alsa \
129         --enable-jack
130
131 %{__make}
132
133 %install
134 rm -rf $RPM_BUILD_ROOT
135
136 %{__make} install \
137         DESTDIR=$RPM_BUILD_ROOT
138
139 %py_postclean
140 rm -f $RPM_BUILD_ROOT%{py_sitedir}/aubio/_aubiowrapper.{la,a}
141
142 %clean
143 rm -rf $RPM_BUILD_ROOT
144
145 %post   -p /sbin/ldconfig
146 %postun -p /sbin/ldconfig
147
148 %files
149 %defattr(644,root,root,755)
150 %doc AUTHORS ChangeLog NEWS README THANKS TODO
151 %attr(755,root,root) %{_libdir}/libaubio.so.*.*.*
152 %attr(755,root,root) %{_libdir}/libaubioext.so.*.*.*
153
154 %files devel
155 %defattr(644,root,root,755)
156 %attr(755,root,root) %{_libdir}/libaubio.so
157 %attr(755,root,root) %{_libdir}/libaubioext.so
158 %{_libdir}/libaubio.la
159 %{_libdir}/libaubioext.la
160 %{_includedir}/%{name}
161 %{_pkgconfigdir}/aubio.pc
162
163 %files static
164 %defattr(644,root,root,755)
165 %{_libdir}/libaubio.a
166 %{_libdir}/libaubioext.a
167
168 %files progs
169 %defattr(644,root,root,755)
170 %attr(755,root,root) %{_bindir}/aubionotes
171 %attr(755,root,root) %{_bindir}/aubioonset
172 %attr(755,root,root) %{_bindir}/aubiotrack
173 %{_mandir}/man1/aubionotes.1*
174 %{_mandir}/man1/aubioonset.1*
175 %{_mandir}/man1/aubiotrack.1*
176 %{_datadir}/sounds/aubio
177
178 %if %{with python}
179 %files -n python-aubio
180 %defattr(644,root,root,755)
181 %dir %{py_sitedir}/aubio
182 %attr(755,root,root) %{py_sitedir}/aubio/_aubiowrapper.so
183 %{py_sitescriptdir}/aubio
184 # examples
185 %attr(755,root,root) %{_bindir}/aubiocut
186 %attr(755,root,root) %{_bindir}/aubiopitch
187 %{_mandir}/man1/aubiocut.1*
188 %{_mandir}/man1/aubiopitch.1*
189 %endif
This page took 0.071585 seconds and 2 git commands to generate.