]> git.pld-linux.org Git - packages/attr.git/blob - attr.spec
- xfsprogs-devel is no longer BRed
[packages/attr.git] / attr.spec
1 Summary:        Utility for managing filesystem extended attributes
2 Summary(pl):    Narzêdzia do zarz±dzania rozszerzonymi atrybutami systemu plików
3 Name:           attr
4 Version:        2.4.16
5 Release:        1
6 # most part is on LGPL v2.1, but the rest enforces GPL
7 License:        GPL
8 Group:          Applications/System
9 Source0:        ftp://linux-xfs.sgi.com/projects/xfs/download/cmd_tars/%{name}-%{version}.src.tar.gz
10 # Source0-md5:  13ba7836876882da53b2c1eab5ab66bc
11 Patch0:         %{name}-miscfix.patch
12 Patch1:         %{name}-po.patch
13 URL:            http://oss.sgi.com/projects/xfs/
14 BuildRequires:  autoconf
15 BuildRequires:  automake
16 BuildRequires:  gettext-devel
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %define         _bindir         /bin
20 %define         _libdir         /%{_lib}
21 %define         _libexecdir     /usr/%{_lib}
22
23 %description
24 An experimental attr command to manipulate extended attributes under
25 Linux.
26
27 %description -l pl
28 Eksperymentalna wersja polecenia attr to zarz±dzania rozszerzonymi
29 atrybutami pod systemem Linux.
30
31 %package devel
32 Summary:        Header files and libraries to use extended attributes
33 Summary(pl):    Pliki nag³ówkowe i biblioteki do korzystania z rozszerzonych atrybutów
34 Group:          Development/Libraries
35 Requires:       %{name} = %{version}-%{release}
36
37 %description devel
38 Header files to develop software which manipulate extended attributes.
39
40 %description devel -l pl
41 Pliki nag³ówkowe potrzebne do tworzenia oprogramowania manipuluj±cego
42 rozszerzonymi atrybutami.
43
44 %package static
45 Summary:        Static libraries for extended attributes
46 Summary(pl):    Biblioteki statyczne do korzystania z rozszerzonych atrybutów
47 Group:          Development/Libraries
48 Requires:       %{name}-devel = %{version}-%{release}
49
50 %description static
51 Static libraries for extended attributes.
52
53 %description static -l pl
54 Biblioteki statyczne do korzystania z rozszerzonych atrybutów.
55
56 %prep
57 %setup -q
58 %patch0 -p1
59 %patch1 -p1
60
61 %build
62 rm -f aclocal.m4
63 %{__aclocal} -I m4
64 %{__autoconf}
65 %configure \
66         DEBUG="%{?debug:-DDEBUG}%{!?debug:-DNDEBUG}" \
67         OPTIMIZER="%{rpmcflags} -DENABLE_GETTEXT"
68
69 %{__make}
70
71 %install
72 rm -rf $RPM_BUILD_ROOT
73
74 DIST_ROOT=$RPM_BUILD_ROOT
75 DIST_INSTALL=`pwd`/install.manifest
76 DIST_INSTALL_DEV=`pwd`/install-dev.manifest
77 DIST_INSTALL_LIB=`pwd`/install-lib.manifest
78 export DIST_ROOT DIST_INSTALL DIST_INSTALL_DEV DIST_INSTALL_LIB
79
80 %{__make} install \
81         DIST_MANIFEST=$DIST_INSTALL
82 %{__make} install-dev \
83         DIST_MANIFEST=$DIST_INSTALL_DEV
84 %{__make} install-lib \
85         DIST_MANIFEST=$DIST_INSTALL_LIB
86
87 rm -f   $RPM_BUILD_ROOT%{_mandir}/man3/{attr_getf,attr_listf}.3
88 rm -f   $RPM_BUILD_ROOT%{_mandir}/man3/{attr_multif,attr_removef,attr_setf}.3
89 rm -rf  $RPM_BUILD_ROOT%{_mandir}/man2
90
91 ln -sf %{_libdir}/$(cd $RPM_BUILD_ROOT%{_libdir} ; echo libattr.so.*.*.*) \
92          $RPM_BUILD_ROOT%{_libexecdir}/libattr.so
93
94 echo ".so attr_get.3"   > $RPM_BUILD_ROOT%{_mandir}/man3/attr_getf.3
95 echo ".so attr_list.3"  > $RPM_BUILD_ROOT%{_mandir}/man3/attr_listf.3
96 echo ".so attr_multi.3" > $RPM_BUILD_ROOT%{_mandir}/man3/attr_multif.3
97 echo ".so attr_remove.3" > $RPM_BUILD_ROOT%{_mandir}/man3/attr_removef.3
98 echo ".so attr_set.3"   > $RPM_BUILD_ROOT%{_mandir}/man3/attr_setf.3
99
100 %find_lang %{name}
101
102 %clean
103 rm -rf $RPM_BUILD_ROOT
104
105 %post   -p /sbin/ldconfig
106 %postun -p /sbin/ldconfig
107
108 %files -f %{name}.lang
109 %defattr(644,root,root,755)
110 %doc README doc/CHANGES
111 %attr(755,root,root) %{_bindir}/*
112 %attr(755,root,root) %{_libdir}/lib*.so.*.*
113 %{_mandir}/man[158]/*
114
115 %files devel
116 %defattr(644,root,root,755)
117 %{_libexecdir}/lib*.la
118 %attr(755,root,root) %{_libexecdir}/lib*.so
119 %{_includedir}/attr
120 %{_mandir}/man3/*
121
122 %files static
123 %defattr(644,root,root,755)
124 %{_libexecdir}/lib*.a
This page took 0.070919 seconds and 4 git commands to generate.