]> git.pld-linux.org Git - packages/attr.git/blob - attr.spec
- updated to 2.4.19, updated miscfix patch
[packages/attr.git] / attr.spec
1 Summary:        Utility for managing filesystem extended attributes
2 Summary(pl):    Narzêdzia do zarz±dzania rozszerzonymi atrybutami systemu plików
3 Name:           attr
4 Version:        2.4.19
5 Release:        1
6 # most part is on LGPL v2.1, but the rest enforces GPL
7 License:        GPL
8 Group:          Applications/System
9 Source0:        ftp://linux-xfs.sgi.com/projects/xfs/download/cmd_tars/%{name}-%{version}.src.tar.gz
10 # Source0-md5:  0ea0d3bea5a58727eafd46fa1c0f09cc
11 Patch0:         %{name}-miscfix.patch
12 Patch1:         %{name}-po.patch
13 URL:            http://oss.sgi.com/projects/xfs/
14 BuildRequires:  autoconf
15 BuildRequires:  automake
16 BuildRequires:  gettext-devel
17 BuildRequires:  sed >= 4.1.1-1  
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %define         _bindir         /bin
21 %define         _libdir         /%{_lib}
22 %define         _libexecdir     /usr/%{_lib}
23
24 %description
25 An experimental attr command to manipulate extended attributes under
26 Linux.
27
28 %description -l pl
29 Eksperymentalna wersja polecenia attr to zarz±dzania rozszerzonymi
30 atrybutami pod systemem Linux.
31
32 %package devel
33 Summary:        Header files and libraries to use extended attributes
34 Summary(pl):    Pliki nag³ówkowe i biblioteki do korzystania z rozszerzonych atrybutów
35 Group:          Development/Libraries
36 Requires:       %{name} = %{version}-%{release}
37
38 %description devel
39 Header files to develop software which manipulate extended attributes.
40
41 %description devel -l pl
42 Pliki nag³ówkowe potrzebne do tworzenia oprogramowania manipuluj±cego
43 rozszerzonymi atrybutami.
44
45 %package static
46 Summary:        Static libraries for extended attributes
47 Summary(pl):    Biblioteki statyczne do korzystania z rozszerzonych atrybutów
48 Group:          Development/Libraries
49 Requires:       %{name}-devel = %{version}-%{release}
50
51 %description static
52 Static libraries for extended attributes.
53
54 %description static -l pl
55 Biblioteki statyczne do korzystania z rozszerzonych atrybutów.
56
57 %prep
58 %setup -q
59 %patch0 -p1
60 %patch1 -p1
61
62 %build
63 rm -f aclocal.m4
64 %{__aclocal} -I m4
65 %{__autoconf}
66 %configure \
67         DEBUG="%{?debug:-DDEBUG}%{!?debug:-DNDEBUG}" \
68         OPTIMIZER="%{rpmcflags} -DENABLE_GETTEXT"
69
70 %{__make}
71
72 %install
73 rm -rf $RPM_BUILD_ROOT
74
75 DIST_ROOT=$RPM_BUILD_ROOT
76 DIST_INSTALL=`pwd`/install.manifest
77 DIST_INSTALL_DEV=`pwd`/install-dev.manifest
78 DIST_INSTALL_LIB=`pwd`/install-lib.manifest
79 export DIST_ROOT DIST_INSTALL DIST_INSTALL_DEV DIST_INSTALL_LIB
80
81 %{__make} install \
82         DIST_MANIFEST=$DIST_INSTALL
83 %{__make} install-dev \
84         DIST_MANIFEST=$DIST_INSTALL_DEV
85 %{__make} install-lib \
86         DIST_MANIFEST=$DIST_INSTALL_LIB
87
88 rm -f   $RPM_BUILD_ROOT%{_mandir}/man3/{attr_getf,attr_listf}.3
89 rm -f   $RPM_BUILD_ROOT%{_mandir}/man3/{attr_multif,attr_removef,attr_setf}.3
90 rm -rf  $RPM_BUILD_ROOT%{_mandir}/man2
91
92 ln -sf %{_libdir}/$(cd $RPM_BUILD_ROOT%{_libdir} ; echo libattr.so.*.*.*) \
93          $RPM_BUILD_ROOT%{_libexecdir}/libattr.so
94
95 %{__sed} -i "s|libdir='%{_libdir}'|libdir='%{_libexecdir}'|" \
96         $RPM_BUILD_ROOT%{_libexecdir}/libattr.la
97
98 echo ".so attr_get.3"   > $RPM_BUILD_ROOT%{_mandir}/man3/attr_getf.3
99 echo ".so attr_list.3"  > $RPM_BUILD_ROOT%{_mandir}/man3/attr_listf.3
100 echo ".so attr_multi.3" > $RPM_BUILD_ROOT%{_mandir}/man3/attr_multif.3
101 echo ".so attr_remove.3" > $RPM_BUILD_ROOT%{_mandir}/man3/attr_removef.3
102 echo ".so attr_set.3"   > $RPM_BUILD_ROOT%{_mandir}/man3/attr_setf.3
103
104 %find_lang %{name}
105
106 %clean
107 rm -rf $RPM_BUILD_ROOT
108
109 %post   -p /sbin/ldconfig
110 %postun -p /sbin/ldconfig
111
112 %files -f %{name}.lang
113 %defattr(644,root,root,755)
114 %doc README doc/CHANGES
115 %attr(755,root,root) %{_bindir}/*
116 %attr(755,root,root) %{_libdir}/lib*.so.*.*
117 %{_mandir}/man[158]/*
118
119 %files devel
120 %defattr(644,root,root,755)
121 %{_libexecdir}/lib*.la
122 %attr(755,root,root) %{_libexecdir}/lib*.so
123 %{_includedir}/attr
124 %{_mandir}/man3/*
125
126 %files static
127 %defattr(644,root,root,755)
128 %{_libexecdir}/lib*.a
This page took 0.088889 seconds and 4 git commands to generate.