]> git.pld-linux.org Git - packages/attr.git/blob - attr.spec
- massive attack, adding Source-md5
[packages/attr.git] / attr.spec
1 Summary:        Utility for managing filesystem extended attributes
2 Summary(pl):    Narzêdzia do zarz±dzania rozszerzonymi atrybutami fs
3 Name:           attr
4 Version:        2.4.1
5 Release:        3
6 # most part is on LGPL v2.1, but the rest enforces GPL
7 License:        GPL
8 Group:          Applications/System
9 Source0:        ftp://linux-xfs.sgi.com/projects/xfs/download/cmd_tars/%{name}-%{version}.src.tar.gz
10 # Source0-md5: 1cd48b80889ffb033f53e63e66014071
11 Patch0:         %{name}-miscfix.patch
12 URL:            http://oss.sgi.com/projects/xfs/
13 BuildRequires:  autoconf
14 BuildRequires:  e2fsprogs-devel
15 BuildRequires:  xfsprogs-devel >= 2.0.0
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %define         _bindir         /bin
19 %define         _libdir         /lib
20 %define         _libexecdir     /usr/lib
21
22 %description
23 An experimental attr command to manipulate extended attributes under
24 Linux.
25
26 %description -l pl
27 Eksperymentalna wersja polecenia attr to zarz±dzania rozszerzonymi
28 atrybutami pod systemem Linux.
29
30 %package devel
31 Summary:        Header files and libraries to use extended attributes
32 Summary(pl):    Pliki nag³ówkowe i biblioteki
33 Group:          Development/Libraries
34 Requires:       %{name} = %{version}
35
36 %description devel
37 Header files to develop software which manipulate extended attributes.
38
39 %description devel -l pl
40 Pliki nag³ówkowe potrzebne do tworzenia oprogramowania manipuluj±cego
41 rozszerzonymi atrybutami.
42
43 %package static
44 Summary:        Static libraries for extended attributes
45 Summary(pl):    Biblioteki statyczne attr
46 Group:          Development/Libraries
47 Requires:       %{name}-devel = %{version}
48
49 %description static
50 Static libraries for extended attributes.
51
52 %description static -l pl
53 Biblioteki statyczne attr.
54
55 %prep
56 %setup  -q
57 %patch0 -p1
58
59 %build
60 DEBUG="%{?debug:-DDEBUG}%{!?debug:-DNDEBUG}"; export DEBUG
61 %{__autoconf}
62 %configure
63
64 %{__make}
65
66 %install
67 rm -rf $RPM_BUILD_ROOT
68
69 DIST_ROOT="$RPM_BUILD_ROOT"
70 DIST_INSTALL=`pwd`/install.manifest
71 DIST_INSTALL_DEV=`pwd`/install-dev.manifest
72 DIST_INSTALL_LIB=`pwd`/install-lib.manifest
73 export DIST_ROOT DIST_INSTALL DIST_INSTALL_DEV DIST_INSTALL_LIB
74
75 %{__make} install DIST_MANIFEST="$DIST_INSTALL"
76 %{__make} install-dev DIST_MANIFEST="$DIST_INSTALL_DEV"
77 %{__make} install-lib DIST_MANIFEST="$DIST_INSTALL_LIB"
78
79 rm -f   $RPM_BUILD_ROOT%{_mandir}/man3/{attr_getf,attr_listf}.3
80 rm -f   $RPM_BUILD_ROOT%{_mandir}/man3/{attr_multif,attr_removef,attr_setf}.3
81 rm -rf  $RPM_BUILD_ROOT%{_mandir}/man2
82
83 ln -sf %{_libdir}/$(cd $RPM_BUILD_ROOT/lib ; echo libattr.so.*.*.*) \
84          $RPM_BUILD_ROOT%{_libexecdir}/libattr.so
85
86 echo ".so attr_get.3"   > $RPM_BUILD_ROOT%{_mandir}/man3/attr_getf.3
87 echo ".so attr_list.3"  > $RPM_BUILD_ROOT%{_mandir}/man3/attr_listf.3
88 echo ".so attr_multi.3" > $RPM_BUILD_ROOT%{_mandir}/man3/attr_multif.3
89 echo ".so attr_remove.3" > $RPM_BUILD_ROOT%{_mandir}/man3/attr_removef.3
90 echo ".so attr_set.3"   > $RPM_BUILD_ROOT%{_mandir}/man3/attr_setf.3
91
92 %find_lang %{name}
93
94 %clean
95 rm -rf $RPM_BUILD_ROOT
96
97 %post   -p /sbin/ldconfig
98 %postun -p /sbin/ldconfig
99
100 %files -f %{name}.lang
101 %defattr(644,root,root,755)
102 %doc README doc/CHANGES
103 %attr(755,root,root) %{_bindir}/*
104 %attr(755,root,root) %{_libdir}/lib*.so.*.*
105 %{_mandir}/man[158]/*
106
107 %files devel
108 %defattr(644,root,root,755)
109 %{_libexecdir}/lib*.la
110 %attr(755,root,root) %{_libexecdir}/lib*.so
111 %{_includedir}/attr
112 %{_mandir}/man3/*
113
114 %files static
115 %defattr(644,root,root,755)
116 %{_libexecdir}/lib*.a
This page took 0.098263 seconds and 4 git commands to generate.