]> git.pld-linux.org Git - packages/attr.git/blob - attr.spec
- removed all Group fields translations (oure rpm now can handle translating
[packages/attr.git] / attr.spec
1 Summary:        Utility for managing filesystem extended attributes
2 Summary(pl):    Narzêdzia do zarz±dzania rozszerzonymi atrybutami fs
3 Name:           attr
4 Version:        1.1.4
5 Release:        1
6 License:        GPL
7 Group:          Applications/System
8 Source0:        ftp://linux-xfs.sgi.com/projects/xfs/download/cmd_tars/%{name}-%{version}.src.tar.gz
9 Patch0:         %{name}-miscfix.patch
10 URL:            http://oss.sgi.com/projects/xfs/
11 BuildRequires:  autoconf
12 BuildRequires:  e2fsprogs-devel
13 BuildRequires:  xfsprogs-devel
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %define         _bindir         /bin
17
18 %description
19 An *experimental* command (attr) to manipulate extended attributes
20 under Linux.
21
22 %description -l pl
23 *Eksperymentalna* komenda (attr) to zarz±dzania rozszerzonymi
24 atrybutami pod systemem Linux.
25
26 %package devel
27 Summary:        Header files and libraries to use extended attributes
28 Summary(pl):    Pliki nag³ówkowe i biblioteki
29 Group:          Development/Libraries
30
31 %description devel
32 Header files and libraries to develop software which manipulate
33 extended attributes.
34
35 %description -l pl devel
36 Pliki nag³ówkowe i biblioteki potrzebne do rozwoju oprogramowania
37 manipuluj±cego rozszerzonymi atrybutami.
38
39 %prep
40 %setup  -q
41 %patch0 -p1
42
43 %build
44 DEBUG="%{?debug:-DDEBUG}%{!?debug:-DNDEBUG}"; export DEBUG
45 autoconf
46 %configure 
47
48 %{__make}
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52
53 DIST_ROOT="$RPM_BUILD_ROOT"
54 DIST_INSTALL=`pwd`/install.manifest
55 DIST_INSTALL_DEV=`pwd`/install-dev.manifest
56 export DIST_ROOT DIST_INSTALL DIST_INSTALL_DEV 
57 %{__make} install DIST_MANIFEST="$DIST_INSTALL"
58 %{__make} install-dev DIST_MANIFEST="$DIST_INSTALL_DEV"
59
60 rm -f   $RPM_BUILD_ROOT%{_mandir}/man3/{attr_getf,attr_listf}.3
61 rm -f   $RPM_BUILD_ROOT%{_mandir}/man3/{attr_multif,attr_removef,attr_setf}.3
62
63 rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.so
64 ln -sf /lib/libattr.so.0.0.0 $RPM_BUILD_ROOT%{_libdir}/libattr.so
65
66 echo ".so man3/attr_get.3"      > $RPM_BUILD_ROOT%{_mandir}/man3/attr_getf.3
67 echo ".so man3/attr_list.3"     > $RPM_BUILD_ROOT%{_mandir}/man3/attr_listf.3
68 echo ".so man3/attr_multi.3"    > $RPM_BUILD_ROOT%{_mandir}/man3/attr_multif.3
69 echo ".so man3/attr_remove.3"   > $RPM_BUILD_ROOT%{_mandir}/man3/attr_removef.3
70 echo ".so man3/attr_set.3"      > $RPM_BUILD_ROOT%{_mandir}/man3/attr_setf.3
71
72 gzip -9nf doc/CHANGES
73
74 %clean
75 rm -rf $RPM_BUILD_ROOT
76
77 %post -p /sbin/ldconfig
78 %postun -p /sbin/ldconfig
79
80 %files
81 %defattr(644,root,root,755)
82 %doc doc/*.gz
83 %attr(755,root,root) %{_bindir}/*
84 %attr(755,root,root) /lib/lib*.so.*.*
85 %{_mandir}/man[18]/*
86
87 %files devel
88 %defattr(644,root,root,755)
89 %attr(755,root,root) %{_libdir}/lib*.la
90 %attr(755,root,root) %{_libdir}/lib*.so
91 %{_libdir}/lib*.a
92 %{_includedir}/attr
93 %{_mandir}/man[23]/*
This page took 0.046701 seconds and 4 git commands to generate.