]> git.pld-linux.org Git - packages/attr.git/blob - attr.spec
- shared lib fix
[packages/attr.git] / attr.spec
1 Summary:        Utility for managing filesystem extended attributes
2 Summary(pl):    Narzêdzia do zarz±dzania rozszerzonymi atrybutami fs
3 Name:           attr
4 Version:        1.1.3
5 Release:        1
6 License:        GPL
7 Group:          Applications/System
8 Group(de):      Applikationen/System
9 Group(pl):      Aplikacje/System
10 Source0:        ftp://linux-xfs.sgi.com/projects/xfs/download/cmd_tars/%{name}-%{version}.src.tar.gz
11 Patch0:         %{name}-miscfix.patch
12 URL:            http://oss.sgi.com/projects/xfs/
13 BuildRequires:  autoconf
14 BuildRequires:  e2fsprogs-devel
15 BuildRequires:  xfsprogs-devel
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %define         _bindir         /bin
19
20 %description
21 An *experimental* command (attr) to manipulate extended attributes
22 under Linux.
23
24 %description -l pl
25 *Eksperymentalna* komenda (attr) to zarz±dzania rozszerzonymi
26 atrybutami pod systemem Linux.
27
28 %package devel
29 Summary:        Header files and libraries to use extended attributes
30 Summary(pl):    Pliki nag³ówkowe i biblioteki
31 Group:          Development/Libraries
32 Group(de):      Entwicklung/Libraries
33 Group(fr):      Development/Librairies
34 Group(pl):      Programowanie/Biblioteki
35
36 %description devel
37 Header files and libraries to develop software which manipulate
38 extended attributes.
39
40 %description -l pl devel
41 Pliki nag³ówkowe i biblioteki potrzebne do rozwoju oprogramowania
42 manipuluj±cego rozszerzonymi atrybutami.
43
44 %prep
45 %setup  -q
46 %patch0 -p1
47
48 %build
49 DEBUG="%{?debug:-DDEBUG}%{!?debug:-DNDEBUG}"; export DEBUG
50 autoconf
51 %configure 
52
53 %{__make}
54
55 %install
56 rm -rf $RPM_BUILD_ROOT
57
58 DIST_ROOT="$RPM_BUILD_ROOT"
59 DIST_INSTALL=`pwd`/install.manifest
60 DIST_INSTALL_DEV=`pwd`/install-dev.manifest
61 export DIST_ROOT DIST_INSTALL DIST_INSTALL_DEV 
62 %{__make} install DIST_MANIFEST="$DIST_INSTALL"
63 %{__make} install-dev DIST_MANIFEST="$DIST_INSTALL_DEV"
64
65 rm -f   $RPM_BUILD_ROOT%{_mandir}/man3/{attr_getf,attr_listf}.3
66 rm -f   $RPM_BUILD_ROOT%{_mandir}/man3/{attr_multif,attr_removef,attr_setf}.3
67
68 rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.so
69 ln -sf /lib/libattr.so.* $RPM_BUILD_ROOT%{_libdir}/libattr.so
70
71 echo ".so man3/attr_get.3"      > $RPM_BUILD_ROOT%{_mandir}/man3/attr_getf.3
72 echo ".so man3/attr_list.3"     > $RPM_BUILD_ROOT%{_mandir}/man3/attr_listf.3
73 echo ".so man3/attr_multi.3"    > $RPM_BUILD_ROOT%{_mandir}/man3/attr_multif.3
74 echo ".so man3/attr_remove.3"   > $RPM_BUILD_ROOT%{_mandir}/man3/attr_removef.3
75 echo ".so man3/attr_set.3"      > $RPM_BUILD_ROOT%{_mandir}/man3/attr_setf.3
76
77 gzip -9nf doc/CHANGES
78
79 %clean
80 rm -rf $RPM_BUILD_ROOT
81
82 %files
83 %defattr(644,root,root,755)
84 %doc doc/*.gz
85 %attr(755,root,root) %{_bindir}/*
86 %attr(755,root,root) /lib/lib*.so.*.*
87 %{_mandir}/man[18]/*
88
89 %files devel
90 %defattr(644,root,root,755)
91 %attr(755,root,root) %{_libdir}/lib*.la
92 %attr(755,root,root) %{_libdir}/lib*.so
93 %{_libdir}/lib*.a
94 %{_includedir}/attr
95 %{_mandir}/man[23]/*
This page took 0.030567 seconds and 4 git commands to generate.