]> git.pld-linux.org Git - packages/attr.git/blob - attr.spec
- man2 pages are in man-pages now (these are pure Linux/new glibc calls)
[packages/attr.git] / attr.spec
1 Summary:        Utility for managing filesystem extended attributes
2 Summary(pl):    Narzêdzia do zarz±dzania rozszerzonymi atrybutami fs
3 Name:           attr
4 Version:        2.2.0
5 Release:        2
6 License:        GPL
7 Group:          Applications/System
8 Source0:        ftp://linux-xfs.sgi.com/projects/xfs/download/cmd_tars/%{name}-%{version}.src.tar.gz
9 Patch0:         %{name}-miscfix.patch
10 URL:            http://oss.sgi.com/projects/xfs/
11 BuildRequires:  autoconf
12 BuildRequires:  e2fsprogs-devel
13 BuildRequires:  xfsprogs-devel >= 2.0.0
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %define         _bindir         /bin
17 %define         _libdir         /lib
18 %define         _libexecdir     /usr/lib
19
20 %description
21 An experimental attr command to manipulate extended attributes under
22 Linux.
23
24 %description -l pl
25 Eksperymentalna wersja polecenia attr to zarz±dzania rozszerzonymi
26 atrybutami pod systemem Linux.
27
28 %package devel
29 Summary:        Header files and libraries to use extended attributes
30 Summary(pl):    Pliki nag³ówkowe i biblioteki
31 Group:          Development/Libraries
32 Requires:       %{name} = %{version}
33
34 %description devel
35 Header files to develop software which manipulate extended attributes.
36
37 %description devel -l pl
38 Pliki nag³ówkowe potrzebne do tworzenia oprogramowania manipuluj±cego
39 rozszerzonymi atrybutami.
40
41 %package static
42 Summary:        Static libraries for extended attributes
43 Summary(pl):    Biblioteki statyczne attr
44 Group:          Development/Libraries
45 Requires:       %{name}-devel = %{version}
46
47 %description static
48 Static libraries for extended attributes.
49
50 %description static -l pl
51 Biblioteki statyczne attr.
52
53 %prep
54 %setup  -q
55 %patch0 -p1
56
57 %build
58 DEBUG="%{?debug:-DDEBUG}%{!?debug:-DNDEBUG}"; export DEBUG
59 %{__autoconf}
60 %configure
61
62 %{__make}
63
64 %install
65 rm -rf $RPM_BUILD_ROOT
66
67 DIST_ROOT="$RPM_BUILD_ROOT"
68 DIST_INSTALL=`pwd`/install.manifest
69 DIST_INSTALL_DEV=`pwd`/install-dev.manifest
70 DIST_INSTALL_LIB=`pwd`/install-lib.manifest
71 export DIST_ROOT DIST_INSTALL DIST_INSTALL_DEV DIST_INSTALL_LIB
72
73 %{__make} install DIST_MANIFEST="$DIST_INSTALL"
74 %{__make} install-dev DIST_MANIFEST="$DIST_INSTALL_DEV"
75 %{__make} install-lib DIST_MANIFEST="$DIST_INSTALL_LIB"
76
77 rm -f   $RPM_BUILD_ROOT%{_mandir}/man3/{attr_getf,attr_listf}.3
78 rm -f   $RPM_BUILD_ROOT%{_mandir}/man3/{attr_multif,attr_removef,attr_setf}.3
79 rm -rf  $RPM_BUILD_ROOT%{_mandir}/man2
80
81 ln -sf %{_libdir}/libattr.so.1.0.1 $RPM_BUILD_ROOT%{_libexecdir}/libattr.so
82
83 echo ".so attr_get.3"   > $RPM_BUILD_ROOT%{_mandir}/man3/attr_getf.3
84 echo ".so attr_list.3"  > $RPM_BUILD_ROOT%{_mandir}/man3/attr_listf.3
85 echo ".so attr_multi.3" > $RPM_BUILD_ROOT%{_mandir}/man3/attr_multif.3
86 echo ".so attr_remove.3" > $RPM_BUILD_ROOT%{_mandir}/man3/attr_removef.3
87 echo ".so attr_set.3"   > $RPM_BUILD_ROOT%{_mandir}/man3/attr_setf.3
88
89 %find_lang %{name}
90
91 %clean
92 rm -rf $RPM_BUILD_ROOT
93
94 %post   -p /sbin/ldconfig
95 %postun -p /sbin/ldconfig
96
97 %files -f %{name}.lang
98 %defattr(644,root,root,755)
99 %doc doc/CHANGES
100 %attr(755,root,root) %{_bindir}/*
101 %attr(755,root,root) %{_libdir}/lib*.so.*.*
102 %{_mandir}/man[18]/*
103
104 %files devel
105 %defattr(644,root,root,755)
106 %{_libexecdir}/lib*.la
107 %attr(755,root,root) %{_libexecdir}/lib*.so
108 %{_includedir}/attr
109 %{_mandir}/man[35]/*
110
111 %files static
112 %defattr(644,root,root,755)
113 %{_libexecdir}/lib*.a
This page took 0.035646 seconds and 4 git commands to generate.