]> git.pld-linux.org Git - packages/attr.git/blob - attr.spec
- autodetect libattr filename when creating libattr.so symlink
[packages/attr.git] / attr.spec
1 Summary:        Utility for managing filesystem extended attributes
2 Summary(pl):    Narzêdzia do zarz±dzania rozszerzonymi atrybutami fs
3 Name:           attr
4 Version:        2.4.1
5 Release:        2
6 # most part is on LGPL v2.1, but the rest enforces GPL
7 License:        GPL
8 Group:          Applications/System
9 Source0:        ftp://linux-xfs.sgi.com/projects/xfs/download/cmd_tars/%{name}-%{version}.src.tar.gz
10 Patch0:         %{name}-miscfix.patch
11 URL:            http://oss.sgi.com/projects/xfs/
12 BuildRequires:  autoconf
13 BuildRequires:  e2fsprogs-devel
14 BuildRequires:  xfsprogs-devel >= 2.0.0
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 %define         _bindir         /bin
18 %define         _libdir         /lib
19 %define         _libexecdir     /usr/lib
20
21 %description
22 An experimental attr command to manipulate extended attributes under
23 Linux.
24
25 %description -l pl
26 Eksperymentalna wersja polecenia attr to zarz±dzania rozszerzonymi
27 atrybutami pod systemem Linux.
28
29 %package devel
30 Summary:        Header files and libraries to use extended attributes
31 Summary(pl):    Pliki nag³ówkowe i biblioteki
32 Group:          Development/Libraries
33 Requires:       %{name} = %{version}
34
35 %description devel
36 Header files to develop software which manipulate extended attributes.
37
38 %description devel -l pl
39 Pliki nag³ówkowe potrzebne do tworzenia oprogramowania manipuluj±cego
40 rozszerzonymi atrybutami.
41
42 %package static
43 Summary:        Static libraries for extended attributes
44 Summary(pl):    Biblioteki statyczne attr
45 Group:          Development/Libraries
46 Requires:       %{name}-devel = %{version}
47
48 %description static
49 Static libraries for extended attributes.
50
51 %description static -l pl
52 Biblioteki statyczne attr.
53
54 %prep
55 %setup  -q
56 %patch0 -p1
57
58 %build
59 DEBUG="%{?debug:-DDEBUG}%{!?debug:-DNDEBUG}"; export DEBUG
60 %{__autoconf}
61 %configure
62
63 %{__make}
64
65 %install
66 rm -rf $RPM_BUILD_ROOT
67
68 DIST_ROOT="$RPM_BUILD_ROOT"
69 DIST_INSTALL=`pwd`/install.manifest
70 DIST_INSTALL_DEV=`pwd`/install-dev.manifest
71 DIST_INSTALL_LIB=`pwd`/install-lib.manifest
72 export DIST_ROOT DIST_INSTALL DIST_INSTALL_DEV DIST_INSTALL_LIB
73
74 %{__make} install DIST_MANIFEST="$DIST_INSTALL"
75 %{__make} install-dev DIST_MANIFEST="$DIST_INSTALL_DEV"
76 %{__make} install-lib DIST_MANIFEST="$DIST_INSTALL_LIB"
77
78 rm -f   $RPM_BUILD_ROOT%{_mandir}/man3/{attr_getf,attr_listf}.3
79 rm -f   $RPM_BUILD_ROOT%{_mandir}/man3/{attr_multif,attr_removef,attr_setf}.3
80 rm -rf  $RPM_BUILD_ROOT%{_mandir}/man2
81
82 ln -sf %{_libdir}/$(cd $RPM_BUILD_ROOT/lib ; echo libattr.so.*.*.*) \
83          $RPM_BUILD_ROOT%{_libexecdir}/libattr.so
84
85 echo ".so attr_get.3"   > $RPM_BUILD_ROOT%{_mandir}/man3/attr_getf.3
86 echo ".so attr_list.3"  > $RPM_BUILD_ROOT%{_mandir}/man3/attr_listf.3
87 echo ".so attr_multi.3" > $RPM_BUILD_ROOT%{_mandir}/man3/attr_multif.3
88 echo ".so attr_remove.3" > $RPM_BUILD_ROOT%{_mandir}/man3/attr_removef.3
89 echo ".so attr_set.3"   > $RPM_BUILD_ROOT%{_mandir}/man3/attr_setf.3
90
91 %find_lang %{name}
92
93 %clean
94 rm -rf $RPM_BUILD_ROOT
95
96 %post   -p /sbin/ldconfig
97 %postun -p /sbin/ldconfig
98
99 %files -f %{name}.lang
100 %defattr(644,root,root,755)
101 %doc README doc/CHANGES
102 %attr(755,root,root) %{_bindir}/*
103 %attr(755,root,root) %{_libdir}/lib*.so.*.*
104 %{_mandir}/man[18]/*
105
106 %files devel
107 %defattr(644,root,root,755)
108 %{_libexecdir}/lib*.la
109 %attr(755,root,root) %{_libexecdir}/lib*.so
110 %{_includedir}/attr
111 %{_mandir}/man[35]/*
112
113 %files static
114 %defattr(644,root,root,755)
115 %{_libexecdir}/lib*.a
This page took 0.095302 seconds and 4 git commands to generate.