]> git.pld-linux.org Git - packages/attr.git/blob - attr.spec
- 2.4.12
[packages/attr.git] / attr.spec
1 Summary:        Utility for managing filesystem extended attributes
2 Summary(pl):    Narzêdzia do zarz±dzania rozszerzonymi atrybutami systemu plików
3 Name:           attr
4 Version:        2.4.12
5 Release:        1
6 # most part is on LGPL v2.1, but the rest enforces GPL
7 License:        GPL
8 Group:          Applications/System
9 Source0:        ftp://linux-xfs.sgi.com/projects/xfs/download/cmd_tars/%{name}-%{version}.src.tar.gz
10 # Source0-md5:  50ea2fb53bed58dc2f407ed73786a9e2
11 Patch0:         %{name}-miscfix.patch
12 URL:            http://oss.sgi.com/projects/xfs/
13 BuildRequires:  autoconf
14 BuildRequires:  automake
15 BuildRequires:  xfsprogs-devel >= 2.6.0
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %define         _bindir         /bin
19 %define         _libdir         /lib
20 %define         _libexecdir     /usr/lib
21
22 %description
23 An experimental attr command to manipulate extended attributes under
24 Linux.
25
26 %description -l pl
27 Eksperymentalna wersja polecenia attr to zarz±dzania rozszerzonymi
28 atrybutami pod systemem Linux.
29
30 %package devel
31 Summary:        Header files and libraries to use extended attributes
32 Summary(pl):    Pliki nag³ówkowe i biblioteki do korzystania z rozszerzonych atrybutów
33 Group:          Development/Libraries
34 Requires:       %{name} = %{version}
35
36 %description devel
37 Header files to develop software which manipulate extended attributes.
38
39 %description devel -l pl
40 Pliki nag³ówkowe potrzebne do tworzenia oprogramowania manipuluj±cego
41 rozszerzonymi atrybutami.
42
43 %package static
44 Summary:        Static libraries for extended attributes
45 Summary(pl):    Biblioteki statyczne do korzystania z rozszerzonych atrybutów
46 Group:          Development/Libraries
47 Requires:       %{name}-devel = %{version}
48
49 %description static
50 Static libraries for extended attributes.
51
52 %description static -l pl
53 Biblioteki statyczne do korzystania z rozszerzonych atrybutów.
54
55 %prep
56 %setup -q
57 %patch0 -p1
58
59 %build
60 rm -f aclocal.m4
61 %{__aclocal} -I m4
62 %{__autoconf}
63 %configure \
64         DEBUG="%{?debug:-DDEBUG}%{!?debug:-DNDEBUG}" \
65         OPTIMIZER="%{rpmcflags}"
66
67 %{__make}
68
69 %install
70 rm -rf $RPM_BUILD_ROOT
71
72 DIST_ROOT=$RPM_BUILD_ROOT
73 DIST_INSTALL=`pwd`/install.manifest
74 DIST_INSTALL_DEV=`pwd`/install-dev.manifest
75 DIST_INSTALL_LIB=`pwd`/install-lib.manifest
76 export DIST_ROOT DIST_INSTALL DIST_INSTALL_DEV DIST_INSTALL_LIB
77
78 %{__make} install \
79         DIST_MANIFEST=$DIST_INSTALL
80 %{__make} install-dev \
81         DIST_MANIFEST=$DIST_INSTALL_DEV
82 %{__make} install-lib \
83         DIST_MANIFEST=$DIST_INSTALL_LIB
84
85 rm -f   $RPM_BUILD_ROOT%{_mandir}/man3/{attr_getf,attr_listf}.3
86 rm -f   $RPM_BUILD_ROOT%{_mandir}/man3/{attr_multif,attr_removef,attr_setf}.3
87 rm -rf  $RPM_BUILD_ROOT%{_mandir}/man2
88
89 ln -sf %{_libdir}/$(cd $RPM_BUILD_ROOT%{_libdir} ; echo libattr.so.*.*.*) \
90          $RPM_BUILD_ROOT%{_libexecdir}/libattr.so
91
92 echo ".so attr_get.3"   > $RPM_BUILD_ROOT%{_mandir}/man3/attr_getf.3
93 echo ".so attr_list.3"  > $RPM_BUILD_ROOT%{_mandir}/man3/attr_listf.3
94 echo ".so attr_multi.3" > $RPM_BUILD_ROOT%{_mandir}/man3/attr_multif.3
95 echo ".so attr_remove.3" > $RPM_BUILD_ROOT%{_mandir}/man3/attr_removef.3
96 echo ".so attr_set.3"   > $RPM_BUILD_ROOT%{_mandir}/man3/attr_setf.3
97
98 %find_lang %{name}
99
100 %clean
101 rm -rf $RPM_BUILD_ROOT
102
103 %post   -p /sbin/ldconfig
104 %postun -p /sbin/ldconfig
105
106 %files -f %{name}.lang
107 %defattr(644,root,root,755)
108 %doc README doc/CHANGES
109 %attr(755,root,root) %{_bindir}/*
110 %attr(755,root,root) %{_libdir}/lib*.so.*.*
111 %{_mandir}/man[158]/*
112
113 %files devel
114 %defattr(644,root,root,755)
115 %{_libexecdir}/lib*.la
116 %attr(755,root,root) %{_libexecdir}/lib*.so
117 %{_includedir}/attr
118 %{_mandir}/man3/*
119
120 %files static
121 %defattr(644,root,root,755)
122 %{_libexecdir}/lib*.a
This page took 0.082883 seconds and 4 git commands to generate.