]> git.pld-linux.org Git - packages/attr.git/blob - attr.spec
- 2.4.8
[packages/attr.git] / attr.spec
1 Summary:        Utility for managing filesystem extended attributes
2 Summary(pl):    Narzêdzia do zarz±dzania rozszerzonymi atrybutami fs
3 Name:           attr
4 Version:        2.4.8
5 Release:        1
6 # most part is on LGPL v2.1, but the rest enforces GPL
7 License:        GPL
8 Group:          Applications/System
9 Source0:        ftp://linux-xfs.sgi.com/projects/xfs/download/Release-1.3/cmd_tars/%{name}-%{version}.src.tar.gz
10 # Source0-md5:  d2016137a97f8f7ec956a19f45c3f7b7
11 Patch0:         %{name}-miscfix.patch
12 URL:            http://oss.sgi.com/projects/xfs/
13 BuildRequires:  autoconf
14 BuildRequires:  automake
15 BuildRequires:  e2fsprogs-devel
16 BuildRequires:  xfsprogs-devel >= 2.5.6
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %define         _bindir         /bin
20 %define         _libdir         /lib
21 %define         _libexecdir     /usr/lib
22
23 %description
24 An experimental attr command to manipulate extended attributes under
25 Linux.
26
27 %description -l pl
28 Eksperymentalna wersja polecenia attr to zarz±dzania rozszerzonymi
29 atrybutami pod systemem Linux.
30
31 %package devel
32 Summary:        Header files and libraries to use extended attributes
33 Summary(pl):    Pliki nag³ówkowe i biblioteki
34 Group:          Development/Libraries
35 Requires:       %{name} = %{version}
36
37 %description devel
38 Header files to develop software which manipulate extended attributes.
39
40 %description devel -l pl
41 Pliki nag³ówkowe potrzebne do tworzenia oprogramowania manipuluj±cego
42 rozszerzonymi atrybutami.
43
44 %package static
45 Summary:        Static libraries for extended attributes
46 Summary(pl):    Biblioteki statyczne attr
47 Group:          Development/Libraries
48 Requires:       %{name}-devel = %{version}
49
50 %description static
51 Static libraries for extended attributes.
52
53 %description static -l pl
54 Biblioteki statyczne attr.
55
56 %prep
57 %setup -q
58 %patch0 -p1
59
60 %build
61 rm -f aclocal.m4
62 %{__aclocal} -I m4
63 %{__autoconf}
64 %configure \
65         DEBUG="%{?debug:-DDEBUG}%{!?debug:-DNDEBUG}" \
66         OPTIMIZER="%{rpmcflags}"
67
68 %{__make}
69
70 %install
71 rm -rf $RPM_BUILD_ROOT
72
73 DIST_ROOT=$RPM_BUILD_ROOT
74 DIST_INSTALL=`pwd`/install.manifest
75 DIST_INSTALL_DEV=`pwd`/install-dev.manifest
76 DIST_INSTALL_LIB=`pwd`/install-lib.manifest
77 export DIST_ROOT DIST_INSTALL DIST_INSTALL_DEV DIST_INSTALL_LIB
78
79 %{__make} install \
80         DIST_MANIFEST=$DIST_INSTALL
81 %{__make} install-dev \
82         DIST_MANIFEST=$DIST_INSTALL_DEV
83 %{__make} install-lib \
84         DIST_MANIFEST=$DIST_INSTALL_LIB
85
86 rm -f   $RPM_BUILD_ROOT%{_mandir}/man3/{attr_getf,attr_listf}.3
87 rm -f   $RPM_BUILD_ROOT%{_mandir}/man3/{attr_multif,attr_removef,attr_setf}.3
88 rm -rf  $RPM_BUILD_ROOT%{_mandir}/man2
89
90 ln -sf %{_libdir}/$(cd $RPM_BUILD_ROOT%{_libdir} ; echo libattr.so.*.*.*) \
91          $RPM_BUILD_ROOT%{_libexecdir}/libattr.so
92
93 echo ".so attr_get.3"   > $RPM_BUILD_ROOT%{_mandir}/man3/attr_getf.3
94 echo ".so attr_list.3"  > $RPM_BUILD_ROOT%{_mandir}/man3/attr_listf.3
95 echo ".so attr_multi.3" > $RPM_BUILD_ROOT%{_mandir}/man3/attr_multif.3
96 echo ".so attr_remove.3" > $RPM_BUILD_ROOT%{_mandir}/man3/attr_removef.3
97 echo ".so attr_set.3"   > $RPM_BUILD_ROOT%{_mandir}/man3/attr_setf.3
98
99 %find_lang %{name}
100
101 %clean
102 rm -rf $RPM_BUILD_ROOT
103
104 %post   -p /sbin/ldconfig
105 %postun -p /sbin/ldconfig
106
107 %files -f %{name}.lang
108 %defattr(644,root,root,755)
109 %doc README doc/CHANGES
110 %attr(755,root,root) %{_bindir}/*
111 %attr(755,root,root) %{_libdir}/lib*.so.*.*
112 %{_mandir}/man[158]/*
113
114 %files devel
115 %defattr(644,root,root,755)
116 %{_libexecdir}/lib*.la
117 %attr(755,root,root) %{_libexecdir}/lib*.so
118 %{_includedir}/attr
119 %{_mandir}/man3/*
120
121 %files static
122 %defattr(644,root,root,755)
123 %{_libexecdir}/lib*.a
This page took 0.087156 seconds and 4 git commands to generate.