]> git.pld-linux.org Git - packages/attr.git/blob - attr.spec
- spacing
[packages/attr.git] / attr.spec
1 Summary:        Utility for managing filesystem extended attributes
2 Summary(pl):    Narzêdzia do zarz±dzania rozszerzonymi atrybutami systemu plików
3 Name:           attr
4 Version:        2.4.19
5 Release:        1
6 # most part is on LGPL v2.1, but the rest enforces GPL
7 License:        GPL
8 Group:          Applications/System
9 Source0:        ftp://linux-xfs.sgi.com/projects/xfs/download/cmd_tars/%{name}-%{version}.src.tar.gz
10 # Source0-md5:  0ea0d3bea5a58727eafd46fa1c0f09cc
11 Patch0:         %{name}-miscfix.patch
12 Patch1:         %{name}-po.patch
13 URL:            http://oss.sgi.com/projects/xfs/
14 BuildRequires:  autoconf
15 BuildRequires:  automake
16 BuildRequires:  gettext-devel
17 BuildRequires:  sed >= 4.1.1-1
18 Obsoletes:      libattr
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %define         _bindir         /bin
22 %define         _libdir         /%{_lib}
23 %define         _libexecdir     /usr/%{_lib}
24
25 %description
26 An experimental attr command to manipulate extended attributes under
27 Linux.
28
29 %description -l pl
30 Eksperymentalna wersja polecenia attr to zarz±dzania rozszerzonymi
31 atrybutami pod systemem Linux.
32
33 %package devel
34 Summary:        Header files and libraries to use extended attributes
35 Summary(pl):    Pliki nag³ówkowe i biblioteki do korzystania z rozszerzonych atrybutów
36 Group:          Development/Libraries
37 Requires:       %{name} = %{version}-%{release}
38
39 %description devel
40 Header files to develop software which manipulate extended attributes.
41
42 %description devel -l pl
43 Pliki nag³ówkowe potrzebne do tworzenia oprogramowania manipuluj±cego
44 rozszerzonymi atrybutami.
45
46 %package static
47 Summary:        Static libraries for extended attributes
48 Summary(pl):    Biblioteki statyczne do korzystania z rozszerzonych atrybutów
49 Group:          Development/Libraries
50 Requires:       %{name}-devel = %{version}-%{release}
51
52 %description static
53 Static libraries for extended attributes.
54
55 %description static -l pl
56 Biblioteki statyczne do korzystania z rozszerzonych atrybutów.
57
58 %prep
59 %setup -q
60 %patch0 -p1
61 %patch1 -p1
62
63 %build
64 rm -f aclocal.m4
65 %{__aclocal} -I m4
66 %{__autoconf}
67 %configure \
68         DEBUG="%{?debug:-DDEBUG}%{!?debug:-DNDEBUG}" \
69         OPTIMIZER="%{rpmcflags} -DENABLE_GETTEXT"
70
71 %{__make}
72
73 %install
74 rm -rf $RPM_BUILD_ROOT
75
76 DIST_ROOT=$RPM_BUILD_ROOT
77 DIST_INSTALL=`pwd`/install.manifest
78 DIST_INSTALL_DEV=`pwd`/install-dev.manifest
79 DIST_INSTALL_LIB=`pwd`/install-lib.manifest
80 export DIST_ROOT DIST_INSTALL DIST_INSTALL_DEV DIST_INSTALL_LIB
81
82 %{__make} install \
83         DIST_MANIFEST=$DIST_INSTALL
84 %{__make} install-dev \
85         DIST_MANIFEST=$DIST_INSTALL_DEV
86 %{__make} install-lib \
87         DIST_MANIFEST=$DIST_INSTALL_LIB
88
89 rm -f   $RPM_BUILD_ROOT%{_mandir}/man3/{attr_getf,attr_listf}.3
90 rm -f   $RPM_BUILD_ROOT%{_mandir}/man3/{attr_multif,attr_removef,attr_setf}.3
91 rm -rf  $RPM_BUILD_ROOT%{_mandir}/man2
92
93 ln -sf %{_libdir}/$(cd $RPM_BUILD_ROOT%{_libdir} ; echo libattr.so.*.*.*) \
94          $RPM_BUILD_ROOT%{_libexecdir}/libattr.so
95
96 %{__sed} -i "s|libdir='%{_libdir}'|libdir='%{_libexecdir}'|" \
97         $RPM_BUILD_ROOT%{_libexecdir}/libattr.la
98
99 echo ".so attr_get.3"   > $RPM_BUILD_ROOT%{_mandir}/man3/attr_getf.3
100 echo ".so attr_list.3"  > $RPM_BUILD_ROOT%{_mandir}/man3/attr_listf.3
101 echo ".so attr_multi.3" > $RPM_BUILD_ROOT%{_mandir}/man3/attr_multif.3
102 echo ".so attr_remove.3" > $RPM_BUILD_ROOT%{_mandir}/man3/attr_removef.3
103 echo ".so attr_set.3"   > $RPM_BUILD_ROOT%{_mandir}/man3/attr_setf.3
104
105 %find_lang %{name}
106
107 %clean
108 rm -rf $RPM_BUILD_ROOT
109
110 %post   -p /sbin/ldconfig
111 %postun -p /sbin/ldconfig
112
113 %files -f %{name}.lang
114 %defattr(644,root,root,755)
115 %doc README doc/CHANGES
116 %attr(755,root,root) %{_bindir}/*
117 %attr(755,root,root) %{_libdir}/lib*.so.*.*
118 %{_mandir}/man[158]/*
119
120 %files devel
121 %defattr(644,root,root,755)
122 %{_libexecdir}/lib*.la
123 %attr(755,root,root) %{_libexecdir}/lib*.so
124 %{_includedir}/attr
125 %{_mandir}/man3/*
126
127 %files static
128 %defattr(644,root,root,755)
129 %{_libexecdir}/lib*.a
This page took 0.049716 seconds and 4 git commands to generate.