]> git.pld-linux.org Git - packages/attr.git/blob - attr.spec
- 2.4.15
[packages/attr.git] / attr.spec
1 Summary:        Utility for managing filesystem extended attributes
2 Summary(pl):    Narzêdzia do zarz±dzania rozszerzonymi atrybutami systemu plików
3 Name:           attr
4 Version:        2.4.15
5 Release:        1
6 # most part is on LGPL v2.1, but the rest enforces GPL
7 License:        GPL
8 Group:          Applications/System
9 Source0:        ftp://linux-xfs.sgi.com/projects/xfs/download/cmd_tars/%{name}-%{version}.src.tar.gz
10 # Source0-md5:  b785ec1b5b351b6ffcf0c31b12d87692
11 Source1:        %{name}-pl.po
12 Patch0:         %{name}-miscfix.patch
13 URL:            http://oss.sgi.com/projects/xfs/
14 BuildRequires:  autoconf
15 BuildRequires:  automake
16 BuildRequires:  gettext-devel
17 BuildRequires:  xfsprogs-devel 
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %define         _bindir         /bin
21 %define         _libdir         /%{_lib}
22 %define         _libexecdir     /usr/%{_lib}
23
24 %description
25 An experimental attr command to manipulate extended attributes under
26 Linux.
27
28 %description -l pl
29 Eksperymentalna wersja polecenia attr to zarz±dzania rozszerzonymi
30 atrybutami pod systemem Linux.
31
32 %package devel
33 Summary:        Header files and libraries to use extended attributes
34 Summary(pl):    Pliki nag³ówkowe i biblioteki do korzystania z rozszerzonych atrybutów
35 Group:          Development/Libraries
36 Requires:       %{name} = %{version}
37
38 %description devel
39 Header files to develop software which manipulate extended attributes.
40
41 %description devel -l pl
42 Pliki nag³ówkowe potrzebne do tworzenia oprogramowania manipuluj±cego
43 rozszerzonymi atrybutami.
44
45 %package static
46 Summary:        Static libraries for extended attributes
47 Summary(pl):    Biblioteki statyczne do korzystania z rozszerzonych atrybutów
48 Group:          Development/Libraries
49 Requires:       %{name}-devel = %{version}
50
51 %description static
52 Static libraries for extended attributes.
53
54 %description static -l pl
55 Biblioteki statyczne do korzystania z rozszerzonych atrybutów.
56
57 %prep
58 %setup -q
59 %patch0 -p1
60 chmod -Rf u+w .
61 cp %{SOURCE1} po/pl.po
62 %{__perl} -pi -e 's/^(LINGUAS.*)/$1 pl/' po/Makefile
63
64 %build
65 rm -f aclocal.m4
66 %{__aclocal} -I m4
67 %{__autoconf}
68 %configure \
69         DEBUG="%{?debug:-DDEBUG}%{!?debug:-DNDEBUG}" \
70         OPTIMIZER="%{rpmcflags} -DENABLE_GETTEXT"
71
72 %{__make}
73
74 %install
75 rm -rf $RPM_BUILD_ROOT
76
77 DIST_ROOT=$RPM_BUILD_ROOT
78 DIST_INSTALL=`pwd`/install.manifest
79 DIST_INSTALL_DEV=`pwd`/install-dev.manifest
80 DIST_INSTALL_LIB=`pwd`/install-lib.manifest
81 export DIST_ROOT DIST_INSTALL DIST_INSTALL_DEV DIST_INSTALL_LIB
82
83 %{__make} install \
84         DIST_MANIFEST=$DIST_INSTALL
85 %{__make} install-dev \
86         DIST_MANIFEST=$DIST_INSTALL_DEV
87 %{__make} install-lib \
88         DIST_MANIFEST=$DIST_INSTALL_LIB
89
90 rm -f   $RPM_BUILD_ROOT%{_mandir}/man3/{attr_getf,attr_listf}.3
91 rm -f   $RPM_BUILD_ROOT%{_mandir}/man3/{attr_multif,attr_removef,attr_setf}.3
92 rm -rf  $RPM_BUILD_ROOT%{_mandir}/man2
93
94 ln -sf %{_libdir}/$(cd $RPM_BUILD_ROOT%{_libdir} ; echo libattr.so.*.*.*) \
95          $RPM_BUILD_ROOT%{_libexecdir}/libattr.so
96
97 echo ".so attr_get.3"   > $RPM_BUILD_ROOT%{_mandir}/man3/attr_getf.3
98 echo ".so attr_list.3"  > $RPM_BUILD_ROOT%{_mandir}/man3/attr_listf.3
99 echo ".so attr_multi.3" > $RPM_BUILD_ROOT%{_mandir}/man3/attr_multif.3
100 echo ".so attr_remove.3" > $RPM_BUILD_ROOT%{_mandir}/man3/attr_removef.3
101 echo ".so attr_set.3"   > $RPM_BUILD_ROOT%{_mandir}/man3/attr_setf.3
102
103 %find_lang %{name}
104
105 %clean
106 rm -rf $RPM_BUILD_ROOT
107
108 %post   -p /sbin/ldconfig
109 %postun -p /sbin/ldconfig
110
111 %files -f %{name}.lang
112 %defattr(644,root,root,755)
113 %doc README doc/CHANGES
114 %attr(755,root,root) %{_bindir}/*
115 %attr(755,root,root) %{_libdir}/lib*.so.*.*
116 %{_mandir}/man[158]/*
117
118 %files devel
119 %defattr(644,root,root,755)
120 %{_libexecdir}/lib*.la
121 %attr(755,root,root) %{_libexecdir}/lib*.so
122 %{_includedir}/attr
123 %{_mandir}/man3/*
124
125 %files static
126 %defattr(644,root,root,755)
127 %{_libexecdir}/lib*.a
This page took 0.031615 seconds and 4 git commands to generate.