]> git.pld-linux.org Git - packages/attr.git/blob - attr.spec
- many small fixes, inspired by kloczek
[packages/attr.git] / attr.spec
1 Summary:        Utility for managing filesystem extended attributes
2 Summary(pl):    Narzêdzia do zarz±dzania rozszerzonymi atrybutami fs
3 Name:           attr
4 Version:        2.4.1
5 Release:        3
6 # most part is on LGPL v2.1, but the rest enforces GPL
7 License:        GPL
8 Group:          Applications/System
9 Source0:        ftp://linux-xfs.sgi.com/projects/xfs/download/cmd_tars/%{name}-%{version}.src.tar.gz
10 # Source0-md5:  1cd48b80889ffb033f53e63e66014071
11 Patch0:         %{name}-miscfix.patch
12 URL:            http://oss.sgi.com/projects/xfs/
13 BuildRequires:  autoconf
14 BuildRequires:  e2fsprogs-devel
15 BuildRequires:  xfsprogs-devel >= 2.0.0
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %define         _bindir         /bin
19 %define         _libdir         /lib
20 %define         _libexecdir     /usr/lib
21
22 %description
23 An experimental attr command to manipulate extended attributes under
24 Linux.
25
26 %description -l pl
27 Eksperymentalna wersja polecenia attr to zarz±dzania rozszerzonymi
28 atrybutami pod systemem Linux.
29
30 %package devel
31 Summary:        Header files and libraries to use extended attributes
32 Summary(pl):    Pliki nag³ówkowe i biblioteki
33 Group:          Development/Libraries
34 Requires:       %{name} = %{version}
35
36 %description devel
37 Header files to develop software which manipulate extended attributes.
38
39 %description devel -l pl
40 Pliki nag³ówkowe potrzebne do tworzenia oprogramowania manipuluj±cego
41 rozszerzonymi atrybutami.
42
43 %package static
44 Summary:        Static libraries for extended attributes
45 Summary(pl):    Biblioteki statyczne attr
46 Group:          Development/Libraries
47 Requires:       %{name}-devel = %{version}
48
49 %description static
50 Static libraries for extended attributes.
51
52 %description static -l pl
53 Biblioteki statyczne attr.
54
55 %prep
56 %setup  -q
57 %patch0 -p1
58
59 %build
60 DEBUG="%{?debug:-DDEBUG}%{!?debug:-DNDEBUG}"; export DEBUG
61 %{__autoconf}
62 %configure
63
64 %{__make}
65
66 %install
67 rm -rf $RPM_BUILD_ROOT
68
69 DIST_ROOT=$RPM_BUILD_ROOT
70 DIST_INSTALL=`pwd`/install.manifest
71 DIST_INSTALL_DEV=`pwd`/install-dev.manifest
72 DIST_INSTALL_LIB=`pwd`/install-lib.manifest
73 export DIST_ROOT DIST_INSTALL DIST_INSTALL_DEV DIST_INSTALL_LIB
74
75 %{__make} install \
76         DIST_MANIFEST=$DIST_INSTALL
77 %{__make} install-dev \
78         DIST_MANIFEST=$DIST_INSTALL_DEV
79 %{__make} install-lib \
80         DIST_MANIFEST=$DIST_INSTALL_LIB
81
82 rm -f   $RPM_BUILD_ROOT%{_mandir}/man3/{attr_getf,attr_listf}.3
83 rm -f   $RPM_BUILD_ROOT%{_mandir}/man3/{attr_multif,attr_removef,attr_setf}.3
84 rm -rf  $RPM_BUILD_ROOT%{_mandir}/man2
85
86 ln -sf %{_libdir}/$(cd $RPM_BUILD_ROOT/lib ; echo libattr.so.*.*.*) \
87          $RPM_BUILD_ROOT%{_libexecdir}/libattr.so
88
89 echo ".so attr_get.3"   > $RPM_BUILD_ROOT%{_mandir}/man3/attr_getf.3
90 echo ".so attr_list.3"  > $RPM_BUILD_ROOT%{_mandir}/man3/attr_listf.3
91 echo ".so attr_multi.3" > $RPM_BUILD_ROOT%{_mandir}/man3/attr_multif.3
92 echo ".so attr_remove.3" > $RPM_BUILD_ROOT%{_mandir}/man3/attr_removef.3
93 echo ".so attr_set.3"   > $RPM_BUILD_ROOT%{_mandir}/man3/attr_setf.3
94
95 %find_lang %{name}
96
97 %clean
98 rm -rf $RPM_BUILD_ROOT
99
100 %post   -p /sbin/ldconfig
101 %postun -p /sbin/ldconfig
102
103 %files -f %{name}.lang
104 %defattr(644,root,root,755)
105 %doc README doc/CHANGES
106 %attr(755,root,root) %{_bindir}/*
107 %attr(755,root,root) %{_libdir}/lib*.so.*.*
108 %{_mandir}/man[158]/*
109
110 %files devel
111 %defattr(644,root,root,755)
112 %{_libexecdir}/lib*.la
113 %attr(755,root,root) %{_libexecdir}/lib*.so
114 %{_includedir}/attr
115 %{_mandir}/man3/*
116
117 %files static
118 %defattr(644,root,root,755)
119 %{_libexecdir}/lib*.a
This page took 0.0674 seconds and 4 git commands to generate.