]> git.pld-linux.org Git - packages/attr.git/blob - attr.spec
- converted to UTF-8
[packages/attr.git] / attr.spec
1 Summary:        Utility for managing filesystem extended attributes
2 Summary(pl.UTF-8):   Narzędzia do zarządzania rozszerzonymi atrybutami systemu plików
3 Name:           attr
4 Version:        2.4.32
5 Release:        3
6 License:        LGPL v2+ (library), GPL v2+ (utilities)
7 Group:          Applications/System
8 Source0:        ftp://linux-xfs.sgi.com/projects/xfs/download/cmd_tars/%{name}_%{version}-1.tar.gz
9 # Source0-md5:  092739e9b944815aecc1f5d8379d5ea5
10 Patch0:         %{name}-miscfix.patch
11 Patch1:         %{name}-lt.patch
12 Patch2:         %{name}-LDFLAGS.patch
13 URL:            http://oss.sgi.com/projects/xfs/
14 BuildRequires:  autoconf
15 BuildRequires:  automake
16 BuildRequires:  gettext-devel
17 BuildRequires:  libtool
18 Obsoletes:      libattr
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %define         _bindir         /bin
22 %define         _libdir         /%{_lib}
23 %define         _libexecdir     /usr/%{_lib}
24
25 %description
26 An experimental attr command to manipulate extended attributes under
27 Linux.
28
29 %description -l pl.UTF-8
30 Eksperymentalna wersja polecenia attr to zarządzania rozszerzonymi
31 atrybutami pod systemem Linux.
32
33 %package devel
34 Summary:        Header files and libraries to use extended attributes
35 Summary(pl.UTF-8):   Pliki nagłówkowe i biblioteki do korzystania z rozszerzonych atrybutów
36 Group:          Development/Libraries
37 Requires:       %{name} = %{version}-%{release}
38
39 %description devel
40 Header files to develop software which manipulate extended attributes.
41
42 %description devel -l pl.UTF-8
43 Pliki nagłówkowe potrzebne do tworzenia oprogramowania manipulującego
44 rozszerzonymi atrybutami.
45
46 %package static
47 Summary:        Static libraries for extended attributes
48 Summary(pl.UTF-8):   Biblioteki statyczne do korzystania z rozszerzonych atrybutów
49 Group:          Development/Libraries
50 Requires:       %{name}-devel = %{version}-%{release}
51
52 %description static
53 Static libraries for extended attributes.
54
55 %description static -l pl.UTF-8
56 Biblioteki statyczne do korzystania z rozszerzonych atrybutów.
57
58 %prep
59 %setup -q
60 %patch0 -p1
61 %patch1 -p1
62 %patch2 -p1
63
64 %build
65 rm -f aclocal.m4
66 %{__aclocal} -I m4
67 %{__autoconf}
68 %configure \
69         DEBUG="%{?debug:-DDEBUG}%{!?debug:-DNDEBUG}" \
70         OPTIMIZER="%{rpmcflags} -DENABLE_GETTEXT"
71
72 %{__make} \
73         LLDFLAGS="%{rpmldflags}"
74
75 %install
76 rm -rf $RPM_BUILD_ROOT
77
78 DIST_ROOT=$RPM_BUILD_ROOT
79 DIST_INSTALL=`pwd`/install.manifest
80 DIST_INSTALL_DEV=`pwd`/install-dev.manifest
81 DIST_INSTALL_LIB=`pwd`/install-lib.manifest
82 export DIST_ROOT DIST_INSTALL DIST_INSTALL_DEV DIST_INSTALL_LIB
83
84 %{__make} install \
85         DIST_MANIFEST=$DIST_INSTALL
86 %{__make} install-dev \
87         DIST_MANIFEST=$DIST_INSTALL_DEV
88 %{__make} install-lib \
89         DIST_MANIFEST=$DIST_INSTALL_LIB
90
91 rm -f   $RPM_BUILD_ROOT%{_mandir}/man3/{attr_getf,attr_listf}.3
92 rm -f   $RPM_BUILD_ROOT%{_mandir}/man3/{attr_multif,attr_removef,attr_setf}.3
93 rm -rf  $RPM_BUILD_ROOT%{_mandir}/man2
94
95 ln -sf %{_libdir}/$(cd $RPM_BUILD_ROOT%{_libdir} ; echo libattr.so.*.*.*) \
96          $RPM_BUILD_ROOT%{_libexecdir}/libattr.so
97
98 %{__sed} -i "s|libdir='%{_libdir}'|libdir='%{_libexecdir}'|" \
99         $RPM_BUILD_ROOT%{_libexecdir}/libattr.la
100
101 echo ".so attr_get.3"   > $RPM_BUILD_ROOT%{_mandir}/man3/attr_getf.3
102 echo ".so attr_list.3"  > $RPM_BUILD_ROOT%{_mandir}/man3/attr_listf.3
103 echo ".so attr_multi.3" > $RPM_BUILD_ROOT%{_mandir}/man3/attr_multif.3
104 echo ".so attr_remove.3" > $RPM_BUILD_ROOT%{_mandir}/man3/attr_removef.3
105 echo ".so attr_set.3"   > $RPM_BUILD_ROOT%{_mandir}/man3/attr_setf.3
106
107 %find_lang %{name}
108
109 %clean
110 rm -rf $RPM_BUILD_ROOT
111
112 %post   -p /sbin/ldconfig
113 %postun -p /sbin/ldconfig
114
115 %files -f %{name}.lang
116 %defattr(644,root,root,755)
117 %doc README doc/CHANGES
118 %attr(755,root,root) %{_bindir}/*
119 %attr(755,root,root) %{_libdir}/lib*.so.*.*
120 %{_mandir}/man[158]/*
121
122 %files devel
123 %defattr(644,root,root,755)
124 %{_libexecdir}/lib*.la
125 %attr(755,root,root) %{_libexecdir}/lib*.so
126 %{_includedir}/attr
127 %{_mandir}/man3/*
128
129 %files static
130 %defattr(644,root,root,755)
131 %{_libexecdir}/lib*.a
This page took 0.038693 seconds and 4 git commands to generate.