]> git.pld-linux.org Git - packages/atlas.git/blob - atlas.spec
- very raw/broken/nfy version
[packages/atlas.git] / atlas.spec
1 Summary:        The atlas libraries for numerical linear algebra
2 Summary(pl):    Biblioteki numeryczne atlas do algebry liniowej
3 Name:           atlas
4 Version:        3.7.10
5 Release:        1
6 License:        freely distributable
7 Group:          Development/Libraries
8 Source0:        http://dl.sourceforge.net/math-atlas/%{name}%{version}.tar.bz2
9 # Source0-md5:  c24aa9f676122fe6331fa63dd88c4113
10 URL:            http://math-atlas.sourceforge.net/
11 BuildRequires:  autoconf
12 BuildRequires:  automake
13 BuildRequires:  libtool >= 1:1.4.2-9
14 BuildRequires:  gcc-g77
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 %description
18 The ATLAS (Automatically Tuned Linear Algebra Software) project is an
19 ongoing research effort focusing on applying empirical techniques in
20 order to provide portable performance. At present, it provides C and
21 Fortran77 interfaces to a portably efficient BLAS implementation, as
22 well as a few routines from LAPACK.
23
24 %package devel
25 Summary:        atlas header files
26 Summary(pl):    Pliki nag³ówkowe atlas
27 Group:          Development/Libraries
28 Requires:       %{name} = %{version}
29 Requires:       blas-devel = %{version}
30 Obsoletes:      lapack-man
31
32 %description devel
33 atlas header files.
34
35 %description devel -l pl
36 Pliki nag³ówkowe atlas.
37
38 %package static
39 Summary:        Static atlas libraries
40 Summary(pl):    Biblioteki statyczne atlas
41 Group:          Development/Libraries
42 Requires:       %{name}-devel = %{version}
43
44 %description static
45 Static atlas libraries.
46
47 %description static -l pl
48 Biblioteki statyczne atlas.
49
50 %package -n blas
51 Summary:        The BLAS (Basic Linear Algebra Subprograms) library for Linux
52 Summary(pl):    Biblioteka BLAS (Basic Linear Algebra Subprograms) dla Linuksa
53 Group:          Development/Libraries
54 Obsoletes:      lapack-blas
55
56 %description -n blas
57 BLAS (Basic Linear Algebra Subprograms) is a standard library for
58 numerical algebra. BLAS provides a number of basic algorithms for
59 linear algebra. BLAS is fast and well-tested, was written in FORTRAN
60 77.
61
62 Warning: this is a reference implementation from Netlib. If possible,
63 use version optimized for your architecture instead.
64
65 %description -n blas -l pl
66 BLAS (Basic Linear Algebra Subprograms) jest standardow± bibliotek±
67 numeryczn± algebry. Dostarcza wiele podstawowych algorytmów dla
68 algebry liniowej. Jest szybka i dobrze przetestowana, zosta³a napisana
69 w Fortranie 77.
70
71 Ostrze¿enie: to jest implementacja przyk³adowa z repozytorium Netlib.
72 Je¿eli to mo¿liwe, nale¿y u¿ywaæ zamiast niej wersji zoptymalizowanej
73 pod dan± architekturê.
74
75 %package -n blas-devel
76 Summary:        BLAS header files
77 Summary(pl):    Pliki nag³ówkowe BLAS
78 Group:          Development/Libraries
79 Requires:       blas = %{version}
80 Obsoletes:      blas-man
81
82 %description -n blas-devel
83 BLAS header files.
84
85 %description -n blas-devel -l pl
86 Pliki nag³ówkowe BLAS.
87
88 %package -n blas-static
89 Summary:        Static BLAS libraries
90 Summary(pl):    Biblioteki statyczne BLAS
91 Group:          Development/Libraries
92 Requires:       blas-devel = %{version}
93
94 %description -n blas-static
95 Static BLAS libraries.
96
97 %description -n blas-static -l pl
98 Biblioteki statyczne BLAS.
99
100 %prep
101 %setup -q -n ATLAS
102
103 %build
104 # make config CC=xlc_r
105 cat > config.expect <<EOF
106 log_file "config.expect.log"
107 set finished 0
108 set arch foo
109 spawn ./xconfig
110 while {\$finished == 0} {
111   set timeout 120
112   expect {
113     -nocase {Enter number at top left of screen}  {send "99\n"}
114     -nocase {Have you scoped the errata file\?}   {send "y\n"}
115     -nocase {Are you ready to continue\?}         {send "y\n"}
116     -nocase {Enter machine number \[2\]: }        {send "1\n"}
117     -nocase {Are you using a cross-compiler\?}    {send "n\n"}
118     -nocase {enable Posix threads support\?}      {send "y\n"}
119     -nocase {use express setup\?}                 {send "y\n"}
120     -nocase -indices -re {Enter Architecture name \(ARCH\) \[(.*)\]}
121      {global arch; set arch Linux_PPCGP; send "Linux_PPCGP\n"}
122     -nocase {overwrite it\?}                      {send "y\n"}
123     -nocase {Enter File creation delay in seconds}
124                                                   {send "0\n"}
125     -nocase {Enter Top level ATLAS directory}     {send "\n"}
126     -nocase {Enter Directory to build libraries in}     {send "\n"}
127     -nocase {Enter f77 compiler}                  {send "\n"}
128     -nocase {Enter F77 Flags}                     {send "\n"}
129     -nocase {Enter F77 linker}                    {send "\n"}
130     -nocase {Enter F77 Link Flags}                {send "\n"}
131     -nocase {Enter ANSI C compiler}               {send "\n"}
132     -nocase {Enter C Flags \(CCFLAGS\)}           {send "\n"}
133     -nocase {Enter C compiler for generated code} {send "\n"}
134     -nocase {Enter C FLAGS \(MMFLAGS\)}           {send "\n"}
135     -nocase {Enter C Linker}                      {send "\n"}
136     -nocase {Enter C Link Flags}                  {send "\n"}
137     -nocase {Enter Archiver \[}                   {send "\n"}
138     -nocase {Enter Archiver flags}                {send "\n"}
139     -nocase {Enter Ranlib}                        {send "\n"}
140     -nocase {Enter BLAS library}                  {send "\n"}
141     -nocase {Enter General and system libs}       {send "\n"}
142     -nocase {kill old subdirectories\?}           {send "y\n"}
143     -nocase {Tune the Level 1 BLAS\?}             {send "\n"}
144     -nocase {use supplied default values for install\?}
145                                                   {send "y\n"}
146     -nocase {Configuration completed successfully} {set finished 1}
147     timeout                                       {puts timeout; exit 1}
148   }
149 }
150 close
151 #file copy -force CONFIG/ATLrun.\$arch CONFIG/ATLrun.Linux
152 #file copy -force Make.\$arch Make.Linux
153 exit
154 EOF
155   make xconfig
156   expect -f config.expect
157   rm -f config.expect
158
159 %install
160 rm -rf $RPM_BUILD_ROOT
161
162 %{__make} install DESTDIR=$RPM_BUILD_ROOT
163
164 # present both in blas and lapack
165 rm -f man/manl/{lsame,xerbla}.l
166
167 install -d $RPM_BUILD_ROOT%{_mandir}/man3
168 for d in man/manl/*.l blas/man/manl/*.l ; do
169         install $d $RPM_BUILD_ROOT%{_mandir}/man3/`basename $d .l`.3
170 done
171
172 echo "%defattr(644, root, root, 755)" > blasmans.list
173 find blas/man/manl -name "*.l" -printf "%{_mandir}/man3/%%f\n" | sed 's/\.l/.3*/' >> blasmans.list
174 echo "%defattr(644, root, root, 755)" > mans.list
175 find man/manl -name "*.l" -printf "%{_mandir}/man3/%%f\n" | sed 's/\.l/.3*/' >> mans.list
176
177 %clean
178 rm -fr $RPM_BUILD_ROOT
179
180 %post   -p /sbin/ldconfig
181 %postun -p /sbin/ldconfig
182
183 %post   -n blas -p /sbin/ldconfig
184 %postun -n blas -p /sbin/ldconfig
185
186 %files
187 %defattr(644,root,root,755)
188 %doc README
189 %attr(755,root,root) %{_libdir}/liblapack.so.*.*.*
190
191 %files devel -f mans.list
192 %defattr(644,root,root,755)
193 %attr(755,root,root) %{_libdir}/liblapack.so
194 %{_libdir}/liblapack.la
195
196 %files static
197 %defattr(644,root,root,755)
198 %{_libdir}/liblapack.a
199
200 %files -n blas
201 %defattr(644,root,root,755)
202 %attr(755,root,root) %{_libdir}/libblas.so.*.*.*
203
204 %files -n blas-devel -f blasmans.list
205 %defattr(644,root,root,755)
206 %attr(755,root,root) %{_libdir}/libblas.so
207 %{_libdir}/libblas.la
208
209 %files -n blas-static
210 %defattr(644,root,root,755)
211 %{_libdir}/libblas.a
This page took 0.095244 seconds and 3 git commands to generate.