]> git.pld-linux.org Git - packages/atlas-upload-cli.git/blame - atlas-upload-cli.spec
make -j1 for now
[packages/atlas-upload-cli.git] / atlas-upload-cli.spec
CommitLineData
2b549a48
ER
1#
2# Conditional build:
3%bcond_with tests # build without tests
4
5Summary: CLI to upload application code to Atlas
6Name: atlas-upload-cli
7Version: 0.2.0
8Release: 1
9License: MPL v2.0
10Group: Applications/System
11Source0: https://github.com/hashicorp/atlas-upload-cli/archive/v%{version}/%{name}-%{version}.tar.gz
12# Source0-md5: 06fa00b9feb63b0a25e5331831b5b968
13URL: https://github.com/hashicorp/atlas-upload-cli
14BuildRequires: golang >= 1.2.1
15BuildRequires: rpmbuild(macros) >= 1.228
16BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18# binary stripped or something
19%define _enable_debug_packages 0
20
21%description
22The Atlas Upload CLI is a lightweight command line interface for
23uploading application code to Atlas to kick off deployment processes.
24This is the CLI used to power the vagrant push command and other parts
25of Atlas Go with the Atlas strategy.
26
27It can also be downloaded and used externally with other systems (such
28as a CI service like Jenkins or Travis CI) to initiate Atlas-based
29deploys.
30
31%prep
32%setup -q
33
34# handle external deps:
35#package github.com/hashicorp/atlas-go/archive: cannot download, $GOPATH not set. For more details see: go help gopath
36#package github.com/hashicorp/atlas-go/v1: cannot download, $GOPATH not set. For more details see: go help gopath
37#package github.com/hashicorp/logutils: cannot download, $GOPATH not set. For more details see: go help gopath
38#package github.com/mitchellh/ioprogress: cannot download, $GOPATH not set. For more details see: go help gopath
39
40%build
41export GOPATH=$(pwd)/vendor
fe38ddb9
ER
42# make -j1 because https://github.com/hashicorp/atlas-upload-cli/pull/10
43%{__make} -j1
2b549a48
ER
44
45%install
46rm -rf $RPM_BUILD_ROOT
47install -d $RPM_BUILD_ROOT%{_bindir}
48install -p bin/atlas-upload $RPM_BUILD_ROOT%{_bindir}
49
50%clean
51rm -rf $RPM_BUILD_ROOT
52
53%files
54%defattr(644,root,root,755)
55%doc README.md CHANGELOG.md LICENSE
56%attr(755,root,root) %{_bindir}/atlas-upload
This page took 0.085739 seconds and 4 git commands to generate.