]> git.pld-linux.org Git - packages/atl2.git/blob - atl2.spec
- Initial Release
[packages/atl2.git] / atl2.spec
1 #
2 # Conditional build:
3 %bcond_without  dist_kernel     # allow non-distribution kernel
4 %bcond_with     verbose         # verbose build (V=1)
5 #
6 %define         _rel    1
7 Summary:        Attansic(R) L2 Fast Ethernet Adapter driver for Linux
8 Summary(pl.UTF-8):      Sterownik do karty Attansic(R) L2 Fast Ethernet Adapter
9 Name:           kernel%{_alt_kernel}-net-atl2
10 Version:        1.4.0.20
11 Release:        %{_rel}@%{_kernel_ver_str}
12 License:        GPL v2
13 Group:          Base/Kernel
14 Source0:        http://starowa.one.pl/~uzi/pld/atl2-%{version}.tar.gz
15 # Source0-md5:  196771fa8e7164d4c9beabcfdf4058b5
16 URL:            http://support.attansic.com
17 %{?with_dist_kernel:BuildRequires:      kernel%{_alt_kernel}-module-build >= 3:2.6.20.2}
18 BuildRequires:  rpmbuild(macros) >= 1.379
19 BuildRequires:  unrar
20 Requires(post,postun):  /sbin/depmod
21 %if %{with dist_kernel}
22 %requires_releq_kernel
23 Requires(postun):       %releq_kernel
24 %endif
25 Provides:       kernel(atl2)
26 Obsoletes:      atl2
27 Obsoletes:      linux-net-atl2
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 This package contains the Linux driver for the 
32 Attansic(R) L2 Fast Ethernet network Adapter.
33
34 %description -l pl.UTF-8
35 Ten pakiet zawiera sterownik dla Linuksa do kart sieciowych
36 Attansic(R) L2 Fast Ethernet Adapter.
37
38 %prep
39 %setup -q -n atl2-%{version}
40
41 cat > src/Makefile <<'EOF'
42 CFILES = at_main.c at_hw.c at_param.c at_ethtool.c kcompat.c  
43 obj-m := atl2.o
44 atl2-objs := $(CFILES:.c=.o)
45 EOF
46
47 %build
48 %build_kernel_modules -C src -m atl2
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52 %install_kernel_modules -m src/atl2 -d kernel/drivers/net -n atl2 -s current
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %post
58 %depmod %{_kernel_ver}
59
60 %postun
61 %depmod %{_kernel_ver}
62
63 %files
64 %defattr(644,root,root,755)
65 %doc atl2.7 COPYING readme release_note.txt ldistrib.txt
66 /etc/modprobe.d/%{_kernel_ver}/atl2.conf
67 /lib/modules/%{_kernel_ver}/kernel/drivers/net/atl2*.ko*
This page took 0.058355 seconds and 3 git commands to generate.