]> git.pld-linux.org Git - packages/atl2.git/blob - atl2.spec
- kill useless P and O
[packages/atl2.git] / atl2.spec
1 #
2 # Conditional build:
3 %bcond_without  dist_kernel     # allow non-distribution kernel
4 %bcond_with     verbose         # verbose build (V=1)
5 #
6 %define         _rel    1
7 Summary:        Attansic(R) L2 Fast Ethernet Adapter driver for Linux
8 Summary(pl.UTF-8):      Sterownik do kart Attansic(R) L2 Fast Ethernet Adapter
9 Name:           kernel%{_alt_kernel}-net-atl2
10 Version:        1.4.0.20
11 Release:        %{_rel}@%{_kernel_ver_str}
12 License:        GPL v2
13 Group:          Base/Kernel
14 Source0:        http://starowa.one.pl/~uzi/pld/atl2-%{version}.tar.gz
15 # Source0-md5:  196771fa8e7164d4c9beabcfdf4058b5
16 URL:            http://www.attansic.com/
17 %{?with_dist_kernel:BuildRequires:      kernel%{_alt_kernel}-module-build >= 3:2.6.20.2}
18 BuildRequires:  rpmbuild(macros) >= 1.379
19 Requires(post,postun):  /sbin/depmod
20 %if %{with dist_kernel}
21 %requires_releq_kernel
22 Requires(postun):       %releq_kernel
23 %endif
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 This package contains the Linux driver for the Attansic(R) L2 Fast
28 Ethernet Adapter.
29
30 %description -l pl.UTF-8
31 Ten pakiet zawiera sterownik dla Linuksa do kart sieciowych
32 Attansic(R) L2 Fast Ethernet Adapter.
33
34 %prep
35 %setup -q -n atl2-%{version}
36
37 cat > src/Makefile <<'EOF'
38 obj-m := atl2.o
39 atl2-objs := at_main.o at_hw.o at_param.o at_ethtool.o kcompat.o
40 EOF
41
42 %build
43 %build_kernel_modules -C src -m atl2
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47 %install_kernel_modules -m src/atl2 -d kernel/drivers/net
48
49 %clean
50 rm -rf $RPM_BUILD_ROOT
51
52 %post
53 %depmod %{_kernel_ver}
54
55 %postun
56 %depmod %{_kernel_ver}
57
58 %files
59 %defattr(644,root,root,755)
60 %doc atl2.7 COPYING readme release_note.txt ldistrib.txt
61 /etc/modprobe.d/%{_kernel_ver}/atl2.conf
62 /lib/modules/%{_kernel_ver}/kernel/drivers/net/atl2*.ko*
This page took 0.049083 seconds and 3 git commands to generate.