]> git.pld-linux.org Git - packages/athcool.git/commitdiff
- DESTDIR support and some other small fixes
authorPaweł Gołaszewski <blues@pld-linux.org>
Tue, 5 Aug 2003 21:59:03 +0000 (21:59 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    athcool-DESTDIR.patch -> 1.1

athcool-DESTDIR.patch [new file with mode: 0644]

diff --git a/athcool-DESTDIR.patch b/athcool-DESTDIR.patch
new file mode 100644 (file)
index 0000000..09b1821
--- /dev/null
@@ -0,0 +1,33 @@
+--- ./Makefile.org     Sat Jun 21 07:38:54 2003
++++ ./Makefile Tue Aug  5 23:58:44 2003
+@@ -11,8 +11,9 @@
+ CC    = gcc
+ LD    = $(CC)
+ RM    = rm -f
+-CFLAGS        = -O2 -Wall
+-LDFLAGS = $(CFLAGS)
++FLAGS = -O2 -Wall
++CFLAGS        =
++LDFLAGS =
+ DEF     = -I. -I$(includedir)
+ LIBPCI  = -lpci
+ LDLIBS        = $(LIBPCI)
+@@ -25,14 +26,14 @@
+ all: $(PACKAGE)
+ $(PACKAGE): $(OBJS)
+-      $(CC) $(CFLAGS) $(OBJS) $(LDLIBS) -o $@
++      $(CC) $(FLAGS) $(CFLAGS) $(OBJS) $(LDLIBS) -o $@
+ install::
+-      install -d $(sbindir)
+-      install -s $(PACKAGE) $(sbindir)
++      install -d $(DESTDIR)$(sbindir)
++      install -s $(PACKAGE) $(DESTDIR)$(sbindir)
+ .c.o:
+-      $(CC) $(CFLAGS) $(DEF) -c $< -o $@
++      $(CC) $(FLAGS) $(CFLAGS) $(DEF) -c $< -o $@
+ clean:
+       -$(RM) $(PACKAGE) *.o core *~ a.out test
This page took 0.084749 seconds and 4 git commands to generate.