]> git.pld-linux.org Git - packages/atftp.git/blob - atftp.spec
- use %useradd/%groupadd macros
[packages/atftp.git] / atftp.spec
1 Summary:        Client for the Trivial File Transfer Protocol (TFTP)
2 Summary(de):    Client für das 'trivial file transfer protocol (tftp)'
3 Summary(fr):    Client pour le « trivial file transfer protocol » (tftp)
4 Summary(pl):    Klient TFTP (Trivial File Transfer Protocol)
5 Summary(tr):    Ýlkel dosya aktarým protokolu (TFTP) için sunucu ve istemci
6 Name:           atftp
7 Version:        0.7
8 Release:        4
9 License:        GPL
10 Group:          Applications/Networking
11 Source0:        ftp://ftp.mamalinux.com/pub/atftp/%{name}-%{version}.tar.gz
12 # Source0-md5:  3b27365772d918050b2251d98a9c7c82
13 Source1:        atftpd.inetd
14 BuildRequires:  autoconf
15 BuildRequires:  automake
16 BuildRequires:  libwrap-devel
17 BuildRequires:  libtool
18 BuildRequires:  rpmbuild(macros) >= 1.202
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 The Trivial File Transfer Protocol (TFTP) is normally used only for
23 booting diskless workstations. This package contains tftp client.
24
25 %description -l de
26 Das trivial file transfer protocol (tftp) wird in der Regel nur zum
27 Booten von disklosen Workstations benutzt. Es bietet nur geringe
28 Sicherheit und sollte nur im Bedarfsfall aktiviert werden.
29
30 %description -l fr
31 Le « trivial file transfer protocol » (tftp) est normalement utilisé
32 uniquement pour démarrer les stations de travail sans disque. Il offre
33 très peu de sécurité et ne devrait pas être activé sauf si c'est
34 nécessaire.
35
36 %description -l pl
37 Tftp (trivial file transfer protocol) jest u¿ywany g³ównie do
38 startowania stacji bezdyskowych z sieci. Pakiet ten zawiera aplikacjê
39 tftp klienta.
40
41 %description -l tr
42 Ýlkel dosya aktarým protokolu genelde disksiz iþ istasyonlarýnýn að
43 üzerinden açýlmalarýnda kullanýlýr. Güvenlik denetimleri çok az
44 olduðundan zorunlu kalmadýkça çalýþtýrýlmamalýdýr.
45
46 %package -n atftpd
47 Summary:        Daemon for the trivial file transfer protocol (tftp)
48 Summary(de):    Dämon für das 'trivial file transfer protocol (tftp)'
49 Summary(fr):    Démon pour le « trivial file transfer protocol » (tftp)
50 Summary(pl):    Serwer tftp (trivial file transfer protocol)
51 Summary(tr):    Ýlkel dosya aktarým protokolu (TFTP) için sunucu ve istemci
52 Group:          Networking/Daemons
53 PreReq:         rc-inetd >= 0.8.1
54 Requires(pre):  /bin/id
55 Requires(pre):  /usr/sbin/useradd
56 Requires(postun):       /usr/sbin/userdel
57 Provides:       tftpdaemon
58 Provides:       user(tftp)
59 Obsoletes:      inetutils-tftpd
60 Obsoletes:      tftpd
61 Obsoletes:      tftpd-hpa
62 Obsoletes:      tftp-server
63 Obsoletes:      utftpd
64
65 %description -n atftpd
66 The Trivial File Transfer Protocol (TFTP) is normally used only for
67 booting diskless workstations. The tftp package provides the user
68 interface for TFTP, which allows users to transfer files to and from a
69 remote machine. It provides very little security, and should not be
70 enabled unless it is needed.
71
72 %description -n atftpd -l de
73 Das trivial file transfer protocol (tftp) wird in der Regel nur zum
74 Booten von disklosen Workstations benutzt. Es bietet nur geringe
75 Sicherheit und sollte nur im Bedarfsfall aktiviert werden.
76
77 %description -n atftpd -l fr
78 Le « trivial file transfer protocol » (tftp) est normalement utilisé
79 uniquement pour démarrer les stations de travail sans disque. Il offre
80 très peu de sécurité et ne devrait pas être activé sauf si c'est
81 nécessaire.
82
83 %description -n atftpd -l pl
84 TFTP (Trivial File Transfer Protocol) jest u¿ywany g³ównie do
85 startowania stacji bezdyskowych z sieci. Serwer tftp powinien byæ
86 instalowany tylko wtedy, kiedy zachodzi taka konieczno¶æ poniewa¿
87 nale¿y on do aplikacji o niskim poziomie bezpieczeñstwa.
88
89 %prep
90 %setup -q
91
92 %build
93 rm -f missing
94 %{__libtoolize}
95 %{__aclocal}
96 %{__automake}
97 %{__autoconf}
98 %configure
99 %{__make}
100
101 %install
102 rm -rf $RPM_BUILD_ROOT
103 install -d $RPM_BUILD_ROOT{%{_bindir},%{_sbindir},/etc/sysconfig/rc-inetd} \
104         $RPM_BUILD_ROOT{%{_mandir}/man{1,8},/var/lib/tftp}
105
106 install atftpd $RPM_BUILD_ROOT%{_sbindir}
107 install atftp $RPM_BUILD_ROOT%{_bindir}
108 install *.8 $RPM_BUILD_ROOT%{_mandir}/man8/
109 install *.1 $RPM_BUILD_ROOT%{_mandir}/man1/
110
111 install %{SOURCE1} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/tftpd
112
113 %clean
114 rm -rf $RPM_BUILD_ROOT
115
116 %pre -n atftpd
117 %useradd -u 15 -r -d /var/lib/tftp -s /bin/false -c "TFTP User" -g ftp tftp
118
119 %post -n atftpd
120 if [ -f /var/lock/subsys/rc-inetd ]; then
121         /etc/rc.d/init.d/rc-inetd reload 1>&2
122 else
123         echo "Type \"/etc/rc.d/init.d/rc-inetd start\" to start inet server." 1>&2
124 fi
125
126 %postun -n atftpd
127 if [ "$1" = "0" -a -f /var/lock/subsys/rc-inetd ]; then
128         /etc/rc.d/init.d/rc-inetd reload
129 fi
130 if [ "$1" = "0" ]; then
131         %userremove tftp
132 fi
133
134 %files
135 %defattr(644,root,root,755)
136 %attr(755,root,root) %{_bindir}/*
137 %{_mandir}/man1/*
138
139 %files -n atftpd
140 %defattr(644,root,root,755)
141 %doc README FAQ
142 %attr(755,root,root) %{_sbindir}/*
143 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/sysconfig/rc-inetd/tftpd
144 %attr(750,tftp,root) %dir /var/lib/tftp
145 %{_mandir}/man8/*
This page took 0.088576 seconds and 3 git commands to generate.