]> git.pld-linux.org Git - packages/atermlib.git/blob - atermlib.spec
661fc8d0995627a5e143802904be4de02bc6c917
[packages/atermlib.git] / atermlib.spec
1 Summary:        The ATerm Library
2 Name:           atermlib
3 Version:        2.5
4 Release:        1
5 License:        LGPL
6 Group:          Development
7 Source0:        http://ftp.strategoxt.org/pub/stratego/StrategoXT/strategoxt-0.17/aterm-%{version}.tar.gz
8 # Source0-md5:  33ddcb1a229baf406ad1f603eb1d5995
9 Patch0:         https://svn.nixos.org/repos/nix/nixpkgs/trunk/pkgs/development/libraries/aterm/max-long.patch
10 # Patch0-md5:   0c7e50b3686a079959e7c978af9444db
11 Patch1:         strdup.patch
12 URL:            http://www.cwi.nl/htbin/sen1/twiki/bin/view/SEN1/ATermLibrary
13 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
14
15 %description
16 ATerm (short for Annotated Term) is an abstract data type designed for
17 the exchange of tree-like data structures between distributed
18 applications.
19
20 The ATerm library forms a comprehensive procedural interface which
21 enables creation and manipulation of ATerms in C and Java. The ATerm
22 implementation is based on maximal subterm sharing and automatic
23 garbage collection.
24
25 A binary exchange format for the concise representation of ATerms
26 (sharing preserved) allows the fast exchange of ATerms between
27 applications. In a typical application---parse trees which contain
28 considerable redundant information---less than 2 bytes are needed to
29 represent a node in memory, and less than 2 bits are needed to
30 represent it in binary format. The implementation of ATerms scales up
31 to the manipulation of ATerms in the giga-byte range.
32
33 Programming
34
35 The ATerm library provides a comprehensive interface in C and Java to
36 handle the annotated term data-type in an efficient manner. If the
37 terms you handle are limited to a specific signature, you can use
38 ApiGen to generate typed interfaces to the same ATerms.
39
40 %prep
41 %setup -q -n aterm-%{version}
42 %patch0 -p1
43 %patch1 -p1
44
45 %build
46 CFLAGS="%{rpmcflags} -D__NO_CTYPE"
47 %configure \
48         --disable-static
49 %{__make} -j1
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53 %{__make} install \
54         INSTALL="install -p" \
55         DESTDIR=$RPM_BUILD_ROOT
56
57 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libATerm.la
58
59 %clean
60 rm -rf $RPM_BUILD_ROOT
61
62 %files
63 %defattr(644,root,root,755)
64 %attr(755,root,root) %{_bindir}/atdiff
65 %attr(755,root,root) %{_bindir}/atrmannos
66 %attr(755,root,root) %{_bindir}/atsum
67 %attr(755,root,root) %{_bindir}/baf2taf
68 %attr(755,root,root) %{_bindir}/baf2trm
69 %attr(755,root,root) %{_bindir}/baffle
70 %attr(755,root,root) %{_bindir}/dicttoc
71 %attr(755,root,root) %{_bindir}/taf2baf
72 %attr(755,root,root) %{_bindir}/taf2trm
73 %attr(755,root,root) %{_bindir}/termsize
74 %attr(755,root,root) %{_bindir}/trm2baf
75 %attr(755,root,root) %{_bindir}/trm2taf
76 %attr(755,root,root) %{_bindir}/trmcat
77 %{_includedir}/abool.h
78 %{_includedir}/afun.h
79 %{_includedir}/aterm1.h
80 %{_includedir}/aterm2.h
81 %{_includedir}/atypes.h
82 %{_includedir}/deprecated.h
83 %{_includedir}/encoding.h
84 %attr(755,root,root) %{_libdir}/libATerm.so
85 %{_pkgconfigdir}/aterm.pc
This page took 0.051902 seconds and 2 git commands to generate.