]> git.pld-linux.org Git - packages/aterm.git/blob - aterm.spec
- initial version.
[packages/aterm.git] / aterm.spec
1 %define name aterm
2 %define version 0.3.4
3 %define release 1
4 %define serial 1
5
6 Summary: aterm - terminal emulator in an X window
7 Name: %{name}
8 Version: %{version}
9 Release:%{release}
10 Epoch: %{serial}
11 Copyright: GPL
12 Group: X11/Utilities
13 Vendor: Sasha Vasko <sashav@sprintmail.com>
14 URL: http://members.xoom.com/sashav/aterm
15 Distribution: Freshmeat RPMs
16 Packager: Ryan Weaver <ryanw@infohwy.com>
17 Source: http://members.xoom.com/sashav/aterm/%{name}-%{version}.tar.gz
18 Source1: aterm.wmconfig
19 Buildroot: /tmp/%{name}-%{version}-root
20
21 %description
22 aterm, version %{version}, is a colour vt102 terminal emulator based on
23 rxvt 2.4.8 with Alfredo Kojima's additions of fast transparency,
24 intended as an xterm(1) replacement for users who do not require
25 features such as Tektronix 4014 emulation and toolkit-style
26 configurability. As a result, aterm uses much less swap space -- a
27 significant advantage on a machine serving many X sessions.
28
29 It was created with AfterStep Window Manger users in mind, but is not
30 tied to any libraries, and can be used anywhere.
31
32 %prep
33 %setup -q
34
35 CFLAGS="$RPM_OPT_FLAGS" ./configure --prefix=/usr/X11R6 \
36         --enable-utmp --enable-wtmp --enable-background-image \
37         --with-png --with-jpeg \
38         --enable-transparency --enable-menubar --enable-graphics \
39         --enable-next-scroll --disable-backspace-key \
40         --disable-delete-key --enable-xgetdefault
41
42 %build
43 make
44
45 %install
46 if [ -d $RPM_BUILD_ROOT ]; then rm -rf $RPM_BUILD_ROOT; fi
47 mkdir -p $RPM_BUILD_ROOT/usr/X11R6
48 mkdir -p $RPM_BUILD_ROOT/etc/X11/wmconfig
49
50 make prefix=$RPM_BUILD_ROOT/usr/X11R6 install
51 install -m 644 $RPM_SOURCE_DIR/aterm.wmconfig $RPM_BUILD_ROOT/etc/X11/wmconfig/aterm
52
53 %clean
54 rm -rf $RPM_BUILD_ROOT
55
56 %files
57 %defattr(-,root,root)
58 %doc doc ChangeLog
59 /usr/X11R6/bin/aterm
60 /usr/X11R6/man/man1/aterm.1
61 %config(missingok) /etc/X11/wmconfig/aterm
62
63 %changelog
64 * Fri Feb 26 1999 Ryan Weaver <ryanw@infohwy.com>
65   [aterm-0.3.4-1]
66
67 - main.c: (SetBackgroundType()) - now correctly checks for shading being 100
68   and allows for fast transparency/tinting in that case. That brings fast 
69   transparency back in bussiness.
70 - main.c: (resize_windows()) - now checks if root background has changed, and
71   updates window even if it was not moved in this case. 
72 - main.c: (resize_windows()) - removed strange event checking loop so to get 
73   rid of unresized window problem, when resizing very fast.
74 - screen.c: (CLEAR_CHARS(),CLEAR_ROWS()) - hopefully fixed random occuring bug
75   when parts of the window close to the border were not cleared sometimes.
76 - main.c: (resize_windows()) - fixed bug when window contents gets flushed on
77   window move, if compiled without transparency and background image. 
78 - command.c: (process_x_event()) ReparentNotify message handler fixed to
79   set parent windows backgrounds to ParentRelative in any transparency mode -
80   that should fix problems that KDE users were having with it. 
81   Also XErrorHandler is set here to prevent crashes on Window Manager restarts.
82 - ximage_utils.c: (ShadeXImage()) moved here from pixmap.c
83 - ximage_utils.c: added some ifdefs to enable easy porting to/from AfterStep
84 - ximage_utils.c: (ShadeXImage()) - uses correct data types for pointers - as
85   the result shading should work fine now on 64-bit CPUs
86 - pixmap.c: (GetMyPosition()) split in two - GetWinPosition() - more generic
87   function.
88 - pixmap.c: (GetMyPosition()) now sets error handler to prevent crashes - when
89   restarting window manager.
90 - pixmap.c: (ValidateSrcPixmap()) split in two ValidatePixmap() - is more 
91   generic version. ValidateSrcPixmap() is resetting root background ID if it 
92   changed.
93 - pixmap.c: (CutPixmap()) chaged to more generic CutWinPixmap().
94 - pixmap.c: changed to reflect all this changes above.
95 - configure.in: minor changes to improve libasimage detection.   
96 - rxvt.h: SB_WIDTH and other scrollbar parameters has been moved to feature.h
97   so ppl don't have to edit rxvt.h every time they upgrade.
98
99 * Mon Feb 22 1999 Ryan Weaver <ryanw@infohwy.com>
100   [aterm-0.3.3-1]
101 - Added -sh %, -bgtype <type>, -txttype <type>, -tinttype <type> options.
102 - Changed -tint to -tint <color> to make possible different background and 
103   tinting colors.
104 - Changed -pixmap <file[;geom]> meaning of geom now is the area of original 
105   image, to be cut out, and used as the background. 
106 - src/pixmap.c: complete rewrite of everything that was in there, to enable
107   all those cool transformations. Includes Shading functions, stretching/
108   scaling/etc function, capturing of the root background, if root pixmap ID is
109   not available.X errors handling to prevent crashing.
110 - Added ximage_utils.c from AfterStep's libasimage, to be used when libasimage
111   cannot be found, or linked with.
112 - rxvt.h: Added ShadingInfo and BackgroundInfo structures to hold all 
113   background image information. Respectively TermWin.background  member was 
114   added
115 - rxvt.h: added one more color definition : tintColor
116 - rxvt.h: added variables to hold all those new options.
117 - main.c: added Background information initialization functions, and textType,
118   tintType, and bgType parsing functions.
119 - main.c: (CreateWindows())tintGC only created if we do fast transparency.
120 - main.c: (CreateWindows())text GC is created using txttype option's function.
121 - main.c: (resize_window())completely reworked to accomodate all new 
122   capabilities. It now checks for visibility, changed absolute position and 
123   size of the window prior to do any tinting/shading/rendering. That sometimes
124   causing aterm not to perform shading on startup - will fix later.
125 - main.c: (resize_window1())does not do scr_clear() anymore - it's done 
126   outside of it if needed.
127 - command.c: PropertyChanged event handler modifyed to check for visibility
128   prior to do tinting/shading/rendering.
129 - screen.c: fast tinting is performed only if tintGC is available, instead
130   of checking for Opt_tint.
131 - command.c: added Rafal Wierzbicki changes to support for Unix98 ptys with 
132   linux-2.2.x and glibc-2.1
133 - added tools dir, and tools/makeatermversion script to automate new aterm 
134   version creating/tar-balling.
135 - man pages hopefully updated. 
136
137 * Sat Jan 16 1999 Ryan Weaver <ryanw@infohwy.com>
138   [aterm-0.3.2-1]
139 - src/rxvt.h ParentWin1, ParentWin2 changed to array, first elem of which 
140   should always be main window of aterm (TermWin.parent)
141 - src/main.c (resize_window()) added check for event code, not only event 
142   type, when checking for queued resizing events.
143   That allows filtering of events that has nothing to do with resizing,
144   and fixes screen refresh problems when aterm is mapped/unmapped.
145 - src/screen.c (scr_clear_tint()) removed ClearWindow for parent windows.
146   That seems to be unneccessary and that was causing aterm death on 
147   window manager restart.
148 - src/main.c (resize_window()) changed to not query size of toppest parent 
149   window as far as it can become invalid on window manager's restart. 
150   That was also causing aterm's death on Window Manager restarts.
151
152 * Thu Jan 14 1999 Ryan Weaver <ryanw@infohwy.com>
153   [aterm-0.3.1-1]
154 - src/command.c (process_x_event()) added check for _XROOTPMAP_ID value -
155   so not to refresh screen when it's None - that fixes problem with aterm
156   dieing on AfterStep restart.
157
158
159 * Thu Jan 14 1999 Ryan Weaver <ryanw@infohwy.com>
160   [aterm-0.3.0-1]
161 - started new development version. USE IT WITH CAUTION !!!
162 - Changed --enable-background-xpm to --enable-background-image. Due to wider
163   image format support it makes better sense.
164 - Added optional integration with AfterStep libraries for wider image format
165   support. JPEG and PNG images can now be used as background, 
166   if shared AfterStep libraries are installed on system.
167   libJPEG v.6.0a and/or libPNG v.1.0.2 or greater required.
168   Imaging library detection macros has been taken from AfterStep distribution.
169   AfterStep libs will only be used if configured with --enable-background-image
170   flag.
171 - --enable-aftersteplibs configure flag added to enable/disable AfterStep
172   integration. Enabled by default. 
173 - the following configure options added to enable/disable image library usage :
174   --with-xpm-includes=DIR use XPM includes in DIR
175   --with-xpm-library=DIR  use XPM library in DIR
176   --with-xpm              use XPM
177   --with-jpeg-includes=DIR use JPEG includes in DIR
178   --with-jpeg-library=DIR  use JPEG library in DIR
179   --with-jpeg              support JPEG image format [yes]
180   --with-png-includes=DIR use PNG includes in DIR
181   --with-png-library=DIR  use PNG library in DIR
182   --with-png              support PNG image format [yes]
183 - src/feature.h removed obsolete code for XPM_BUFFERING support.
184 - src/main.c (resize_window()) fixed bug when transparent background gets 
185   garbled, when Shading/Unshading aterm in AfterStep.
186 - src/screen.c scr_clear() changed into scr_clear_tint(int bWithTinting) 
187   to enable/disable tinting while clearing window. scr_clear() is now
188   a macro calling scr_clear_tint(1).
189 - src/screen.c (scr_clear_tint()) fixed minor bug in tinting code
190   to use TermWin_internalBorder instead of BORDERWIDTH
191 - src/screen.c (CLEAR_CHARS(),CLEAR_ROWS()) fixed bug when clearing
192   screen will keep tine border around window untinted.
193   ( based on contribution from Michael Bruun Petersen" <mbp@image.dk>)
194 - src/main.c added (SetBackgroundPixmap(char* PixmapSpec)) to parse pixmap
195   specification load/scale pixmap.
196 - src/main.c (change_font()) added sanity check for font width, that will
197   hopefully prevent aterm from crashing, when using some fonts.
198   ( thanks to <suchness> for suggestion ).
199 - src/xpm.c moved to src/pixmap.c due to wider image format support that
200   makes better sense.
201 - src/pixmap.c removed obsolete code for XPM_BUFFERING
202 - src/pixmap.c (set_bgPixmap()) modifyed for optional utilization of 
203   AfterStep libraries.
204 - src/pixmap.c (resize_pixmap()) added support to prevent pixmap from 
205   tiling vertical, horizontal or in both directions. See src/feature.h
206   to enable/disable this.
207   ( contributed by Eric Tremblay <deltax@dsuper.net> )
208 - src/rxvt.h   added :
209   #include <sys/int_types.h> 
210   to fix compilation problems on some Solaris boxes.
211   ( suggested by Albert Dorofeev <tigr@tigr.net> )
212 - src/scrollbar2.c rewrote NeXT scrollbar code for better portability
213   and configurability. Now scrollbar width and look can be changed at 
214   compile time, using options in rxvt.h.
215 - src/rxvt.h added bunch of defines to enable NeXT scrollbar tweaking at 
216   compile time:
217     /* could be anything from 13 to 19  but the true NeXT is 17 */ 
218     # define SB_WIDTH           17 
219     /* this will define somemore parameters for shaping NeXTish scrollbars */
220     /* NEXT_SCROLL_CLEAN if defined removes shades of gray from buttons */
221     # undef NEXT_SCROLL_CLEAN   
222     # define NEXT_SCROLL_SQUARE_ARROWS 
223     # define SB_BORDER_WIDTH 1
224     /* this makes buttons thinner then scrollbar's base ( if more then 0 ) */ 
225     # define SIDE_STEP_WIDTH 0
226     /* end NeXT scrollbar specific fetures */
227
228 * Thu Dec 31 1998 Ryan Weaver <ryanw@infohwy.com>
229   [aterm-0.2.0-1]
230 - First RPM
231 - *Converted documentation to aterm vs. rxvt
232 - *src/features.h [ATERM_PATH_ENV]: Added ATERMPATH env. variable to
233   define PATH where to search for files. Aterm is now looking in ATERMPATH,
234   then RXVTPATH, and only then in PATH.
235 - * --enable-transparency and --enable-next-scroll are now set by default.
This page took 0.05815 seconds and 4 git commands to generate.