]> git.pld-linux.org Git - packages/aterm.git/blob - aterm.spec
s/%{_target}/%{_target_platform}/
[packages/aterm.git] / aterm.spec
1 %define name aterm
2 %define version 0.3.4
3 %define release 1
4 %define serial 1
5
6 Summary: aterm - terminal emulator in an X window
7 Name: %{name}
8 Version: %{version}
9 Release:%{release}
10 Epoch: %{serial}
11 Copyright: GPL
12 Group: X11/Utilities
13 Vendor: Sasha Vasko <sashav@sprintmail.com>
14 URL: http://members.xoom.com/sashav/aterm
15 Distribution: Freshmeat RPMs
16 Packager: Ryan Weaver <ryanw@infohwy.com>
17 Source: http://members.xoom.com/sashav/aterm/%{name}-%{version}.tar.gz
18 Source1: aterm.wmconfig
19 BuildRoot:      /tmp/%{name}-%{version}-root
20
21 %description
22 aterm, version %{version}, is a colour vt102 terminal emulator based on
23 rxvt 2.4.8 with Alfredo Kojima's additions of fast transparency,
24 intended as an xterm(1) replacement for users who do not require
25 features such as Tektronix 4014 emulation and toolkit-style
26 configurability. As a result, aterm uses much less swap space -- a
27 significant advantage on a machine serving many X sessions.
28
29 It was created with AfterStep Window Manger users in mind, but is not
30 tied to any libraries, and can be used anywhere.
31
32 %prep
33 %setup -q
34
35 CFLAGS="$RPM_OPT_FLAGS" LDFLAGS="-s" \
36 ./configure %{_target_platform} \
37         --prefix=/usr/X11R6 \
38         --enable-utmp \
39         --enable-wtmp \
40         --enable-background-image \
41         --with-png \
42         --with-jpeg \
43         --enable-transparency \
44         --enable-menubar \
45         --enable-graphics \
46         --enable-next-scroll \
47         --disable-backspace-key \
48         --disable-delete-key \
49         --enable-xgetdefault
50
51 %build
52 make
53
54 %install
55 if [ -d $RPM_BUILD_ROOT ]; then rm -rf $RPM_BUILD_ROOT; fi
56 mkdir -p $RPM_BUILD_ROOT/usr/X11R6
57 mkdir -p $RPM_BUILD_ROOT/etc/X11/wmconfig
58
59 make prefix=$RPM_BUILD_ROOT/usr/X11R6 install
60 install -m 644 $RPM_SOURCE_DIR/aterm.wmconfig $RPM_BUILD_ROOT/etc/X11/wmconfig/aterm
61
62 %clean
63 rm -rf $RPM_BUILD_ROOT
64
65 %files
66 %defattr(-,root,root)
67 %doc doc ChangeLog
68 /usr/X11R6/bin/aterm
69 /usr/X11R6/man/man1/aterm.1
70 %config(missingok) /etc/X11/wmconfig/aterm
71
72 %changelog
73 * Fri Feb 26 1999 Ryan Weaver <ryanw@infohwy.com>
74   [aterm-0.3.4-1]
75
76 - main.c: (SetBackgroundType()) - now correctly checks for shading being 100
77   and allows for fast transparency/tinting in that case. That brings fast 
78   transparency back in bussiness.
79 - main.c: (resize_windows()) - now checks if root background has changed, and
80   updates window even if it was not moved in this case. 
81 - main.c: (resize_windows()) - removed strange event checking loop so to get 
82   rid of unresized window problem, when resizing very fast.
83 - screen.c: (CLEAR_CHARS(),CLEAR_ROWS()) - hopefully fixed random occuring bug
84   when parts of the window close to the border were not cleared sometimes.
85 - main.c: (resize_windows()) - fixed bug when window contents gets flushed on
86   window move, if compiled without transparency and background image. 
87 - command.c: (process_x_event()) ReparentNotify message handler fixed to
88   set parent windows backgrounds to ParentRelative in any transparency mode -
89   that should fix problems that KDE users were having with it. 
90   Also XErrorHandler is set here to prevent crashes on Window Manager restarts.
91 - ximage_utils.c: (ShadeXImage()) moved here from pixmap.c
92 - ximage_utils.c: added some ifdefs to enable easy porting to/from AfterStep
93 - ximage_utils.c: (ShadeXImage()) - uses correct data types for pointers - as
94   the result shading should work fine now on 64-bit CPUs
95 - pixmap.c: (GetMyPosition()) split in two - GetWinPosition() - more generic
96   function.
97 - pixmap.c: (GetMyPosition()) now sets error handler to prevent crashes - when
98   restarting window manager.
99 - pixmap.c: (ValidateSrcPixmap()) split in two ValidatePixmap() - is more 
100   generic version. ValidateSrcPixmap() is resetting root background ID if it 
101   changed.
102 - pixmap.c: (CutPixmap()) chaged to more generic CutWinPixmap().
103 - pixmap.c: changed to reflect all this changes above.
104 - configure.in: minor changes to improve libasimage detection.   
105 - rxvt.h: SB_WIDTH and other scrollbar parameters has been moved to feature.h
106   so ppl don't have to edit rxvt.h every time they upgrade.
107
108 * Mon Feb 22 1999 Ryan Weaver <ryanw@infohwy.com>
109   [aterm-0.3.3-1]
110 - Added -sh %, -bgtype <type>, -txttype <type>, -tinttype <type> options.
111 - Changed -tint to -tint <color> to make possible different background and 
112   tinting colors.
113 - Changed -pixmap <file[;geom]> meaning of geom now is the area of original 
114   image, to be cut out, and used as the background. 
115 - src/pixmap.c: complete rewrite of everything that was in there, to enable
116   all those cool transformations. Includes Shading functions, stretching/
117   scaling/etc function, capturing of the root background, if root pixmap ID is
118   not available.X errors handling to prevent crashing.
119 - Added ximage_utils.c from AfterStep's libasimage, to be used when libasimage
120   cannot be found, or linked with.
121 - rxvt.h: Added ShadingInfo and BackgroundInfo structures to hold all 
122   background image information. Respectively TermWin.background  member was 
123   added
124 - rxvt.h: added one more color definition : tintColor
125 - rxvt.h: added variables to hold all those new options.
126 - main.c: added Background information initialization functions, and textType,
127   tintType, and bgType parsing functions.
128 - main.c: (CreateWindows())tintGC only created if we do fast transparency.
129 - main.c: (CreateWindows())text GC is created using txttype option's function.
130 - main.c: (resize_window())completely reworked to accomodate all new 
131   capabilities. It now checks for visibility, changed absolute position and 
132   size of the window prior to do any tinting/shading/rendering. That sometimes
133   causing aterm not to perform shading on startup - will fix later.
134 - main.c: (resize_window1())does not do scr_clear() anymore - it's done 
135   outside of it if needed.
136 - command.c: PropertyChanged event handler modifyed to check for visibility
137   prior to do tinting/shading/rendering.
138 - screen.c: fast tinting is performed only if tintGC is available, instead
139   of checking for Opt_tint.
140 - command.c: added Rafal Wierzbicki changes to support for Unix98 ptys with 
141   linux-2.2.x and glibc-2.1
142 - added tools dir, and tools/makeatermversion script to automate new aterm 
143   version creating/tar-balling.
144 - man pages hopefully updated. 
145
146 * Sat Jan 16 1999 Ryan Weaver <ryanw@infohwy.com>
147   [aterm-0.3.2-1]
148 - src/rxvt.h ParentWin1, ParentWin2 changed to array, first elem of which 
149   should always be main window of aterm (TermWin.parent)
150 - src/main.c (resize_window()) added check for event code, not only event 
151   type, when checking for queued resizing events.
152   That allows filtering of events that has nothing to do with resizing,
153   and fixes screen refresh problems when aterm is mapped/unmapped.
154 - src/screen.c (scr_clear_tint()) removed ClearWindow for parent windows.
155   That seems to be unneccessary and that was causing aterm death on 
156   window manager restart.
157 - src/main.c (resize_window()) changed to not query size of toppest parent 
158   window as far as it can become invalid on window manager's restart. 
159   That was also causing aterm's death on Window Manager restarts.
160
161 * Thu Jan 14 1999 Ryan Weaver <ryanw@infohwy.com>
162   [aterm-0.3.1-1]
163 - src/command.c (process_x_event()) added check for _XROOTPMAP_ID value -
164   so not to refresh screen when it's None - that fixes problem with aterm
165   dieing on AfterStep restart.
166
167
168 * Thu Jan 14 1999 Ryan Weaver <ryanw@infohwy.com>
169   [aterm-0.3.0-1]
170 - started new development version. USE IT WITH CAUTION !!!
171 - Changed --enable-background-xpm to --enable-background-image. Due to wider
172   image format support it makes better sense.
173 - Added optional integration with AfterStep libraries for wider image format
174   support. JPEG and PNG images can now be used as background, 
175   if shared AfterStep libraries are installed on system.
176   libJPEG v.6.0a and/or libPNG v.1.0.2 or greater required.
177   Imaging library detection macros has been taken from AfterStep distribution.
178   AfterStep libs will only be used if configured with --enable-background-image
179   flag.
180 - --enable-aftersteplibs configure flag added to enable/disable AfterStep
181   integration. Enabled by default. 
182 - the following configure options added to enable/disable image library usage :
183   --with-xpm-includes=DIR use XPM includes in DIR
184   --with-xpm-library=DIR  use XPM library in DIR
185   --with-xpm              use XPM
186   --with-jpeg-includes=DIR use JPEG includes in DIR
187   --with-jpeg-library=DIR  use JPEG library in DIR
188   --with-jpeg              support JPEG image format [yes]
189   --with-png-includes=DIR use PNG includes in DIR
190   --with-png-library=DIR  use PNG library in DIR
191   --with-png              support PNG image format [yes]
192 - src/feature.h removed obsolete code for XPM_BUFFERING support.
193 - src/main.c (resize_window()) fixed bug when transparent background gets 
194   garbled, when Shading/Unshading aterm in AfterStep.
195 - src/screen.c scr_clear() changed into scr_clear_tint(int bWithTinting) 
196   to enable/disable tinting while clearing window. scr_clear() is now
197   a macro calling scr_clear_tint(1).
198 - src/screen.c (scr_clear_tint()) fixed minor bug in tinting code
199   to use TermWin_internalBorder instead of BORDERWIDTH
200 - src/screen.c (CLEAR_CHARS(),CLEAR_ROWS()) fixed bug when clearing
201   screen will keep tine border around window untinted.
202   ( based on contribution from Michael Bruun Petersen" <mbp@image.dk>)
203 - src/main.c added (SetBackgroundPixmap(char* PixmapSpec)) to parse pixmap
204   specification load/scale pixmap.
205 - src/main.c (change_font()) added sanity check for font width, that will
206   hopefully prevent aterm from crashing, when using some fonts.
207   ( thanks to <suchness> for suggestion ).
208 - src/xpm.c moved to src/pixmap.c due to wider image format support that
209   makes better sense.
210 - src/pixmap.c removed obsolete code for XPM_BUFFERING
211 - src/pixmap.c (set_bgPixmap()) modifyed for optional utilization of 
212   AfterStep libraries.
213 - src/pixmap.c (resize_pixmap()) added support to prevent pixmap from 
214   tiling vertical, horizontal or in both directions. See src/feature.h
215   to enable/disable this.
216   ( contributed by Eric Tremblay <deltax@dsuper.net> )
217 - src/rxvt.h   added :
218   #include <sys/int_types.h> 
219   to fix compilation problems on some Solaris boxes.
220   ( suggested by Albert Dorofeev <tigr@tigr.net> )
221 - src/scrollbar2.c rewrote NeXT scrollbar code for better portability
222   and configurability. Now scrollbar width and look can be changed at 
223   compile time, using options in rxvt.h.
224 - src/rxvt.h added bunch of defines to enable NeXT scrollbar tweaking at 
225   compile time:
226     /* could be anything from 13 to 19  but the true NeXT is 17 */ 
227     # define SB_WIDTH           17 
228     /* this will define somemore parameters for shaping NeXTish scrollbars */
229     /* NEXT_SCROLL_CLEAN if defined removes shades of gray from buttons */
230     # undef NEXT_SCROLL_CLEAN   
231     # define NEXT_SCROLL_SQUARE_ARROWS 
232     # define SB_BORDER_WIDTH 1
233     /* this makes buttons thinner then scrollbar's base ( if more then 0 ) */ 
234     # define SIDE_STEP_WIDTH 0
235     /* end NeXT scrollbar specific fetures */
236
237 * Thu Dec 31 1998 Ryan Weaver <ryanw@infohwy.com>
238   [aterm-0.2.0-1]
239 - First RPM
240 - *Converted documentation to aterm vs. rxvt
241 - *src/features.h [ATERM_PATH_ENV]: Added ATERMPATH env. variable to
242   define PATH where to search for files. Aterm is now looking in ATERMPATH,
243   then RXVTPATH, and only then in PATH.
244 - * --enable-transparency and --enable-next-scroll are now set by default.
This page took 0.076381 seconds and 4 git commands to generate.