]> git.pld-linux.org Git - packages/at.git/blob - at.spec
- added Requires: mailx
[packages/at.git] / at.spec
1 Summary:        at job spooler
2 Summary(de):    at-Job-Spooler
3 Summary(fr):    Gestionnaire de taches at.
4 Summary(pl):    Demon kontroli zadañ
5 Summary(tr):    þ düzenleyici
6 Name:           at
7 Version:        3.1.8
8 Release:        4
9 Copyright:      GPL
10 Group:          Daemons
11 Group(pl):      Serwery
12 URL:            ftp://jurix.jura.uni-sb.de/pub/linux/sources/system/daemons
13 Source0:        %{name}-%{version}.tar.gz
14 Source1:        %{name}d.init
15 Patch0:         %{name}-lockfile.patch
16 Patch1:         %{name}-install.patch
17 Patch2:         %{name}-man.patch
18 Patch3:         %{name}-batch.patch
19 Buildroot:      /tmp/%{name}-%{version}-root
20 Prereq:         fileutils
21 Prereq:         /sbin/chkconfig
22 Requires:       mailx
23
24 %description
25 at and batch read commands from standard input or a specified file
26 which are to be executed at a later time, using /bin/sh.
27
28 %description -l de
29 Stapelverarbeitung von Lesebefehlen von einer Standard- oder einer 
30 genannten Datei zu einem späteren Zeitpunkt unter Verwendung von /bin/sh.
31
32 %description -l fr
33 at et batch lisent, sur l'entrée standard ou dans un fichier, des
34 commandes qui doivent être exécutées plus tard en utilisant /bin/sh.
35
36 %description -l pl
37 At i batch czytaj± komendy ze standardowego wej¶cia lub specyficznego pliku,
38 które s± nastêpnie wykonywane o okre¶lonej godzinie, przy pomocy /bin/sh.
39
40 %description -l tr
41 at ve batch /bin/sh kabuðunu kullanarak, belli bir saatte çalýþtýrmak üzere
42 standart giriþden ya da bir dosyadan komut okur.
43
44 %prep
45 %setup -q
46 %patch0 -p1 
47 %patch1 -p1 
48 %patch2 -p1 
49 %patch3 -p1 
50
51 %build
52 autoconf
53 CFLAGS=$RPM_OPT_FLAGS LDFLAGS=-s \
54 ./configure \
55         --with-atspool=/var/spool/at/spool \
56         --with-jobdir=/var/spool/at \
57         --with-etcdir=/etc/at
58 make 
59
60 %install
61 rm -rf $RPM_BUILD_ROOT
62
63 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
64
65 make install IROOT=$RPM_BUILD_ROOT
66
67 install at.deny $RPM_BUILD_ROOT/etc/at/at.deny
68 touch   $RPM_BUILD_ROOT/etc/at/at.allow
69
70 mv $RPM_BUILD_ROOT/usr/doc/at $RPM_BUILD_ROOT/usr/doc/%{name}-%{version}
71
72 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/atd
73
74 rm -f $RPM_BUILD_ROOT/usr/man/man1/{atq,atrm,batch}.1
75 rm -f $RPM_BUILD_ROOT/usr/man/man5/at_deny.5
76
77 echo .so at.1 > $RPM_BUILD_ROOT/usr/man/man1/atq.1
78 echo .so at.1 > $RPM_BUILD_ROOT/usr/man/man1/atrm.1
79 echo .so at.1 > $RPM_BUILD_ROOT/usr/man/man1/batch.1
80
81 echo .so at_allow.5 > $RPM_BUILD_ROOT/usr/man/man5/at_deny.5
82 echo .so at_allow.5 > $RPM_BUILD_ROOT/usr/man/man5/at_acces.5
83
84 touch $RPM_BUILD_ROOT/var/spool/at/.SEQ
85
86 gzip -9fn $RPM_BUILD_ROOT/usr/man/man[158]/* \
87         ChangeLog README
88
89 %clean
90 rm -rf $RPM_BUILD_ROOT
91
92 %post
93 /sbin/chkconfig --add atd
94
95 %preun
96 if [ $1 = 0 ] ; then
97   /sbin/chkconfig --del atd
98 fi
99
100 %files
101 %defattr(644,root,root,755) 
102 %doc {ChangeLog,README}.gz
103
104 %attr(750,root,root) %dir /etc/at
105 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/at/*
106 %attr(750,root,root) /etc/rc.d/init.d/atd
107 %attr(755,root,root) /usr/sbin/*
108
109 %attr(4711,root,root) /usr/bin/at
110
111 %attr(755,root,root) /usr/bin/atq
112 %attr(755,root,root) /usr/bin/atrm
113 %attr(755,root,root) /usr/bin/batch
114
115 /usr/man/man[158]/*
116
117 %attr(700,daemon,daemon) %dir /var/spool/at
118 %attr(700,daemon,daemon) %dir /var/spool/at/spool
119 %attr(600,daemon,daemon) %ghost /var/spool/at/.SEQ
120
121 %changelog
122 * Sun Sep 13 1998 Wojtek ¦lusarczyk <wojtek@shadow.eu.org>
123   [3.1.7-5d]
124 - build against glibc-2.1,
125 - translation modified for pl,
126 - fixed files permissions,
127 - macro %%{name}-%%{version} in Source,
128 - macro %%{name}-%%{version} in Patch,
129 - removed conflicts: crontabs <= 1.5,
130 - added %ghost /var/spool/at/.SEQ,
131 - added %defattr and %doc, 
132 - minor modifications of spec file.
133
134 * Thu Sep  8 1998 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
135   [3.1.7-5]
136 - added -q %setup parameter,
137 - changed Buildroot to /tmp/%%{name}-%%{version}-root,
138 - added using %%{name} and %%{version} in Source,
139 - added using $RPM_OPT_FLAGS during compile,
140 - atq(1), atrm(1), batch(1) man pages are now maked as nroff include to at(1)
141   instead making sym link to at.1 (this allow compress man pages in future),
142 - added using %{SOURCE#} macro in %install,
143 - smarter instaling %doc,
144 - changed permission on some executables.
145 - added %attr and %defattr macros in %files (allow build package from
146   non-root account),
147 - start at RH spec.
This page took 0.736722 seconds and 4 git commands to generate.