]> git.pld-linux.org Git - packages/asterisk.git/commitdiff
- nuke editline copy auto/th/asterisk-1_6_1_12-0_34
authorElan Ruusamäe <glen@pld-linux.org>
Wed, 30 Dec 2009 23:38:58 +0000 (23:38 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- make menuselect only needed for building

Changed files:
    asterisk.spec -> 1.154
    libedit-history.patch -> 1.1

asterisk.spec
libedit-history.patch [new file with mode: 0644]

index 2df31174dcc6ad441b8e0fa62b8b375b6b74a22f..1b2113cf8eca27f2edbed1d0f8f82aa658573ab0 100644 (file)
@@ -3,7 +3,6 @@
 # - use shared versions of lpc10, gsm,...
 # - CFLAGS passing
 # - fix bluetooth patch
-# - system mxml
 # - ~/.asterisk_history gets encoded with \xxx on exit, each time yet again
 # - libpath:
 #   /usr/bin/ld: skipping incompatible /usr/lib/libpthread.so when searching for -lpthread
@@ -33,7 +32,7 @@
 %bcond_without verbose         # verbose build
 
 %define                spandsp_version 0.0.2pre26
-%define                rel     0.32
+%define                rel     0.34
 Summary:       Asterisk PBX
 Summary(pl.UTF-8):     Centralka (PBX) Asterisk
 Name:          asterisk
@@ -58,6 +57,8 @@ Patch4:               %{name}-ppc.patch
 Patch5:                external-libedit.patch
 Patch6:                pkg-config-gmime.patch
 Patch7:                FHS-paths.patch
+Patch8:                libedit-history.patch
+Patch9:                pld-banner.patch
 # http://soft-switch.org/downloads/spandsp/spandsp-%{spandsp_version}/asterisk-1.2.x/apps_Makefile.patch
 Patch10:       %{name}-txfax-Makefile.patch
 Patch12:       %{name}-chan_bluetooth.patch
@@ -238,12 +239,15 @@ Application for the Asterisk PBX that uses Festival to convert text to
 speech.
 
 %package h323
-Summary:       h323 resources for Asterisk
+Summary:       H.323 protocol support for Asterisk
 Group:         Applications/Networking
 Requires:      %{name} = %{version}-%{release}
 
 %description h323
-h323 resources for Asterisk.
+This channel driver (chan_h323) provides support for the H.323 protocol for
+Asterisk. This is an implementation originally contributed by NuFone and
+nowdays maintained and distributed by Digium, Inc. Hence, it is considered the
+official H.323 chanel driver.
 
 %package ices
 Summary:       Stream audio from Asterisk to an IceCast server
@@ -458,6 +462,8 @@ local filesystem.
 %patch5 -p0
 %patch6 -p0
 %patch7 -p0
+%patch8 -p1
+%patch9 -p1
 
 %if %{with zhone}
 sed -i -e 's|.*#define.*ZHONE_HACK.*|#define ZHONE_HACK 1|g' channels/chan_zap.c
@@ -484,7 +490,7 @@ cp %{SOURCE11} .
 %{__sed} -i -e 's/^install:.*$/install:/' sounds/Makefile
 
 # avoid using it
-rm -rf imap menuselect/mxml
+rm -rf imap menuselect/mxml main/editline
 
 %build
 rm -f pbx/.depend
@@ -499,16 +505,17 @@ export WGET="/bin/true"
 
 # be sure to invoke ./configure with our flags
 cd menuselect
-%{__aclocal}
+%{__aclocal} -I ../autoconf
 %{__autoheader}
 %{__autoconf}
-%configure
+# we need just plain cli for building
+%configure \
+  --without-newt \
+  --without-gtk2 \
+  --without-curses \
+  --without-ncurses
 cd ..
 
-cd main/editline
-%configure2_13
-cd ../..
-
 %configure \
        %{?with_bristuff:--with-gsmat=%{_prefix}} \
        --with-imap=system \
diff --git a/libedit-history.patch b/libedit-history.patch
new file mode 100644 (file)
index 0000000..c667596
--- /dev/null
@@ -0,0 +1,38 @@
+--- asterisk-1.6.1.12/main/asterisk.c~ 2009-12-30 23:34:17.000000000 +0200
++++ asterisk-1.6.1.12/main/asterisk.c  2009-12-30 23:34:19.095481746 +0200
+@@ -110,7 +110,7 @@
+ #include "asterisk/utils.h"
+ #include "asterisk/file.h"
+ #include "asterisk/io.h"
+-#include "editline/histedit.h"
++#include <histedit.h>
+ #include "asterisk/config.h"
+ #include "asterisk/ast_version.h"
+ #include "asterisk/linkedlists.h"
+@@ -2291,7 +2291,7 @@
+                       int mlen = 0, maxmbuf = 2048;
+                       /* Start with a 2048 byte buffer */                     
+                       if (!(mbuf = ast_malloc(maxmbuf))) {
+-                              lf->cursor[0] = savechr;
++//                            lf->cursor[0] = savechr; // this is readonly variable
+                               return (char *)(CC_ERROR);
+                       }
+                       snprintf(buf, sizeof(buf), "_COMMAND MATCHESARRAY \"%s\" \"%s\"", lf->buffer, ptr); 
+@@ -2303,7 +2303,7 @@
+                                       /* Every step increment buffer 1024 bytes */
+                                       maxmbuf += 1024;                                        
+                                       if (!(mbuf = ast_realloc(mbuf, maxmbuf))) {
+-                                              lf->cursor[0] = savechr;
++//                                            lf->cursor[0] = savechr; // this is readonly variable
+                                               return (char *)(CC_ERROR);
+                                       }
+                               }
+@@ -2365,7 +2365,7 @@
+               ast_free(matches);
+       }
+-      lf->cursor[0] = savechr;
++//    lf->cursor[0] = savechr; // this is readonly variable
+       return (char *)(long)retval;
+ }
This page took 1.127444 seconds and 4 git commands to generate.