]> git.pld-linux.org Git - packages/asterisk.git/commitdiff
- patches for new pwlib/openh323 from cvs asterisk
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Sun, 20 Mar 2005 19:34:31 +0000 (19:34 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    asterisk-openh323-formats.patch -> 1.1
    asterisk-openh323-rtti.patch -> 1.1

asterisk-openh323-formats.patch [new file with mode: 0644]
asterisk-openh323-rtti.patch [new file with mode: 0644]

diff --git a/asterisk-openh323-formats.patch b/asterisk-openh323-formats.patch
new file mode 100644 (file)
index 0000000..372626f
--- /dev/null
@@ -0,0 +1,33 @@
+diff -urN asterisk-1.0.7.org/channels/h323/ast_h323.cpp asterisk-1.0.7/channels/h323/ast_h323.cpp
+--- asterisk-1.0.7.org/channels/h323/ast_h323.cpp      2004-11-05 00:14:26.000000000 +0100
++++ asterisk-1.0.7/channels/h323/ast_h323.cpp  2005-03-20 20:27:59.908829920 +0100
+@@ -994,6 +994,7 @@
+       } else {
+               endPoint->SetSendUserInputMode(H323Connection::SendUserInputAsInlineRFC2833);
+       }
++#if 0
+       if (cap & AST_FORMAT_SPEEX) {
+               /* Not real sure if Asterisk acutally supports all
+                  of the various different bit rates so add them 
+@@ -1005,6 +1006,7 @@
+               endPoint->SetCapability(0, 0, new SpeexNarrow5AudioCapability());
+               endPoint->SetCapability(0, 0, new SpeexNarrow6AudioCapability());
+       }
++#endif
+       if (cap & AST_FORMAT_G729A) {
+               AST_G729ACapability *g729aCap;
+@@ -1018,11 +1020,13 @@
+               endPoint->SetCapability(0, 0, g7231Cap = new H323_G7231Capability);
+       } 
++#if 0
+       if (cap & AST_FORMAT_GSM) {
+               H323_GSM0610Capability *gsmCap;
+               endPoint->SetCapability(0, 0, gsmCap = new H323_GSM0610Capability);
+               gsmCap->SetTxFramesInPacket(gsmFrames);
+       } 
++#endif
+       if (cap & AST_FORMAT_ULAW) {
+               H323_G711Capability *g711uCap;
diff --git a/asterisk-openh323-rtti.patch b/asterisk-openh323-rtti.patch
new file mode 100644 (file)
index 0000000..3a77fd9
--- /dev/null
@@ -0,0 +1,12 @@
+diff -urN asterisk-1.0.7.org/channels/h323/Makefile asterisk-1.0.7/channels/h323/Makefile
+--- asterisk-1.0.7.org/channels/h323/Makefile  2004-11-15 03:35:35.000000000 +0100
++++ asterisk-1.0.7/channels/h323/Makefile      2005-03-20 20:19:02.386545728 +0100
+@@ -77,7 +77,7 @@
+       ar cr libchanh323.a ast_h323.o
+ ast_h323.o:   ast_h323.cpp
+-      $(CXX) -g -c -fno-rtti -o $@ $(CFLAGS) $<
++      $(CXX) -g -c -o $@ $(CFLAGS) $<
+ ifneq ($(wildcard .depend),)
+ include .depend
This page took 0.031714 seconds and 4 git commands to generate.