]> git.pld-linux.org Git - packages/aspseek.git/commitdiff
- revert user changes
authorpascalek <pascalek@pld-linux.org>
Sat, 17 May 2003 06:47:52 +0000 (06:47 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    aspseek.spec -> 1.15

aspseek.spec

index 472c19428544eb8f7532c0f66b81039bc30c1b0f..92218190cf4af1ae411f7845fa7aff1004b86e06 100644 (file)
@@ -19,7 +19,9 @@ BuildRequires:        openssl-devel >= 0.9.7
 BuildRequires: mysql-devel
 BuildRequires: libstdc++-devel
 BuildRequires: zlib-devel
-Requires(pre): user-aspseek
+Requires(pre): /bin/id
+Requires(pre): /usr/sbin/useradd
+Requires(postun):      /usr/sbin/userdel
 Requires(post):        fileutils
 Requires(post,preun):  /sbin/chkconfig
 Requires(post,postun): /sbin/ldconfig
@@ -135,6 +137,16 @@ touch $RPM_BUILD_ROOT/var/log/aspseek.log
 %clean
 rm -rf $RPM_BUILD_ROOT
 
+%pre
+if [ -n "`id -u aspseek 2>/dev/null`" ]; then
+       if [ "`id -u aspseek`" != "50" ]; then
+               echo "Error: user aspseek doesn't have uid=50. Correct this before installing aspseek." 1>&2
+               exit 1
+       fi
+else
+       /usr/sbin/useradd -u 50 -r -d /home/services/aspseek -s /bin/false -c "ASPSEEK User" -g root aspseek 1>&2
+fi
+
 %post
 /sbin/ldconfig
 /sbin/chkconfig --add %{name}
@@ -150,6 +162,9 @@ fi
 
 %postun
 /sbin/ldconfig
+if [ "$1" = "0" ]; then
+       /usr/sbin/userdel aspseek
+fi
 
 %post db-mysql
 /sbin/ldconfig
This page took 0.108496 seconds and 4 git commands to generate.