]> git.pld-linux.org Git - packages/aspell.git/commitdiff
- updated URLs, added patch from project
authorJakub Bogusz <qboosh@pld-linux.org>
Fri, 3 May 2002 12:50:18 +0000 (12:50 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- fixed messing with libdir and co.
- added pspell module to package
- noinstalled patch to allow build w/o aspell already installed,
  amfix patch to allow rebuild automake files
- release 2

Changed files:
    aspell-.33-fix2.diff -> 1.1
    aspell-amfix.patch -> 1.1
    aspell-noinstalled.patch -> 1.1
    aspell.spec -> 1.29

aspell-.33-fix2.diff [new file with mode: 0644]
aspell-amfix.patch [new file with mode: 0644]
aspell-noinstalled.patch [new file with mode: 0644]
aspell.spec

diff --git a/aspell-.33-fix2.diff b/aspell-.33-fix2.diff
new file mode 100644 (file)
index 0000000..841d2c9
--- /dev/null
@@ -0,0 +1,47 @@
+To apply this patch cd into the Aspell source directory and then
+  patch -p0 < <this file>
+
+It is meant to be applied against Aspell .33.7.*
+
+This patch will:
+- Workaround a bug in Pspell where multi-byte words are not getting
+  null terminated properly.
+- Truly fix a bug in suggest.cc so that Aspell will suggest correctly
+  when typo-analysis is not used such as when sug-mode is ultra 
+  or bad spellers.
+
+--- lib/suggest.cc~    Wed Aug  1 03:40:49 2001
++++ lib/suggest.cc     Fri Nov  9 00:10:16 2001
+@@ -455,7 +455,7 @@
+   void Working::score_list() {
+     if (near_misses.empty()) return;
+-    bool no_soundslike = strcmp(manager->lang().soundslike_name(), "none") != 0;
++    bool no_soundslike = strcmp(manager->lang().soundslike_name(), "none") == 0;
+     if (parms.use_typo_analysis) {
+       
+--- pspell-module/manager.cc~  Wed Jan 31 22:08:58 2001
++++ pspell-module/manager.cc   Sun Dec  9 22:51:14 2001
+@@ -59,7 +59,9 @@
+     if (w == 0) return 0;
+     temp_str = "";
+     from_internal->convert(w, temp_buf);
+-    return temp_str.c_str();
++    char t[4] = {0};
++    temp_str.append(t, 4);
++    return temp_str.data();
+   }
+   template <>
+@@ -70,7 +72,9 @@
+     wi.get_word(tmp,local_info.convert);
+     temp_str = "";
+     from_internal->convert(tmp.c_str(), temp_buf);
+-    return temp_str.c_str();
++    char t[4] = {0};
++    temp_str.append(t, 4);
++    return temp_str.data();
+   }
+   template <typename T>
diff --git a/aspell-amfix.patch b/aspell-amfix.patch
new file mode 100644 (file)
index 0000000..7b9d1ae
--- /dev/null
@@ -0,0 +1,42 @@
+diff -Nur aspell-.33.7.1.orig/data/Makefile.am aspell-.33.7.1/data/Makefile.am
+--- aspell-.33.7.1.orig/data/Makefile.am       Fri May  3 11:28:26 2002
++++ aspell-.33.7.1/data/Makefile.am    Fri May  3 11:29:18 2002
+@@ -23,7 +23,7 @@
+ pspelldata_DATA = $(pwlifiles)
+-CLEANFILES += $(dictfiles) $(pwlifiles)
++CLEANFILES = $(dictfiles) $(pwlifiles)
+ english-med-only:
+       cd ../; bd=`pwd`; cd scowl/final; \
+diff -Nur aspell-.33.7.1.orig/manual/Makefile.am aspell-.33.7.1/manual/Makefile.am
+--- aspell-.33.7.1.orig/manual/Makefile.am     Fri Jul 27 05:06:09 2001
++++ aspell-.33.7.1/manual/Makefile.am  Fri May  3 11:29:37 2002
+@@ -4,7 +4,7 @@
+ ## CLEANFILES += manual2.tex manual2.aux manual2.log
+-MAINTAINERCLEANFILES += manual.*  manual-html manual-text
++MAINTAINERCLEANFILES = manual.*  manual-html manual-text
+ manual: @MAINTAINER_MODE_TRUE@ manual-text
+diff -Nur aspell-.33.7.1.orig/manual/man-html/Makefile.am aspell-.33.7.1/manual/man-html/Makefile.am
+--- aspell-.33.7.1.orig/manual/man-html/Makefile.am    Mon Apr  3 04:11:50 2000
++++ aspell-.33.7.1/manual/man-html/Makefile.am Fri May  3 11:29:51 2002
+@@ -8,4 +8,4 @@
+ *.css:
+ *.png:
+-MAINTAINERCLEANFILES += ${pkgdoc_html_DATA} *.pl WARNINGS
++MAINTAINERCLEANFILES = ${pkgdoc_html_DATA} *.pl WARNINGS
+diff -Nur aspell-.33.7.1.orig/manual/man-text/Makefile.am aspell-.33.7.1/manual/man-text/Makefile.am
+--- aspell-.33.7.1.orig/manual/man-text/Makefile.am    Wed Jan 19 22:53:07 2000
++++ aspell-.33.7.1/manual/man-text/Makefile.am Fri May  3 11:29:57 2002
+@@ -6,4 +6,4 @@
+ *.txt:
+-MAINTAINERCLEANFILES += *.txt
++MAINTAINERCLEANFILES = *.txt
diff --git a/aspell-noinstalled.patch b/aspell-noinstalled.patch
new file mode 100644 (file)
index 0000000..4607998
--- /dev/null
@@ -0,0 +1,61 @@
+--- aspell-.33.7.1/data/Makefile.am.orig       Wed May  2 01:34:28 2001
++++ aspell-.33.7.1/data/Makefile.am    Fri May  3 11:21:27 2002
+@@ -30,35 +30,35 @@
+       cat english-*.10 english-*.20 english-*.35 english-*.50 \
+             english-*.60 english-*.65 \
+           special-*.35 special-*.50 \
+-      | $$bd/src/aspell --lang=english \
++      | $$bd/src/aspell --conf=/dev/null --per-conf=/dev/null --lang=english \
+         create master $$bd/data/english-med-only
+ american-med-only:
+       cd ../; bd=`pwd`; cd scowl/final; \
+       cat american-*.10 american-*.20 american-*.35 american-*.50 \
+             american-*.60 american-*.65 \
+-      | $$bd/src/aspell --lang=english \
++      | $$bd/src/aspell --conf=/dev/null --per-conf=/dev/null --lang=english \
+         create master $$bd/data/american-med-only
+ british-med-only:
+       cd ../; bd=`pwd`; cd scowl/final; \
+       cat british-*.10 british-*.20 british-*.35 british-*.50 \
+             british-*.60 british-*.65 \
+-      | $$bd/src/aspell --lang=english \
++      | $$bd/src/aspell --conf=/dev/null --per-conf=/dev/null --lang=english \
+         create master $$bd/data/british-med-only
+ canadian-med-only:
+       cd ../; bd=`pwd`; cd scowl/final; \
+       cat canadian-*.10 canadian-*.20 canadian-*.35 canadian-*.50 \
+             canadian-*.60 canadian-*.65 \
+-      | $$bd/src/aspell --lang=english \
++      | $$bd/src/aspell --conf=/dev/null --per-conf=/dev/null --lang=english \
+         create master $$bd/data/canadian-med-only
+ english-variant-0:
+       cd ../; bd=`pwd`; cd scowl/final; \
+       cat variant_0-*.10 variant_0-*.20 variant_0-*.35 variant_0-*.50 \
+           variant_0-*.60 variant_0-*.65 \
+-      | $$bd/src/aspell --lang=english \
++      | $$bd/src/aspell --conf=/dev/null --per-conf=/dev/null --lang=english \
+         create master $$bd/data/english-variant-0
+ english-variant-1:
+@@ -67,7 +67,7 @@
+           variant_0-*.60                \
+           variant_1-*.10 variant_1-*.20 variant_1-*.35 variant_1-*.50 \
+           variant_1-*.60 variant_1-*.65 \
+-      | $$bd/src/aspell --lang=english \
++      | $$bd/src/aspell --conf=/dev/null --per-conf=/dev/null --lang=english \
+         create master $$bd/data/english-variant-1
+ english-variant-2:
+@@ -78,7 +78,7 @@
+           variant_1-*.60 variant_1-*.65 \
+           variant_2-*.10 variant_2-*.20 variant_2-*.35 variant_2-*.50 \
+           variant_2-*.60                \
+-      | $$bd/src/aspell --lang=english \
++      | $$bd/src/aspell --conf=/dev/null --per-conf=/dev/null --lang=english \
+         create master $$bd/data/english-variant-2
+ en-aspell.pwli:
index 370ecff83d18efdef4a0ece71f0f6a1ebb478931..2dd2bf132cd10d121642948bbb98d1de3373aa59 100644 (file)
@@ -4,14 +4,20 @@ Summary:      Aspell is an Open Source spell checker
 Summary(pl):   Aspell jest kontrolerem pisowni
 Name:          aspell
 Version:       0%{ver}
-Release:       1
+Release:       2
 Epoch:         1
 License:       LGPL
 Group:         Applications/Text
 Vendor:                Kevin Atkinson <kevinatk@home.com>
-Source0:       http://metalab.unc.edu/kevina/aspell/%{name}-%{ver}.tar.gz
-URL:           http://metalab.unc.edu/kevina/aspell/
+Source0:       ftp://ftp.sourceforge.net/pub/sourceforge/aspell/%{name}-%{ver}.tar.gz
+Patch0:                ftp://ftp.sourceforge.net/pub/sourceforge/aspell/%{name}-.33-fix2.diff
+Patch1:                %{name}-noinstalled.patch
+Patch2:                %{name}-amfix.patch
+URL:           http://aspell.sourceforge.net/
+BuildRequires: autoconf
+BuildRequires: automake
 BuildRequires: libstdc++-devel
+BuildRequires: libtool
 BuildRequires: pspell-devel
 Provides:      ispell
 Obsoletes:     ispell
@@ -28,84 +34,88 @@ powerful C++ library with C and Perl interfaces in the works.
 
 %description -l pl
 Aspell jest kontrolerem pisowni zaprojektowanym tak, by móc zast±piæ
-ispell'a. Dodatkowo zawiera wsparcie dla innych jêzyków ni¿ angielski.
+ispella. Dodatkowo zawiera wsparcie dla innych jêzyków ni¿ angielski.
 Interfejs aspella napisany zosta³ w C++, a interfejsy w Perlu i C s±
 aktualnie rozwijane.
 
 %package devel
-Summary:       Libraries and header files for aspell development
-Summary(pl):   Biblioteki i pliki nag³ówkowe dla developerów aspella
+Summary:       Header files for aspell development
+Summary(pl):   Pliki nag³ówkowe dla programistów u¿ywaj±cych aspella
 Group:         Development/Libraries
 Requires:      %{name} = %{version}
 
 %description devel
-Aspell is an Open Source spell checker.
-
-Libraries and header files for aspell development.
+Aspell is an Open Source spell checker. This package contains header
+files for aspell development.
 
 %description -l pl devel
-Aspell jest kontrolerem pisowni. Pakiet ten zawiera biblioteki i pliki
-nag³ówkowe dla developerów aspella.
+Aspell jest kontrolerem pisowni. Ten pakiet zawiera pliki nag³ówkowe
+dla programistów u¿ywaj±cych bibliotek aspella.
 
 %package static
-Summary:       Static Libraries for aspell development
-Summary(pl):   Biblioteki statyczne dla developerów aspella
+Summary:       Static libraries for aspell development
+Summary(pl):   Biblioteki statyczne aspella
 Group:         Development/Libraries
 Requires:      %{name}-devel = %{version}
 
 %description static
-Aspell is an Open Source spell checker.
-
-Static Libraries for aspell development.
+Aspell is an Open Source spell checker. This package contains static
+aspell libraries.
 
 %description -l pl static
 Aspell jest kontrolerem pisowni. Pakiet ten zawiera biblioteki
-statyczne dla developerów aspella.
+statyczne aspella.
 
 %prep
 %setup -q -n %{name}-%{ver}
+%patch0 -p0
+%patch1 -p1
+%patch2 -p1
 
 %build
-CFLAGS="%{rpmcflags}" CXXFLAGS="%{rpmcflags}" LDFLAGS="%{rpmldflags}" \
-%configure %{_target_platform} \
-       --libdir=%{_datadir} \
+libtoolize --copy --force
+aclocal
+autoconf
+automake -a -c -f --foreign
+%configure \
        --enable-shared \
-       --enable-static
+       --enable-static \
+       --enable-dict-dir=%{_datadir}/aspell
+
 %{__make} 
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
 %{__make} install \
-       DESTDIR=$RPM_BUILD_ROOT \
-       pkgdatadir=%{_datadir}/aspell \
-       libdir=%{_libdir}
-
-#cp -pr $RPM_BUILD_ROOT%{_prefix}/doc/aspell .
+       DESTDIR=$RPM_BUILD_ROOT
 
 ln -sf aspell $RPM_BUILD_ROOT%{_bindir}/ispell
 rm -rf $RPM_BUILD_ROOT%{_prefix}/{bin/run-with-aspell,share/aspell/ispell}
 
 gzip -9nf manual/manual2.lyx manual/man-text/*.txt
 
-%post   -p /sbin/ldconfig
-%postun -p /sbin/ldconfig
-
 %clean
 rm -rf $RPM_BUILD_ROOT
 
+%post   -p /sbin/ldconfig
+%postun -p /sbin/ldconfig
+
 %files
 %defattr(644,root,root,755)
-%doc README TODO manual/{*,man-text/*.txt}.gz
+%doc manual/{*,man-text/*.txt}.gz
 %attr(755,root,root) %{_bindir}/*
+%attr(755,root,root) %{_libdir}/libaspell.so.*.*
+%attr(755,root,root) %{_libdir}/libpspell_aspell.so.*.*
+%attr(755,root,root) %{_libdir}/libpspell_aspell.la
 %{_datadir}/aspell
-%{_libdir}/libaspell.so.*.*
+%{_datadir}/pspell/*
 
 %files devel
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libaspell.so
+%attr(755,root,root) %{_libdir}/libaspell.la
 %{_includedir}/aspell
-%{_libdir}/libaspell.la
 
 %files static
 %defattr(644,root,root,755)
This page took 0.10318 seconds and 4 git commands to generate.