]> git.pld-linux.org Git - packages/ash.git/blob - ash.spec
- added ash-mknodes.patch from Tornado
[packages/ash.git] / ash.spec
1 Summary:        Small bourne shell from Berkeley
2 Summary(de):    Kleine Bourne-Shell von Berkeley
3 Summary(fr):    Shell Bourne réduit de Berkeley
4 Summary(pl):    Ma³y shell bourne'a 
5 Summary(tr):    Ufak bir bourne kabuðu
6 Name:           ash
7 Version:        0.2
8 Release:        15
9 Copyright:      BSD
10 Group:          Shells
11 Source:         ftp://sunsite.unc.edu:/pub/Linux/system/shells/ash-linux-%{version}.tar.gz
12 Patch0:         ash-make.patch
13 Patch1:         ash-mknodes.patch
14 Prereq:         fileutils
15 Prereq:         grep
16 Buildroot:      /tmp/%{name}-%{version}-root
17 Conflicts:      mkinitrd <= 1.7
18
19 %description
20 ash is a bourne shell clone from Berkeley.  It supports all of the standard
21 Bourne shell commands and has the advantage of supporting them while 
22 remaining considerably smaller than bash. 
23
24 %description -l de
25 ash ist ein Bourne-Shell-Clone aus Berkeley, der alle Standard-Bourne-Shell-
26 Befehle unterstützt und dennoch erheblich weniger Platz beansprucht als bash. 
27
28 %description -l fr
29 ash est un clone Berkeley du shell Bourne. Il gère toutes les commandes
30 standard du shell Bourne et a l'avantage de les gérer tout en restant
31 considérablement plus petit que bash.
32
33 %description -l pl
34 Ash jest klonem shell'a bourne'a z Berkely. Obs³uguje standardowe komendy
35 shell'a Bourne'a i jest mniejszy ni¿ bash. 
36
37 %description -l tr
38 ash, Berkeley'in bir bourne kabuðu kopyasýdýr. Standart bourne kabuðu
39 komutlarýnýn tümünü destekler ve bash kabuðundan daha küçük olma
40 avantajýna sahiptir.
41
42 %prep
43 %setup  -q -n ash-linux-%{version}
44 %patch0 -p1
45 %patch1 -p1
46
47 %build
48 make
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52 install -d $RPM_BUILD_ROOT/{bin,usr/man/man1}
53
54 install sh $RPM_BUILD_ROOT/bin/ash
55 install sh.1 $RPM_BUILD_ROOT/usr/man/man1/ash.1
56 echo ".so ash.1" > $RPM_BUILD_ROOT/usr/man/man1/bsh.1
57 ln -sf ash $RPM_BUILD_ROOT/bin/bsh
58
59 rm -f sh
60 make STATIC=-static
61
62 install sh $RPM_BUILD_ROOT/bin/ash.static
63
64 gzip -9nf $RPM_BUILD_ROOT/usr/man/man1/*
65
66 %post
67 umask 022
68 echo "/bin/ash" >> /etc/shells
69 echo "/bin/bsh" >> /etc/shells
70 cat /etc/shells | sort -u > /etc/shells.new
71 mv /etc/shells.new /etc/shells
72
73 %postun
74 if [ "$0" = 0 ]; then
75         egrep -v "^/bin/ash|^/bin/bsh" /etc/shells > /etc/shells.new
76         mv /etc/shells.new /etc/shells
77 fi
78
79 %verifyscript
80 for n in ash bsh; do
81     echo -n "Looking for $n in /etc/shells... "
82     if ! grep "^/bin/${n}\$" /etc/shells > /dev/null; then
83         echo "missing"
84         echo "${n} missing from /etc/shells" >&2
85     else
86         echo "found"
87     fi
88 done
89
90 %clean
91 rm -rf $RPM_BUILD_ROOT
92
93 %files
94 %attr(755, root, root) /bin/*
95 %attr(644, root,  man) /usr/man/man1/*
96
97 %changelog
98 * Wed Dec 23 1998 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
99   [0.2-15]
100 - simplification in %postun and %post,
101 - added gzipping man pages.
102
103 * Fri Nov 06 1998 Preston Brown <pbrown@redhat.com>
104   [0.2-14]
105 - updated to correct path on SunSITE.
106
107 * Sun Sep 27 1998 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
108   [0.2-13]
109 - added -q %setup parameter,
110 - simplification in %install,
111 - bsh(1) man page is now maked as nroff include to ash(1) instead
112   making sym link to ash.1 (this allow compress man pages in future).
113
114 * Mon Jun 29 1998 Wojtek Slusarczyk <wojtek@shadow.eu.org>
115 - added pl translation.
116
117 * Tue May 05 1998 Prospector System <bugs@redhat.com>
118 - translations modified for de, fr, tr
119
120 * Mon Oct 20 1997 Erik Troan <ewt@redhat.com>
121 - made /bin/ash built shared
122 - added ash.static
123 - uses a buildroot and %attr
124
125 * Sun Aug 24 1997 Erik Troan <ewt@redhat.com>
126 - built against glibc
127 - statically linked
128
129 * Wed Apr 16 1997 Erik Troan <ewt@redhat.com>
130 - fixed preinstall script to >> /etc/shells for bsh.
This page took 0.063629 seconds and 4 git commands to generate.