]> git.pld-linux.org Git - packages/ash.git/blob - ash.spec
- added using CVS keywords in %changelog (for automating them).
[packages/ash.git] / ash.spec
1 Summary:        Small bourne shell from Berkeley
2 Summary(de):    Kleine Bourne-Shell von Berkeley
3 Summary(fr):    Shell Bourne réduit de Berkeley
4 Summary(pl):    Ma³y shell bourne'a 
5 Summary(tr):    Ufak bir bourne kabuðu
6 Name:           ash
7 Version:        0.2
8 Release:        18
9 Copyright:      BSD
10 Group:          Shells
11 Group(pl):      Pow³oki
12 Source:         ftp://sunsite.unc.edu/pub/Linux/system/shells/ash-linux-%{version}.tar.gz
13 Patch0:         ash-make.patch
14 Patch1:         ash-mknodes.patch
15 Prereq:         fileutils
16 Prereq:         grep
17 BuildRoot:      /tmp/%{name}-%{version}-root
18 Conflicts:      mkinitrd <= 1.7
19
20 %description
21 ash is a bourne shell clone from Berkeley.  It supports all of the standard
22 Bourne shell commands and has the advantage of supporting them while 
23 remaining considerably smaller than bash. 
24
25 %description -l de
26 ash ist ein Bourne-Shell-Clone aus Berkeley, der alle Standard-Bourne-Shell-
27 Befehle unterstützt und dennoch erheblich weniger Platz beansprucht als bash. 
28
29 %description -l fr
30 ash est un clone Berkeley du shell Bourne. Il gère toutes les commandes
31 standard du shell Bourne et a l'avantage de les gérer tout en restant
32 considérablement plus petit que bash.
33
34 %description -l pl
35 Ash jest klonem shell'a Bourne'a z Berkely. Obs³uguje standardowe komendy
36 shell'a Bourne'a i jest mniejszy ni¿ bash. 
37
38 %description -l tr
39 ash, Berkeley'in bir bourne kabuðu kopyasýdýr. Standart bourne kabuðu
40 komutlarýnýn tümünü destekler ve bash kabuðundan daha küçük olma
41 avantajýna sahiptir.
42
43 %prep
44 %setup  -q -n ash-linux-%{version}
45 %patch0 -p1
46 %patch1 -p1
47
48 %build
49 make
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53 install -d $RPM_BUILD_ROOT/{bin,%{_mandir}/man1}
54
55 install sh $RPM_BUILD_ROOT/bin/ash
56 install sh.1 $RPM_BUILD_ROOT%{_mandir}/man1/ash.1
57 echo ".so ash.1" > $RPM_BUILD_ROOT%{_mandir}/man1/bsh.1
58 ln -sf ash $RPM_BUILD_ROOT/bin/bsh
59
60 rm -f sh
61 make STATIC=-static
62
63 install sh $RPM_BUILD_ROOT/bin/ash.static
64
65 gzip -9nf $RPM_BUILD_ROOT%{_mandir}/man1/*
66
67 %post
68 if [ ! -f /etc/shells ]; then
69         echo "/bin/ash" > /etc/shells
70         echo "/bin/bsh" >> /etc/shells
71         echo "/bin/ash.static" >> /etc/shells
72 else
73         if ! grep '^/bin/ash$' /etc/shells > /dev/null; then
74                 echo "/bin/ash" >> /etc/shells
75         fi
76         if ! grep '^/bin/bsh$' /etc/shells > /dev/null; then
77                 echo "/bin/bsh" >> /etc/shells
78         fi
79         if ! grep '^/bin/ash.static$' /etc/shells > /dev/null; then
80                 echo "/bin/ash.static" >> /etc/shells
81         fi
82 fi
83
84 %postun
85 if [ "$0" = 0 ]; then
86         grep -v /bin/ash /etc/shells | grep -v /bin/bsh | grep -v /bin/ash.static > /etc/shells.new
87         mv /etc/shells.new /etc/shells
88 fi
89
90 %verifyscript
91 for n in ash bsh ash.static; do
92     echo -n "Looking for $n in /etc/shells... "
93     if ! grep "^/bin/${n}\$" /etc/shells > /dev/null; then
94         echo "missing"
95         echo "${n} missing from /etc/shells" >&2
96     else
97         echo "found"
98     fi
99 done
100
101 %clean
102 rm -rf $RPM_BUILD_ROOT
103
104 %files
105 %defattr(644,root,root,755)
106 %attr(755,root,root) /bin/*
107 %{_mandir}/man1/*
This page took 0.066873 seconds and 4 git commands to generate.