]> git.pld-linux.org Git - packages/ash.git/blob - ash.spec
- revision up to 15,
[packages/ash.git] / ash.spec
1 Summary:     Small bourne shell from Berkeley
2 Summary(de): Kleine Bourne-Shell von Berkeley
3 Summary(fr): Shell Bourne réduit de Berkeley
4 Summary(pl): Ma³y shell bourne'a 
5 Summary(tr): Ufak bir bourne kabuðu
6 Name:        ash
7 Version:     0.2
8 Release:     15
9 Copyright:   BSD
10 Group:       Shells
11 Source:      ftp://sunsite.unc.edu:/pub/Linux/system/shells/ash-linux-%{version}.tar.gz
12 Patch:       ash-make.patch
13 Prereq:      fileutils, grep
14 Buildroot:   /tmp/%{name}-%{version}-root
15 Conflicts:   mkinitrd <= 1.7
16
17 %description
18 ash is a bourne shell clone from Berkeley.  It supports all of the standard
19 Bourne shell commands and has the advantage of supporting them while 
20 remaining considerably smaller than bash. 
21
22 %description -l de
23 ash ist ein Bourne-Shell-Clone aus Berkeley, der alle Standard-Bourne-Shell-
24 Befehle unterstützt und dennoch erheblich weniger Platz beansprucht als bash. 
25
26 %description -l fr
27 ash est un clone Berkeley du shell Bourne. Il gère toutes les commandes
28 standard du shell Bourne et a l'avantage de les gérer tout en restant
29 considérablement plus petit que bash.
30
31 %description -l pl
32 Ash jest klonem shell'a bourne'a z Berkely. Obs³uguje standardowe komendy
33 shell'a Bourne'a i jest mniejszy ni¿ bash. 
34
35 %description -l tr
36 ash, Berkeley'in bir bourne kabuðu kopyasýdýr. Standart bourne kabuðu
37 komutlarýnýn tümünü destekler ve bash kabuðundan daha küçük olma
38 avantajýna sahiptir.
39
40 %prep
41 %setup -q -n ash-linux-%{version}
42 %patch -p1
43
44 %build
45 make
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49 install -d $RPM_BUILD_ROOT/{bin,usr/man/man1}
50
51 install sh $RPM_BUILD_ROOT/bin/ash
52 install sh.1 $RPM_BUILD_ROOT/usr/man/man1/ash.1
53 echo ".so ash.1" > $RPM_BUILD_ROOT/usr/man/man1/bsh.1
54 ln -sf ash $RPM_BUILD_ROOT/bin/bsh
55
56 rm -f sh
57 make STATIC=-static
58
59 install sh $RPM_BUILD_ROOT/bin/ash.static
60
61 gzip -9nf $RPM_BUILD_ROOT/usr/man/man1/*
62
63 %post
64 umask 022
65 echo "/bin/ash" >> /etc/shells
66 echo "/bin/bsh" >> /etc/shells
67 cat /etc/shells | sort -u > /etc/shells.new
68 mv /etc/shells.new /etc/shells
69
70 %postun
71 if [ "$0" = 0 ]; then
72         egrep -v "^/bin/ash|^/bin/bsh" /etc/shells > /etc/shells.new
73         mv /etc/shells.new /etc/shells
74 fi
75
76 %verifyscript
77 for n in ash bsh; do
78     echo -n "Looking for $n in /etc/shells... "
79     if ! grep "^/bin/${n}\$" /etc/shells > /dev/null; then
80         echo "missing"
81         echo "${n} missing from /etc/shells" >&2
82     else
83         echo "found"
84     fi
85 done
86
87 %clean
88 rm -rf $RPM_BUILD_ROOT
89
90 %files
91 %attr(755, root, root) /bin/*
92 %attr(644, root,  man) /usr/man/man1/*
93
94 %changelog
95 * Wed Dec 23 1998 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
96   [0.2-15]
97 - simplification in %postun and %post,
98 - added gzipping man pages.
99
100 * Fri Nov 06 1998 Preston Brown <pbrown@redhat.com>
101   [0.2-14]
102 - updated to correct path on SunSITE.
103
104 * Sun Sep 27 1998 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
105   [0.2-13]
106 - added -q %setup parameter,
107 - simplification in %install,
108 - bsh(1) man page is now maked as nroff include to ash(1) instead
109   making sym link to ash.1 (this allow compress man pages in future).
110
111 * Mon Jun 29 1998 Wojtek Slusarczyk <wojtek@shadow.eu.org>
112 - added pl translation.
113
114 * Tue May 05 1998 Prospector System <bugs@redhat.com>
115 - translations modified for de, fr, tr
116
117 * Mon Oct 20 1997 Erik Troan <ewt@redhat.com>
118 - made /bin/ash built shared
119 - added ash.static
120 - uses a buildroot and %attr
121
122 * Sun Aug 24 1997 Erik Troan <ewt@redhat.com>
123 - built against glibc
124 - statically linked
125
126 * Wed Apr 16 1997 Erik Troan <ewt@redhat.com>
127 - fixed preinstall script to >> /etc/shells for bsh.
This page took 0.045957 seconds and 4 git commands to generate.