]> git.pld-linux.org Git - packages/ash.git/blob - ash.spec
- Spanish summary/description fixes
[packages/ash.git] / ash.spec
1 #
2 # Conditional build
3 # --without static      - don't build static
4 # --with dietlibc       - link with dietlibc, implies --without static)
5 # Branch: HEAD
6
7 %{?_with_dietlibc:%define _without_static 1}
8
9 Summary:        Small bourne shell from Berkeley
10 Summary(de):    Kleine Bourne-Shell von Berkeley
11 Summary(es):    Pequeña shell bourne de Berkeley
12 Summary(fr):    Shell Bourne réduit de Berkeley
13 Summary(pl):    Ma³y shell bourne'a
14 Summary(pt_BR): Pequena shell bourne de Berkeley
15 Summary(ru):    ïÂÌÅÇÞÅÎÎÁÑ ×ÅÒÓÉÑ Bourne shell (sh)
16 Summary(tr):    Ufak bir bourne kabuðu
17 Summary(uk):    ðÏÌÅÇÛÅÎÁ ×ÅÒӦѠBourne shell (sh)
18 Summary(zh_CN): [ϵͳ]BerkeleyµÄ΢ÐÍBourne Shell
19 Summary(zh_TW): [\e-A¨t\e$)B²Î]Berkeleyªº\e-A·L\e$)B«¬Bourne Shell
20 Name:           ash
21 Version:        0.4.0
22 Release:        10
23 License:        BSD
24 Group:          Applications/Shells
25 Source0:        %{name}-%{version}.tar.gz
26 # Source0-md5:  1c59f5b62a081cb0cb3b053c01d79529
27 Patch0:         %{name}-builtin.patch
28 Patch1:         %{name}-echo.patch
29 Patch2:         %{name}-getcwd.patch
30 Patch3:         %{name}-getopt.patch
31 Patch4:         %{name}-glob.patch
32 Patch5:         %{name}-jobs.patch
33 Patch6:         %{name}-kill.patch
34 Patch7:         %{name}-makefile.patch
35 Patch8:         %{name}-manpage.patch
36 Patch9:         %{name}-hetio.patch
37 Patch10:        %{name}-memout.patch
38 Patch11:        %{name}-misc.patch
39 Patch12:        %{name}-redir.patch
40 Patch13:        %{name}-setmode.patch
41 Patch14:        %{name}-syntax.patch
42 Patch15:        %{name}-test.patch
43 Patch16:        %{name}-times.patch
44 Patch17:        %{name}-debian.patch
45 Patch18:        %{name}-ppid.patch
46 Patch19:        %{name}-freebsd.patch
47 Patch20:        %{name}-sighup.patch
48 Patch21:        %{name}-dietlibc.patch
49 BuildRequires:  byacc
50 %{?_with_dietlibc:BuildRequires:        dietlibc-static}
51 BuildRequires:  flex
52 %{!?_without_static:BuildRequires:      glibc-static}
53 Requires(post,preun,verify):    grep
54 Requires(preun):        fileutils
55 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
56 Conflicts:      mkinitrd <= 1.7
57
58 %define         _bindir         /bin
59
60 %description
61 ash is a bourne shell clone from Berkeley. It supports all of the
62 standard Bourne shell commands and has the advantage of supporting
63 them while remaining considerably smaller than bash.
64
65 %description -l de
66 ash ist ein Bourne-Shell-Clone aus Berkeley, der alle
67 Standard-Bourne-Shell- Befehle unterstützt und dennoch erheblich
68 weniger Platz beansprucht als bash.
69
70 %description -l es
71 Ash es un clon del shell bourne de Berkeley. Soporta todos los
72 comandos padrón de la Bourne shell y tiene la ventaja de soportarlos
73 con un tamaño considerablemente menor del que bash.
74
75 %description -l fr
76 ash est un clone Berkeley du shell Bourne. Il gère toutes les
77 commandes standard du shell Bourne et a l'avantage de les gérer tout
78 en restant considérablement plus petit que bash.
79
80 %description -l pl
81 Ash jest klonem shella Bourne'a z Berkeley. Obs³uguje standardowe
82 komendy shella Bourne'a i jest mniejszy ni¿ bash.
83
84 %description -l pt_BR
85 ash é um clone do shell bourne de Berkeley. Ele suporta todos os
86 comandos-padrão da Bourne shell e tem a vantagem de suportá-los com um
87 tamanho consideravelmente menor do que bash.
88
89 %description -l ru
90 ûÅÌÌ - ÜÔÏ ÂÁÚÏ×ÁÑ ÓÉÓÔÅÍÎÁÑ ÐÒÏÇÒÁÍÍÁ, ËÏÔÏÒÁÑ ÉÎÔÅÒÐÒÅÔÉÒÕÅÔ ËÏÍÁÎÄÙ
91 ÐÏÌØÚÏ×ÁÔÅÌÑ, ××ÏÄÉÍÙÅ Ó ËÌÁ×ÉÁÔÕÒÙ ÉÌÉ ÐÒÉ ÐÏÍÏÝÉ ÍÙÛÉ. Ash - ÜÔÏ
92 ËÌÏΠBourne shell (sh) ÉÚ âÅÒËÌÉ. Ash ÐÏÄÄÅÒÖÉ×ÁÅÔ ×ÓÅ ÓÔÁÎÄÁÒÔÎÙÅ
93 ËÏÍÁÎÄÙ ÛÅÌÌÁ sh, ÂÕÄÕÞÉ ÚÎÁÞÉÔÅÌØÎÏ ÍÅÎØÛÅ ÞÅÍ sh. ÷ ash ÏÔÓÕÔÓÔ×ÕÀÔ
94 ÎÅËÏÔÏÒÙÅ ×ÏÚÍÏÖÎÏÓÔÉ Bourne shell (ÎÁÐÒÉÍÅÒ, ÉÓÔÏÒÉÑ ËÏÍÁÎÄ), ÎÏ ÏÎ
95 ÔÒÅÂÕÅÔ ÚÎÁÞÉÔÅÌØÎÏ ÍÅÎØÛÅ ÐÁÍÑÔÉ.
96
97 %description -l tr
98 ash, Berkeley'in bir bourne kabuðu kopyasýdýr. Standart bourne kabuðu
99 komutlarýnýn tümünü destekler ve bash kabuðundan daha küçük olma
100 avantajýna sahiptir.
101
102 %description -l uk
103 ûÅÌ - ÃÅ ÂÁÚÏ×Á ÓÉÓÔÅÍÎÁ ÐÒÏÇÒÁÍÁ, ËÏÔÒÁ ¦ÎÔÅÒÐÒÅÔÕ¤ ËÏÍÁÎÄÉ
104 ËÏÒÉÓÔÕ×ÁÞÁ, Ñ˦ ××ÏÄÑÔØÓÑ Ú ËÌÁצÁÔÕÒÉ ÁÂÏ ÚÁ ÄÏÐÏÍÏÇÏÀ ÍÉÛ¦. Ash -
105 ÃÅ ËÌÏΠBourne shell (sh) Ú âÅÒË̦. Ash Ð¦ÄÔÒÉÍÕ¤ ÕÓ¦ ÓÔÁÎÄÁÒÔΦ
106 ËÏÍÁÎÄÉ ÛÅÌÁ sh, ÂÕÄÕÞÉ ÚÎÁÞÎÏ ÍÅÎÛÉ͠Φ֠sh. ÷ ash ×¦ÄÓÕÔΦ ÄÅÑ˦
107 ÍÏÖÌÉ×ÏÓÔ¦ Bourne shell (ÎÁÐÒÉËÌÁÄ, ¦ÓÔÏҦѠËÏÍÁÎÄ), ÚÁÔŠצΠ×ÉÍÁÇÁ¤
108 ÚÎÁÞÎÏ ÍÅÎÛÅ ÐÁÍ'ÑÔ¦.
109
110 %package static
111 Summary:        Small bourne shell from Berkeley
112 Summary(de):    Kleine Bourne-Shell von Berkeley
113 Summary(fr):    Shell Bourne réduit de Berkeley
114 Summary(pl):    Ma³y shell bourne'a
115 Summary(tr):    Ufak bir bourne kabuðu
116 Group:          Applications/Shells
117 Requires(post,preun,verify):    grep
118 Requires(preun):        fileutils
119 Conflicts:      mkinitrd <= 1.7
120
121 %description static
122 ash is a bourne shell clone from Berkeley. It supports all of the
123 standard Bourne shell commands and has the advantage of supporting
124 them while remaining considerably smaller than bash.
125
126 %description static -l de
127 ash ist ein Bourne-Shell-Clone aus Berkeley, der alle
128 Standard-Bourne-Shell- Befehle unterstützt und dennoch erheblich
129 weniger Platz beansprucht als bash.
130
131 %description static -l fr
132 ash est un clone Berkeley du shell Bourne. Il gère toutes les
133 commandes standard du shell Bourne et a l'avantage de les gérer tout
134 en restant considérablement plus petit que bash.
135
136 %description static -l pl
137 Ash jest klonem shella Bourne'a z Berkeley. Obs³uguje standardowe
138 komendy shella Bourne'a i jest mniejszy ni¿ bash.
139
140 %description static -l tr
141 ash, Berkeley'in bir bourne kabuðu kopyasýdýr. Standart bourne kabuðu
142 komutlarýnýn tümünü destekler ve bash kabuðundan daha küçük olma
143 avantajýna sahiptir.
144
145 %prep
146 %setup -q
147 %patch0 -p1
148 %patch1 -p1
149 %patch2 -p1
150 %patch3 -p1
151 %patch4 -p1
152 %patch5 -p1
153 %patch6 -p1
154 %patch7 -p1
155 %patch8 -p1
156 %patch9 -p1
157 %patch10 -p1
158 %patch11 -p1
159 %patch12 -p1
160 %patch13 -p1
161 %patch14 -p1
162 %patch15 -p1
163 %patch16 -p1
164 # this is mainly for information, maybe add changelog to %doc?
165 %patch17 -p1
166 %patch18 -p1
167 %patch19 -p1
168 %patch20 -p1
169 %{?_with_dietlibc:%patch21 -p1}
170
171 %build
172
173 %{?_with_dietlibc:%define __cc %{_arch}-dietlibc-gcc}
174
175 %{!?_without_static:%{__make} OPT_FLAGS="%{rpmcflags}" LDFLAGS="-static %{rpmldflags}"}
176 %{!?_without_static:mv -f sh ash.static}
177 %{__make} OPT_FLAGS="%{rpmcflags}" LDFLAGS="%{rpmldflags}" CC="%{__cc}"
178
179 %install
180 rm -rf $RPM_BUILD_ROOT
181 install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1}
182
183 install sh $RPM_BUILD_ROOT%{_bindir}/ash
184 %{!?_without_static:install ash.static $RPM_BUILD_ROOT%{_bindir}/ash.static}
185 install sh.1 $RPM_BUILD_ROOT%{_mandir}/man1/ash.1
186 echo ".so ash.1" > $RPM_BUILD_ROOT%{_mandir}/man1/bsh.1
187 ln -sf ash $RPM_BUILD_ROOT%{_bindir}/bsh
188
189 %clean
190 rm -rf $RPM_BUILD_ROOT
191
192 %post
193 umask 022
194 if [ ! -f /etc/shells ]; then
195         echo "%{_bindir}/ash" > /etc/shells
196         echo "%{_bindir}/bsh" >> /etc/shells
197 else
198         if ! grep -q '^%{_bindir}/ash$' /etc/shells ; then
199                 echo "%{_bindir}/ash" >> /etc/shells
200         fi
201         if ! grep -q '^%{_bindir}/bsh$' /etc/shells ; then
202                 echo "%{_bindir}/bsh" >> /etc/shells
203         fi
204 fi
205
206 %preun
207 if [ "$1" = 0 ]; then
208         umask 022
209         grep -v '^%{_bindir}/ash$' /etc/shells | grep -v '^%{_bindir}/bsh$' > /etc/shells.new
210         mv -f /etc/shells.new /etc/shells
211 fi
212
213 %post static
214 umask 022
215 if [ ! -f /etc/shells ]; then
216         echo "%{_bindir}/ash.static" >> /etc/shells
217 else
218         if ! grep -q '^%{_bindir}/ash.static$' /etc/shells ; then
219                 echo "%{_bindir}/ash.static" >> /etc/shells
220         fi
221 fi
222
223 %preun static
224 if [ "$1" = 0 ]; then
225         umask 022
226         grep -v '^%{_bindir}/ash\.static$' /etc/shells > /etc/shells.new
227         mv -f /etc/shells.new /etc/shells
228 fi
229
230 %verifyscript
231 for n in ash bsh ; do
232         echo -n "Looking for $n in /etc/shells... "
233         if ! grep -q "^%{_bindir}/${n}\$" /etc/shells ; then
234                 echo "missing"
235                 echo "${n} missing from /etc/shells" >&2
236         else
237                 echo "found"
238         fi
239 done
240
241 %verifyscript static
242 echo -n "Looking for ash.static in /etc/shells... "
243 if ! grep -q '^%{_bindir}/ash\.static$' /etc/shells ; then
244         echo "missing"
245         echo "ash.static missing from /etc/shells" >&2
246 else
247         echo "found"
248 fi
249
250 %files
251 %defattr(644,root,root,755)
252 %attr(755,root,root) %{_bindir}/ash
253 %attr(755,root,root) %{_bindir}/bsh
254 %{_mandir}/man1/*
255
256 %{!?_without_static:%files static}
257 %{!?_without_static:%defattr(644,root,root,755)}
258 %{!?_without_static:%attr(755,root,root) %{_bindir}/ash.static}
This page took 0.072066 seconds and 4 git commands to generate.