]> git.pld-linux.org Git - packages/ash.git/blob - ash.spec
- standarized line with BuildRoot field:
[packages/ash.git] / ash.spec
1 Summary:        Small bourne shell from Berkeley
2 Summary(de):    Kleine Bourne-Shell von Berkeley
3 Summary(fr):    Shell Bourne réduit de Berkeley
4 Summary(pl):    Ma³y shell bourne'a 
5 Summary(tr):    Ufak bir bourne kabuðu
6 Name:           ash
7 Version:        0.2
8 Release:        17
9 Copyright:      BSD
10 Group:          Shells
11 Group(pl):      Pow³oki
12 Source:         ftp://sunsite.unc.edu/pub/Linux/system/shells/ash-linux-%{version}.tar.gz
13 Patch0:         ash-make.patch
14 Patch1:         ash-mknodes.patch
15 Prereq:         fileutils
16 Prereq:         grep
17 BuildRoot:      /tmp/%{name}-%{version}-root
18 Conflicts:      mkinitrd <= 1.7
19
20 %description
21 ash is a bourne shell clone from Berkeley.  It supports all of the standard
22 Bourne shell commands and has the advantage of supporting them while 
23 remaining considerably smaller than bash. 
24
25 %description -l de
26 ash ist ein Bourne-Shell-Clone aus Berkeley, der alle Standard-Bourne-Shell-
27 Befehle unterstützt und dennoch erheblich weniger Platz beansprucht als bash. 
28
29 %description -l fr
30 ash est un clone Berkeley du shell Bourne. Il gère toutes les commandes
31 standard du shell Bourne et a l'avantage de les gérer tout en restant
32 considérablement plus petit que bash.
33
34 %description -l pl
35 Ash jest klonem shell'a Bourne'a z Berkely. Obs³uguje standardowe komendy
36 shell'a Bourne'a i jest mniejszy ni¿ bash. 
37
38 %description -l tr
39 ash, Berkeley'in bir bourne kabuðu kopyasýdýr. Standart bourne kabuðu
40 komutlarýnýn tümünü destekler ve bash kabuðundan daha küçük olma
41 avantajýna sahiptir.
42
43 %prep
44 %setup  -q -n ash-linux-%{version}
45 %patch0 -p1
46 %patch1 -p1
47
48 %build
49 make
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53 install -d $RPM_BUILD_ROOT/{bin,usr/man/man1}
54
55 install sh $RPM_BUILD_ROOT/bin/ash
56 install sh.1 $RPM_BUILD_ROOT%{_mandir}/man1/ash.1
57 echo ".so ash.1" > $RPM_BUILD_ROOT%{_mandir}/man1/bsh.1
58 ln -sf ash $RPM_BUILD_ROOT/bin/bsh
59
60 rm -f sh
61 make STATIC=-static
62
63 install sh $RPM_BUILD_ROOT/bin/ash.static
64
65 gzip -9nf $RPM_BUILD_ROOT%{_mandir}/man1/*
66
67 %post
68 umask 022
69 echo "/bin/ash\n/bin/bsh" >> /etc/shells
70 cat /etc/shells | sort -u > /etc/shells.new
71 mv /etc/shells.new /etc/shells
72
73 %postun
74 if [ "$0" = 0 ]; then
75         egrep -v "^/bin/ash|^/bin/bsh" /etc/shells > /etc/shells.new
76         mv /etc/shells.new /etc/shells
77 fi
78
79 %verifyscript
80 for n in ash bsh; do
81     echo -n "Looking for $n in /etc/shells... "
82     if ! grep "^/bin/${n}\$" /etc/shells > /dev/null; then
83         echo "missing"
84         echo "${n} missing from /etc/shells" >&2
85     else
86         echo "found"
87     fi
88 done
89
90 %clean
91 rm -rf $RPM_BUILD_ROOT
92
93 %files
94 %defattr(644,root,root,755)
95 %attr(755,root,root) /bin/*
96 %{_mandir}/man1/*
97
98 %changelog
99 * Wed Apr 21 1999 Piotr Czerwiñski <pius@pld.org.pl>
100   [0.2-17]
101 - added Group(pl),
102 - added full %defattr description,
103 - recompiled on rpm 3.
104
105 * Thu Mar 25 1999 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
106   [0.2-16]
107 - removed man group from man pages.
108
109 * Wed Dec 23 1998 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
110   [0.2-15]
111 - simplification in %postun and %post,
112 - added gzipping man pages.
113
114 * Fri Nov 06 1998 Preston Brown <pbrown@redhat.com>
115   [0.2-14]
116 - updated to correct path on SunSITE.
117
118 * Sun Sep 27 1998 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
119   [0.2-13]
120 - added -q %setup parameter,
121 - simplification in %install,
122 - bsh(1) man page is now maked as nroff include to ash(1) instead
123   making sym link to ash.1 (this allow compress man pages in future).
124
125 * Mon Jun 29 1998 Wojtek Slusarczyk <wojtek@shadow.eu.org>
126 - added pl translation.
127
128 * Tue May 05 1998 Prospector System <bugs@redhat.com>
129 - translations modified for de, fr, tr
130
131 * Mon Oct 20 1997 Erik Troan <ewt@redhat.com>
132 - made /bin/ash built shared
133 - added ash.static
134 - uses a buildroot and %attr
135
136 * Sun Aug 24 1997 Erik Troan <ewt@redhat.com>
137 - built against glibc
138 - statically linked
139
140 * Wed Apr 16 1997 Erik Troan <ewt@redhat.com>
141 - fixed preinstall script to >> /etc/shells for bsh.
This page took 0.050359 seconds and 4 git commands to generate.