]> git.pld-linux.org Git - packages/ash.git/blob - ash.spec
- added -q %setup parameter,
[packages/ash.git] / ash.spec
1 Summary:     Small bourne shell from Berkeley
2 Summary(de): Kleine Bourne-Shell von Berkeley
3 Summary(fr): Shell Bourne réduit de Berkeley
4 Summary(pl): Ma³y shell bourne'a 
5 Summary(tr): Ufak bir bourne kabuðu
6 Name:        ash
7 Version:     0.2
8 Release:     13
9 Copyright:   BSD
10 Group:       Shells
11 Source:      ftp://sunsite.unc.edu:/pub/Linux/system/Shells/ash-linux-%{version}.tar.gz
12 Patch:       ash.patch
13 Prereq:      fileutils, grep
14 Buildroot:   /tmp/%{name}-%{version}-root
15 Conflicts:   mkinitrd <= 1.7
16
17 %description
18 ash is a bourne shell clone from Berkeley.  It supports all of the standard
19 Bourne shell commands and has the advantage of supporting them while 
20 remaining considerably smaller than bash. 
21
22 %description -l de
23 ash ist ein Bourne-Shell-Clone aus Berkeley, der alle Standard-Bourne-Shell-
24 Befehle unterstützt und dennoch erheblich weniger Platz beansprucht als bash. 
25
26 %description -l fr
27 ash est un clone Berkeley du shell Bourne. Il gère toutes les commandes
28 standard du shell Bourne et a l'avantage de les gérer tout en restant
29 considérablement plus petit que bash.
30
31 %description -l pl
32 Ash jest klonem shell'a bourne'a z Berkely. Obs³uguje standardowe komendy
33 shell'a Bourne'a i jest mniejszy ni¿ bash. 
34
35 %description -l tr
36 ash, Berkeley'in bir bourne kabuðu kopyasýdýr. Standart bourne kabuðu
37 komutlarýnýn tümünü destekler ve bash kabuðundan daha küçük olma
38 avantajýna sahiptir.
39
40 %prep
41 %setup -q -n ash-linux-%{version}
42 %patch -p1
43
44 %build
45 make
46 strip sh
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50 install -d $RPM_BUILD_ROOT/{bin,usr/man/man1}
51
52 install -s sh $RPM_BUILD_ROOT/bin/ash
53 install sh.1 $RPM_BUILD_ROOT/usr/man/man1/ash.1
54 echo ".so ash.1" > $RPM_BUILD_ROOT/usr/man/man1/bsh.1
55 ln -sf ash $RPM_BUILD_ROOT/bin/bsh
56
57 rm -f sh
58 make STATIC=-static
59
60 install -s sh $RPM_BUILD_ROOT/bin/ash.static
61
62 %post
63 if [ ! -f /etc/shells ]; then
64         echo "/bin/ash" > /etc/shells
65         echo "/bin/bsh" >> /etc/shells
66 else
67         if ! grep '^/bin/ash$' /etc/shells > /dev/null; then
68                 echo "/bin/ash" >> /etc/shells
69         fi
70         if ! grep '^/bin/bsh$' /etc/shells > /dev/null; then
71                 echo "/bin/bsh" >> /etc/shells
72         fi
73 fi
74
75 %postun
76 if [ "$0" = 0 ]; then
77         grep -v '^/bin/ash' < /etc/shells | grep -v '^/bin/bsh' > /etc/shells.new
78         mv /etc/shells.new /etc/shells
79 fi
80
81 %verifyscript
82 for n in ash bsh; do
83     echo -n "Looking for $n in /etc/shells... "
84     if ! grep "^/bin/${n}\$" /etc/shells > /dev/null; then
85         echo "missing"
86         echo "${n} missing from /etc/shells" >&2
87     else
88         echo "found"
89     fi
90 done
91
92 %clean
93 rm -rf $RPM_BUILD_ROOT
94
95 %files
96 %attr(755, root, root) /bin/*
97 %attr(644, root,  man) /usr/man/man1/*
98
99 %changelog
100 * Sun Sep 27 1998 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
101   [0.2-13]
102 - added -q %setup parameter,
103 - simplification in %install,
104 - bsh(1) man page is now maked as nroff include to ash(1) instead
105   making sym link to ash.1 (this allow compress man pages in future).
106
107 * Mon Jun 29 1998 Wojtek ¦lusarczyk <wojtek@shadow.eu.org>
108 - added pl translation.
109
110 * Tue May 05 1998 Prospector System <bugs@redhat.com>
111 - translations modified for de, fr, tr
112
113 * Mon Oct 20 1997 Erik Troan <ewt@redhat.com>
114 - made /bin/ash built shared
115 - added ash.static
116 - uses a buildroot and %attr
117
118 * Sun Aug 24 1997 Erik Troan <ewt@redhat.com>
119 - built against glibc
120 - statically linked
121
122 * Wed Apr 16 1997 Erik Troan <ewt@redhat.com>
123 - fixed preinstall script to >> /etc/shells for bsh.
This page took 0.044244 seconds and 4 git commands to generate.