]> git.pld-linux.org Git - packages/ash.git/blob - ash.spec
kupa drobnych poprawek (teraz te pakiety buduja sie poprawnie)
[packages/ash.git] / ash.spec
1 Summary:        Small bourne shell from Berkeley
2 Summary(de):    Kleine Bourne-Shell von Berkeley
3 Summary(fr):    Shell Bourne réduit de Berkeley
4 Summary(pl):    Ma³y shell bourne'a 
5 Summary(tr):    Ufak bir bourne kabuðu
6 Name:           ash
7 Version:        0.2
8 Release:        18
9 Copyright:      BSD
10 Group:          Shells
11 Group(pl):      Pow³oki
12 Source:         ftp://sunsite.unc.edu/pub/Linux/system/shells/ash-linux-%{version}.tar.gz
13 Patch0:         ash-make.patch
14 Patch1:         ash-mknodes.patch
15 Prereq:         fileutils
16 Prereq:         grep
17 BuildRoot:      /tmp/%{name}-%{version}-root
18 Conflicts:      mkinitrd <= 1.7
19
20 %description
21 ash is a bourne shell clone from Berkeley.  It supports all of the standard
22 Bourne shell commands and has the advantage of supporting them while 
23 remaining considerably smaller than bash. 
24
25 %description -l de
26 ash ist ein Bourne-Shell-Clone aus Berkeley, der alle Standard-Bourne-Shell-
27 Befehle unterstützt und dennoch erheblich weniger Platz beansprucht als bash. 
28
29 %description -l fr
30 ash est un clone Berkeley du shell Bourne. Il gère toutes les commandes
31 standard du shell Bourne et a l'avantage de les gérer tout en restant
32 considérablement plus petit que bash.
33
34 %description -l pl
35 Ash jest klonem shell'a Bourne'a z Berkely. Obs³uguje standardowe komendy
36 shell'a Bourne'a i jest mniejszy ni¿ bash. 
37
38 %description -l tr
39 ash, Berkeley'in bir bourne kabuðu kopyasýdýr. Standart bourne kabuðu
40 komutlarýnýn tümünü destekler ve bash kabuðundan daha küçük olma
41 avantajýna sahiptir.
42
43 %prep
44 %setup  -q -n ash-linux-%{version}
45 %patch0 -p1
46 %patch1 -p1
47
48 %build
49 make
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53 install -d $RPM_BUILD_ROOT/{bin,%{_mandir}/man1}
54
55 install sh $RPM_BUILD_ROOT/bin/ash
56 install sh.1 $RPM_BUILD_ROOT%{_mandir}/man1/ash.1
57 echo ".so ash.1" > $RPM_BUILD_ROOT%{_mandir}/man1/bsh.1
58 ln -sf ash $RPM_BUILD_ROOT/bin/bsh
59
60 rm -f sh
61 make STATIC=-static
62
63 install sh $RPM_BUILD_ROOT/bin/ash.static
64
65 gzip -9nf $RPM_BUILD_ROOT%{_mandir}/man1/*
66
67 %post
68 if [ ! -f /etc/shells ]; then
69         echo "/bin/ash" > /etc/shells
70         echo "/bin/bsh" >> /etc/shells
71         echo "/bin/ash.static" >> /etc/shells
72 else
73         if ! grep '^/bin/ash$' /etc/shells > /dev/null; then
74                 echo "/bin/ash" >> /etc/shells
75         fi
76         if ! grep '^/bin/bsh$' /etc/shells > /dev/null; then
77                 echo "/bin/bsh" >> /etc/shells
78         fi
79         if ! grep '^/bin/ash.static$' /etc/shells > /dev/null; then
80                 echo "/bin/ash.static" >> /etc/shells
81         fi
82 fi
83
84 %postun
85 if [ "$0" = 0 ]; then
86         grep -v /bin/ash /etc/shells | grep -v /bin/bsh | grep -v /bin/ash.static > /etc/shells.new
87         mv /etc/shells.new /etc/shells
88 fi
89
90 %verifyscript
91 for n in ash bsh ash.static; do
92     echo -n "Looking for $n in /etc/shells... "
93     if ! grep "^/bin/${n}\$" /etc/shells > /dev/null; then
94         echo "missing"
95         echo "${n} missing from /etc/shells" >&2
96     else
97         echo "found"
98     fi
99 done
100
101 %clean
102 rm -rf $RPM_BUILD_ROOT
103
104 %files
105 %defattr(644,root,root,755)
106 %attr(755,root,root) /bin/*
107 %{_mandir}/man1/*
108
109 %changelog
110 * Mon Jun 07 1999 Jan Rêkorajski <baggins@pld.org.pl>
111   [0.2-18]
112 - spec cleanup
113
114 * Wed Apr 21 1999 Piotr Czerwiñski <pius@pld.org.pl>
115   [0.2-17]
116 - added Group(pl),
117 - added full %defattr description,
118 - recompiled on rpm 3.
119
120 * Thu Mar 25 1999 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
121   [0.2-16]
122 - removed man group from man pages.
123
124 * Wed Dec 23 1998 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
125   [0.2-15]
126 - simplification in %postun and %post,
127 - added gzipping man pages.
128
129 * Fri Nov 06 1998 Preston Brown <pbrown@redhat.com>
130   [0.2-14]
131 - updated to correct path on SunSITE.
132
133 * Sun Sep 27 1998 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
134   [0.2-13]
135 - added -q %setup parameter,
136 - simplification in %install,
137 - bsh(1) man page is now maked as nroff include to ash(1) instead
138   making sym link to ash.1 (this allow compress man pages in future).
139
140 * Mon Jun 29 1998 Wojtek Slusarczyk <wojtek@shadow.eu.org>
141 - added pl translation.
142
143 * Tue May 05 1998 Prospector System <bugs@redhat.com>
144 - translations modified for de, fr, tr
145
146 * Mon Oct 20 1997 Erik Troan <ewt@redhat.com>
147 - made /bin/ash built shared
148 - added ash.static
149 - uses a buildroot and %attr
150
151 * Sun Aug 24 1997 Erik Troan <ewt@redhat.com>
152 - built against glibc
153 - statically linked
154
155 * Wed Apr 16 1997 Erik Troan <ewt@redhat.com>
156 - fixed preinstall script to >> /etc/shells for bsh.
This page took 0.068627 seconds and 4 git commands to generate.