]> git.pld-linux.org Git - packages/ash.git/blob - ash.spec
- bumped up revision,
[packages/ash.git] / ash.spec
1 Summary:     Small bourne shell from Berkeley
2 Summary(de): Kleine Bourne-Shell von Berkeley
3 Summary(fr): Shell Bourne réduit de Berkeley
4 Summary(pl): Ma³y shell bourne'a 
5 Summary(tr): Ufak bir bourne kabuðu
6 Name:        ash
7 Version:     0.2
8 Release:     14
9 Copyright:   BSD
10 Group:       Shells
11 Source:      ftp://sunsite.unc.edu:/pub/Linux/system/shells/ash-linux-%{version}.tar.gz
12 Patch:       ash-make.patch
13 Prereq:      fileutils, grep
14 Buildroot:   /tmp/%{name}-%{version}-root
15 Conflicts:   mkinitrd <= 1.7
16
17 %description
18 ash is a bourne shell clone from Berkeley.  It supports all of the standard
19 Bourne shell commands and has the advantage of supporting them while 
20 remaining considerably smaller than bash. 
21
22 %description -l de
23 ash ist ein Bourne-Shell-Clone aus Berkeley, der alle Standard-Bourne-Shell-
24 Befehle unterstützt und dennoch erheblich weniger Platz beansprucht als bash. 
25
26 %description -l fr
27 ash est un clone Berkeley du shell Bourne. Il gère toutes les commandes
28 standard du shell Bourne et a l'avantage de les gérer tout en restant
29 considérablement plus petit que bash.
30
31 %description -l pl
32 Ash jest klonem shell'a bourne'a z Berkely. Obs³uguje standardowe komendy
33 shell'a Bourne'a i jest mniejszy ni¿ bash. 
34
35 %description -l tr
36 ash, Berkeley'in bir bourne kabuðu kopyasýdýr. Standart bourne kabuðu
37 komutlarýnýn tümünü destekler ve bash kabuðundan daha küçük olma
38 avantajýna sahiptir.
39
40 %prep
41 %setup -q -n ash-linux-%{version}
42 %patch -p1
43
44 %build
45 make
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49 install -d $RPM_BUILD_ROOT/{bin,usr/man/man1}
50
51 install -s sh $RPM_BUILD_ROOT/bin/ash
52 install sh.1 $RPM_BUILD_ROOT/usr/man/man1/ash.1
53 echo ".so ash.1" > $RPM_BUILD_ROOT/usr/man/man1/bsh.1
54 ln -sf ash $RPM_BUILD_ROOT/bin/bsh
55
56 rm -f sh
57 make STATIC=-static
58
59 install -s sh $RPM_BUILD_ROOT/bin/ash.static
60
61 %post
62 if [ ! -f /etc/shells ]; then
63         echo "/bin/ash" > /etc/shells
64         echo "/bin/bsh" >> /etc/shells
65 else
66         if ! grep '^/bin/ash$' /etc/shells > /dev/null; then
67                 echo "/bin/ash" >> /etc/shells
68         fi
69         if ! grep '^/bin/bsh$' /etc/shells > /dev/null; then
70                 echo "/bin/bsh" >> /etc/shells
71         fi
72 fi
73
74 %postun
75 if [ "$0" = 0 ]; then
76         grep -v '^/bin/ash' < /etc/shells | grep -v '^/bin/bsh' > /etc/shells.new
77         mv /etc/shells.new /etc/shells
78 fi
79
80 %verifyscript
81 for n in ash bsh; do
82     echo -n "Looking for $n in /etc/shells... "
83     if ! grep "^/bin/${n}\$" /etc/shells > /dev/null; then
84         echo "missing"
85         echo "${n} missing from /etc/shells" >&2
86     else
87         echo "found"
88     fi
89 done
90
91 %clean
92 rm -rf $RPM_BUILD_ROOT
93
94 %files
95 %attr(755, root, root) /bin/*
96 %attr(644, root,  man) /usr/man/man1/*
97
98 %changelog
99 * Fri Nov 06 1998 Preston Brown <pbrown@redhat.com>
100   [0.2-14]
101 - updated to correct path on SunSITE.
102
103 * Sun Sep 27 1998 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
104   [0.2-13]
105 - added -q %setup parameter,
106 - simplification in %install,
107 - bsh(1) man page is now maked as nroff include to ash(1) instead
108   making sym link to ash.1 (this allow compress man pages in future).
109
110 * Mon Jun 29 1998 Wojtek Slusarczyk <wojtek@shadow.eu.org>
111 - added pl translation.
112
113 * Tue May 05 1998 Prospector System <bugs@redhat.com>
114 - translations modified for de, fr, tr
115
116 * Mon Oct 20 1997 Erik Troan <ewt@redhat.com>
117 - made /bin/ash built shared
118 - added ash.static
119 - uses a buildroot and %attr
120
121 * Sun Aug 24 1997 Erik Troan <ewt@redhat.com>
122 - built against glibc
123 - statically linked
124
125 * Wed Apr 16 1997 Erik Troan <ewt@redhat.com>
126 - fixed preinstall script to >> /etc/shells for bsh.
This page took 0.072541 seconds and 4 git commands to generate.