]> git.pld-linux.org Git - packages/arts.git/commitdiff
- merged DEVEL to HEAD (I have no idea why this file was branched)
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Mon, 29 Apr 2002 21:19:00 +0000 (21:19 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    arts.spec -> 1.2

arts.spec

index ce7da230072917fe1c3efd47ffe80efa9057c006..715307b7964dca13197321597fe5281fbd2cfa5c 100644 (file)
--- a/arts.spec
+++ b/arts.spec
@@ -1,19 +1,42 @@
-%define                _sub_ver        rc3
+%define                _kde_ver        3.0
+%define                _ver            1.0.0
+# Set this to rc3 and such.
+# define               _sub_ver
+%define                _rel            2
+
+# Set up version, release and FTP directory.
+%{?_sub_ver:   %define _version        %{_ver}%{_sub_ver}}
+%{!?_sub_ver:  %define _version        %{_ver}}
+%{?_sub_ver:   %define _release        0.%{_sub_ver}.%{_rel}}
+%{!?_sub_ver:  %define _release        %{_rel}}
+%{!?_sub_ver:  %define _ftpdir stable}
+%{?_sub_ver:   %define _ftpdir unstable/kde-%{version}%{_sub_ver}}
+
 Summary:       aRts sound server
 Summary(es):   Sound server used by KDE
 Summary(pl):   Serwer d¼wiêku
 Summary(pt_BR):        Servidor de sons usado pelo KDE
-Name:          kdelibs
-Version:       3.0
-Release:       0.%{_sub_ver}.2
-Epoch:         6
+Name:          arts
+Version:       %{_version}
+Release:       %{_release}
+Epoch:         8
 License:       LGPL
 Vendor:                The KDE Team
 Group:         Libraries
-%{!?_sub_ver:  %define _ftpdir stable}
-%{?_sub_ver:   %define _ftpdir unstable/kde-%{version}%{_sub_ver}}
-Source0:       ftp://ftp.kde.org/pub/kde/%{_ftpdir}/src/%{name}-%{version}%{_sub_ver}.tar.bz2
-Requires:      qt >= 3.0.2-0.20020222.5
+Source0:       ftp://ftp.kde.org/pub/kde/%{_ftpdir}/%{_kde_ver}/src/%{name}-%{version}.tar.bz2
+BuildRequires: alsa-lib-devel
+BuildRequires: audiofile-devel
+BuildRequires: glib2-devel >= 2.0.0
+BuildRequires: libjpeg-devel
+BuildRequires: libpng-devel >= 1.2.2-2
+# not needed, only ./configure check for this
+#BuildRequires:        libvorbis-devel
+#BuildRequires:        mad-devel
+BuildRequires: pkgconfig
+BuildRequires: qt-devel >= 3.0.3
+BuildRequires: XFree86-devel
+BuildRequires: zlib-devel
+Requires:      qt >= 3.0.3
 URL:           http://www.kde.org/
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -57,7 +80,7 @@ X11 dependent part of aRts.
 %description X11 -l pl
 Czê¶æ aRts wymagaj±ca X11.
 
-%package -n qt
+%package qt
 Summary:       QT dependend part of aRts
 Summary(pl):   Czê¶æ aRts wymagaj±ca QT
 Group:         X11/Libraries
@@ -75,7 +98,7 @@ QT dependend part of aRts.
 %description qt -l pl
 Czê¶æ aRts wymagaj±ca QT.
 
-%package -n devel
+%package devel
 Summary:       Sound server - header files
 Summary(es):   Header files for compiling aRtsd applications
 Summary(pl):   Serwer d¼wiêku - pliki nag³ówkowe
@@ -103,63 +126,48 @@ arts.
 %description devel -l pt_BR
 Arquivos para desenvolvimento com o o aRts.
 
-%package message
-Summary:       Program which can be used to display aRts daemon messages
-Summary(pl):   Program do wy¶wietlania komunikatów daemona aRts
-Group:         Development/Tools
-Group(de):     Entwicklung/Werkzeuge
-Group(fr):     Development/Outils
-Group(pl):     Programowanie/Narzêdzia
+%package glib
+Summary:       GLib dependend part of aRts
+Summary(pl):   Czê¶æ aRts wymagaj±ca GLib
+Group:         X11/Libraries
 
-%description message
-This program can be given as -m option argument to aRts daemon. It
-will be called to display messages generated by daemon.
+%description glib
+GLib dependend part of aRts.
 
-%description message -l pl
-Ten program mo¿e byæ przekazany daemonowi aRts jako parametr opcji -m.
-Bêdzie on wywo³ywany w celu wy¶wietlenia komunikatów daemona.
+%description glib -l pl
+Czê¶æ aRts wymagaj±ca GLib.
 
 %prep
-%setup -q -n "%{name}-%{version}%{_sub_ver}"
+%setup -q
 
 %build
 kde_htmldir="%{_htmldir}"; export kde_htmldir
 kde_icondir="%{_pixmapsdir}"; export kde_icondir
 
-%{__make} -f Makefile.cvs
+#%{__make} -f Makefile.cvs
 
-CFLAGS="%{rpmcflags}"
-CXXFLAGS="%{rpmcflags}"
+CFLAGS="%{rpmcflags} `pkg-config libpng12 --cflags`"; export CFLAGS
+CXXFLAGS="%{rpmcflags}"; export CXXFLAGS
 %configure \
        --%{?debug:en}%{!?debug:dis}able-debug \
        --enable-final \
-       --with-alsa \
-
-## Cannot patch configure.in because it does not rebuild correctly on ac25
-#sed -e 's@#define HAVE_LIBAUDIONAS 1@/* #undef HAVE_LIBAUDIONAS */@' \
-#      < config.h \
-#      > config.h.tmp
-#mv -f config.h{.tmp,}
+       --with-xinerama \
+       --with-alsa 
 
 %{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
-#install -d $RPM_BUILD_ROOT%{_pixmapsdir}/{hicolor,locolor}/{16x16,22x22,32x32,48x48}/{actions,apps,devices,filesystems,mimetypes}
 
 %{__make} install DESTDIR=$RPM_BUILD_ROOT
 
-gzip arts/doc/{README,NEWS,TODO}
-
-%find_lang %{name} --with-kde --all-name
-
 %post -p /sbin/ldconfig
 %postun -p /sbin/ldconfig
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%files -f arts.lang
+%files
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/artscat
 %attr(755,root,root) %{_bindir}/artsd
@@ -185,17 +193,17 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/libqtmcop.so.*.*.*
 %attr(755,root,root) %{_libdir}/libqtmcop.la
 
+%files glib
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/libgmcop.so.*.*.*
+%attr(755,root,root) %{_libdir}/libgmcop.la
+
 %files devel
 %defattr(644,root,root,755)
-%doc arts/doc/*.gz
 %attr(755,root,root) %{_bindir}/artsc-config
 %attr(755,root,root) %{_bindir}/mcopidl
-%{_libdir}/lib[mqsx]*.so
+%{_libdir}/lib[mqsxg]*.so
 %{_libdir}/libarts[!k]*.so
 %{_libdir}/libkmedia*.so
 %{_includedir}/arts
 %{_includedir}/artsc
-
-%files message
-%defattr(644,root,root,755)
-%attr(755,root,root) %{_bindir}/artsmessage
This page took 0.051312 seconds and 4 git commands to generate.