]> git.pld-linux.org Git - packages/arts.git/commitdiff
- orphaned, outdated
authorJan Rękorajski <baggins@pld-linux.org>
Fri, 21 Apr 2006 23:40:25 +0000 (23:40 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    arts-1.1.1-streaming-20030317.patch -> 1.2
    arts-1.1.1-video-20030314.patch -> 1.2
    arts-modules.patch -> 1.2
    arts-nas.patch -> 1.2
    arts-nonas.patch -> 1.2

arts-1.1.1-streaming-20030317.patch [deleted file]
arts-1.1.1-video-20030314.patch [deleted file]
arts-modules.patch [deleted file]
arts-nas.patch [deleted file]
arts-nonas.patch [deleted file]

diff --git a/arts-1.1.1-streaming-20030317.patch b/arts-1.1.1-streaming-20030317.patch
deleted file mode 100644 (file)
index c9d330b..0000000
+++ /dev/null
@@ -1,40 +0,0 @@
---- arts-1.1.1/soundserver/soundserverv2_impl.cc.orig  2003-03-17 09:24:17.000000000 +0100
-+++ arts-1.1.1/soundserver/soundserverv2_impl.cc       2003-03-17 09:19:54.000000000 +0100
-@@ -119,7 +119,36 @@
-       TraderQuery query;
-       query.supports("Interface","Arts::PlayObject");
--      query.supports("MimeType", mimetype);
-+
-+      /* Parse URL protocol */
-+      string protocol;
-+
-+      unsigned int urlProto = url.find( ":/" );
-+
-+      if (urlProto != std::string::npos)
-+      {
-+              /* Remove [user[:passwd]@] */
-+              unsigned int urlAt = url.find( '@' );
-+
-+              if (urlAt++ == std::string::npos || urlAt >= urlProto)
-+              {
-+                      urlAt = 0;
-+              }
-+
-+              /* Remove [:port] */
-+              urlProto = url.find( ':', urlAt );
-+
-+              protocol = std::string( url, urlAt, (urlProto - urlAt) );
-+      }
-+
-+      if (!protocol.empty() && protocol != "file")
-+      {
-+              query.supports("Protocol", protocol);
-+      }
-+      if (mimetype != "application/octet-stream")
-+      {
-+              query.supports("MimeType", mimetype);
-+      }
-       string objectType;
diff --git a/arts-1.1.1-video-20030314.patch b/arts-1.1.1-video-20030314.patch
deleted file mode 100644 (file)
index 906531f..0000000
+++ /dev/null
@@ -1,30 +0,0 @@
---- arts-1.1.1/soundserver/kmedia2.idl.video   2003-03-14 22:08:11.000000000 +0100
-+++ arts-1.1.1/soundserver/kmedia2.idl 2003-03-14 22:29:04.000000000 +0100
-@@ -206,14 +206,23 @@
-  */
- interface VideoPlayObject {
-     /**
--     * video output window (active)
--     */
--    attribute long x11WindowId;
--    /**
-      * take a snapshot and draw it onto a pixmap
-      * returns the X11 pixmap ID or -1 on error
-      */
-     long x11Snapshot();
-+    /**
-+     * returns the current value of the property
-+     *
-+     * @param name the name of the property to return
-+     */
-+    long property(string name);
-+    /**
-+     * sets a property
-+     *
-+     * @param name the name of the property to set
-+     * @param value the new value for the property
-+     */
-+    void property(string name, long value);
- };
- /**
diff --git a/arts-modules.patch b/arts-modules.patch
deleted file mode 100644 (file)
index 14b91fa..0000000
+++ /dev/null
@@ -1,54 +0,0 @@
---- arts-030515/artsc/Makefile.am~     2003-03-24 00:30:02.000000000 +0100
-+++ arts-030515/artsc/Makefile.am      2003-05-15 15:26:39.000000000 +0200
-@@ -9,11 +9,11 @@
- bin_SCRIPTS = artsc-config artsdsp
- libartsdsp_la_SOURCES = artsdsp.c
--libartsdsp_la_LDFLAGS = -no-undefined -module $(all_libraries)
-+libartsdsp_la_LDFLAGS = -no-undefined -module -avoid-version $(all_libraries)
- libartsdsp_la_LIBADD = libartsc.la
- libartsdsp_st_la_SOURCES = artsc.c artsdsp.c
--libartsdsp_st_la_LDFLAGS = -no-undefined -module $(all_libraries)
-+libartsdsp_st_la_LDFLAGS = -no-undefined -module -avoid-version $(all_libraries)
- libartsdsp_st_la_LIBADD = $(top_builddir)/libltdl/libltdlc.la
- libartsc_la_SOURCES = artsc.c
-@@ -21,7 +21,7 @@
- libartsc_la_LIBADD = $(top_builddir)/libltdl/libltdlc.la $(LIBPTHREAD) $(USE_THREADS)
- libartscbackend_la_SOURCES = artscbackend.cc
--libartscbackend_la_LDFLAGS = -no-undefined -module $(KDE_RPATH) $(all_libraries)
-+libartscbackend_la_LDFLAGS = -no-undefined -module -avoid-version $(KDE_RPATH) $(all_libraries)
- libartscbackend_la_LIBADD = $(FLOWLIBS) \
-     $(top_builddir)/soundserver/libsoundserver_idl.la
---- arts-030515/soundserver/Makefile.am~       2003-03-24 00:30:05.000000000 +0100
-+++ arts-030515/soundserver/Makefile.am        2003-05-15 15:29:59.000000000 +0200
-@@ -38,13 +38,13 @@
- libartswavplayobject_la_SOURCES = wavplayobject_impl.cc
- libartswavplayobject_la_LIBADD  = $(top_builddir)/mcop/libmcop.la \
-                                   libsoundserver_idl.la $(FLOWLIBS)
--libartswavplayobject_la_LDFLAGS = -no-undefined -module $(all_libraries)
-+libartswavplayobject_la_LDFLAGS = -no-undefined -module -avoid-version $(all_libraries)
- libartswavplayobject_la_COMPILE_FIRST = soundserver.h ../flow/artsflow.h
- libartsgslplayobject_la_SOURCES = gslplayobject_impl.cc
- libartsgslplayobject_la_LIBADD  = $(top_builddir)/mcop/libmcop.la \
-                                   libsoundserver_idl.la $(FLOWLIBS)
--libartsgslplayobject_la_LDFLAGS = -no-undefined -module $(all_libraries)
-+libartsgslplayobject_la_LDFLAGS = -no-undefined -module -avoid-version $(all_libraries)
- libartsgslplayobject_la_COMPILE_FIRST = soundserver.h ../flow/artsflow.h
- ###### "real" programs
---- arts-030515/x11/Makefile.am~       2003-03-24 00:30:05.000000000 +0100
-+++ arts-030515/x11/Makefile.am        2003-05-15 15:32:15.000000000 +0200
-@@ -4,7 +4,7 @@
- libx11globalcomm_la_SOURCES = x11globalcomm.cc x11globalcomm_impl.cc
- libx11globalcomm_la_LIBADD = $(top_builddir)/mcop/libmcop.la $(LIB_X11)
--libx11globalcomm_la_LDFLAGS = -no-undefined -module -version-info 1:0 $(X_LDFLAGS) $(all_libraries)
-+libx11globalcomm_la_LDFLAGS = -no-undefined -module -avoid-version $(X_LDFLAGS) $(all_libraries)
- DISTCLEANFILES = x11globalcomm.cc x11globalcomm.h \
-                  x11globalcomm.mcoptype x11globalcomm.mcopclass
diff --git a/arts-nas.patch b/arts-nas.patch
deleted file mode 100644 (file)
index a358d7e..0000000
+++ /dev/null
@@ -1,32 +0,0 @@
---- arts-1.1.4/configure.in.orig       Wed Sep 10 03:53:29 2003
-+++ arts-1.1.4/configure.in    Tue Mar 16 01:36:12 2004
-@@ -150,6 +150,10 @@
- dnl aRts specific configure tests
- dnl
- dnl Check for libaudio (which can be used to get network audio support)
-+AC_ARG_WITH(nas, [  --with-nas            enable network audio support],
-+[arts_with_nas=$withval])
-+
-+if test "$arts_with_nas" = "yes"; then
- AC_DEFUN([AC_CHECK_LIBAUDIONAS],
- [
-   ac_ldflags_save="$LDFLAGS"
-@@ -177,6 +181,10 @@
-   CPPFLAGS="$ac_CPPFLAGS_save"
-   LDFLAGS="$ac_ldflags_save"
- ])
-+AC_CHECK_LIBAUDIONAS
-+fi
-+
-+AC_SUBST(LIBAUDIONAS)
- dnl libaudiofile is used for loading wave files
- AC_DEFUN([AC_CHECK_LIBAUDIOFILE],
-@@ -428,7 +436,6 @@
- dnl call the tests
- AC_CHECK_LIBAUDIOIO
--AC_CHECK_LIBAUDIONAS
- AC_CHECK_LIBAUDIOFILE
- AC_CHECK_SGILIBAUDIO
- AC_CHECK_REALTIME_SCHED
diff --git a/arts-nonas.patch b/arts-nonas.patch
deleted file mode 100644 (file)
index a175698..0000000
+++ /dev/null
@@ -1,23 +0,0 @@
---- arts-1.1.1/configure.in.in.orig    Sat Mar 22 15:20:21 2003
-+++ arts-1.1.1/configure.in.in Sat Mar 22 15:27:15 2003
-@@ -167,16 +167,17 @@
-   arts_libaudionas_include=no
-   AC_CHECK_HEADER(audio/audiolib.h,
-   [
--    arts_libaudionas_include=yes
-+    arts_libaudionas_include=no
-   ])
-   if test "x$arts_libaudionas_include" = "xyes"; then
-     AC_CHECK_LIB(audio,AuOpenServer,[
-      dnl LDFLAGS in case it's in KDEDIR/lib
--     LIBAUDIONAS="$LDFLAGS -laudio -lXt"
--     AC_DEFINE(HAVE_LIBAUDIONAS, 1,
-+     LIBAUDIONAS=""
-+     AC_DEFINE(HAVE_LIBAUDIONAS, 0,
-         [Define if you have libaudio (required if you want to have NAS support)])
-    ])
-   fi
-+  
-   AC_SUBST(LIBAUDIONAS)
-   AC_LANG_RESTORE
-   CPPFLAGS="$ac_CPPFLAGS_save"
This page took 0.091405 seconds and 4 git commands to generate.