]> git.pld-linux.org Git - packages/arts.git/commitdiff
- Removed modules versioning
authoradgor <adgor@pld-linux.org>
Fri, 16 May 2003 00:16:07 +0000 (00:16 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    arts-modules.patch -> 1.1

arts-modules.patch [new file with mode: 0644]

diff --git a/arts-modules.patch b/arts-modules.patch
new file mode 100644 (file)
index 0000000..14b91fa
--- /dev/null
@@ -0,0 +1,54 @@
+--- arts-030515/artsc/Makefile.am~     2003-03-24 00:30:02.000000000 +0100
++++ arts-030515/artsc/Makefile.am      2003-05-15 15:26:39.000000000 +0200
+@@ -9,11 +9,11 @@
+ bin_SCRIPTS = artsc-config artsdsp
+ libartsdsp_la_SOURCES = artsdsp.c
+-libartsdsp_la_LDFLAGS = -no-undefined -module $(all_libraries)
++libartsdsp_la_LDFLAGS = -no-undefined -module -avoid-version $(all_libraries)
+ libartsdsp_la_LIBADD = libartsc.la
+ libartsdsp_st_la_SOURCES = artsc.c artsdsp.c
+-libartsdsp_st_la_LDFLAGS = -no-undefined -module $(all_libraries)
++libartsdsp_st_la_LDFLAGS = -no-undefined -module -avoid-version $(all_libraries)
+ libartsdsp_st_la_LIBADD = $(top_builddir)/libltdl/libltdlc.la
+ libartsc_la_SOURCES = artsc.c
+@@ -21,7 +21,7 @@
+ libartsc_la_LIBADD = $(top_builddir)/libltdl/libltdlc.la $(LIBPTHREAD) $(USE_THREADS)
+ libartscbackend_la_SOURCES = artscbackend.cc
+-libartscbackend_la_LDFLAGS = -no-undefined -module $(KDE_RPATH) $(all_libraries)
++libartscbackend_la_LDFLAGS = -no-undefined -module -avoid-version $(KDE_RPATH) $(all_libraries)
+ libartscbackend_la_LIBADD = $(FLOWLIBS) \
+     $(top_builddir)/soundserver/libsoundserver_idl.la
+--- arts-030515/soundserver/Makefile.am~       2003-03-24 00:30:05.000000000 +0100
++++ arts-030515/soundserver/Makefile.am        2003-05-15 15:29:59.000000000 +0200
+@@ -38,13 +38,13 @@
+ libartswavplayobject_la_SOURCES = wavplayobject_impl.cc
+ libartswavplayobject_la_LIBADD  = $(top_builddir)/mcop/libmcop.la \
+                                   libsoundserver_idl.la $(FLOWLIBS)
+-libartswavplayobject_la_LDFLAGS = -no-undefined -module $(all_libraries)
++libartswavplayobject_la_LDFLAGS = -no-undefined -module -avoid-version $(all_libraries)
+ libartswavplayobject_la_COMPILE_FIRST = soundserver.h ../flow/artsflow.h
+ libartsgslplayobject_la_SOURCES = gslplayobject_impl.cc
+ libartsgslplayobject_la_LIBADD  = $(top_builddir)/mcop/libmcop.la \
+                                   libsoundserver_idl.la $(FLOWLIBS)
+-libartsgslplayobject_la_LDFLAGS = -no-undefined -module $(all_libraries)
++libartsgslplayobject_la_LDFLAGS = -no-undefined -module -avoid-version $(all_libraries)
+ libartsgslplayobject_la_COMPILE_FIRST = soundserver.h ../flow/artsflow.h
+ ###### "real" programs
+--- arts-030515/x11/Makefile.am~       2003-03-24 00:30:05.000000000 +0100
++++ arts-030515/x11/Makefile.am        2003-05-15 15:32:15.000000000 +0200
+@@ -4,7 +4,7 @@
+ libx11globalcomm_la_SOURCES = x11globalcomm.cc x11globalcomm_impl.cc
+ libx11globalcomm_la_LIBADD = $(top_builddir)/mcop/libmcop.la $(LIB_X11)
+-libx11globalcomm_la_LDFLAGS = -no-undefined -module -version-info 1:0 $(X_LDFLAGS) $(all_libraries)
++libx11globalcomm_la_LDFLAGS = -no-undefined -module -avoid-version $(X_LDFLAGS) $(all_libraries)
+ DISTCLEANFILES = x11globalcomm.cc x11globalcomm.h \
+                  x11globalcomm.mcoptype x11globalcomm.mcopclass
This page took 0.055398 seconds and 4 git commands to generate.