]> git.pld-linux.org Git - packages/arts.git/blob - arts.spec
- post-post-adapter cleanup, unifications
[packages/arts.git] / arts.spec
1 #
2 # Conditional build:
3 %bcond_without  alsa    # disable ALSA support
4 %bcond_with     nas     # enable NAS support
5 %bcond_without  esd     # disable esound support
6 #
7
8 %define         _state          stable
9 %define         _kdever         3.3
10 %define         _ver            1.3.0
11
12 Summary:        aRts sound server
13 Summary(pl):    Serwer d¼wiêku
14 Summary(pt_BR): Servidor de sons usado pelo KDE
15 Name:           arts
16 Version:        %{_ver}
17 Release:        0.1
18 Epoch:          13
19 License:        LGPL
20 Group:          Libraries
21 Source0:        http://download.kde.org/%{_state}/%{_kdever}/src/%{name}-%{_ver}.tar.bz2
22 # Source0-md5:  6a0a03c24a20c43a8e443a5484bb9fef
23 URL:            http://www.kde.org/
24 %{?with_alsa:BuildRequires:     alsa-lib-devel}
25 BuildRequires:  audiofile-devel
26 BuildRequires:  autoconf
27 BuildRequires:  automake
28 BuildRequires:  docbook-dtd41-sgml
29 BuildRequires:  docbook-utils >= 0.6.13-3
30 %{?with_esd:BuildRequires:      esound-devel}
31 BuildRequires:  glib2-devel >= 2.0.0
32 BuildRequires:  libmad-devel
33 BuildRequires:  libtool >= 2:1.5-2
34 BuildRequires:  libvorbis-devel
35 %{?with_nas:BuildRequires:      nas-devel}
36 BuildRequires:  pkgconfig
37 BuildRequires:  qt-devel >= 6:3.2.1-4
38 BuildRequires:  unsermake >= 040805-1
39 Obsoletes:      arts-glib
40 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42 %description
43 The Analog Real-Time Synthesizer, or aRts, is a modular system for
44 synthesizing sound and music on a digital computer. Using small
45 building blocks called modules, the user can easily build complex
46 audio processing tools. Modules typically provide functions such as
47 sound waveform generators, filters, audio effects, mixing, and
48 playback of digital audio in different file formats. The artsd sound
49 server mixes audio from several sources in real time, allowing
50 multiple sound applications to transparently share access to sound
51 hardware.
52
53 %description -l pl
54 Analog Real-Time Synthesizer (w skrócie aRts) to modularny system do
55 obs³ugi d¼wiêku i muzyki na komputerze. Za pomoc± modu³ów u¿ytkownik
56 mo¿e z powodzeniem budowaæ kompleksowe narzêdzia przetwarzania
57 d¼wiêku. Modu³y umo¿liwiaj± generacjê kstza³tu fali, filtrowanie,
58 efekty audio, miksowanie oraz odtwarzanie d¼wiêku cyfrowego w ró¿nych
59 formatach. Serwer d¼wiêku artsd umo¿liwia równie¿ jednoczesne
60 odtwarzanie d¼wiêku z wielu ¼róde³.
61
62 %description -l pt_BR
63 O aRts é um sintetizador analógico em tempo real que é completamente
64 modular. Você pode criar sons e músicas (síntese em tempo real de
65 midi) usando pequenos módulos como oscilador para criar waveforms,
66 vários filtros, mixers, faders, etc. Você pode configurar tudo através
67 de uma interface no KDE. O Servidor aRts é controlado via CORBA. Este
68 design foi escolhido para permitir que outras aplicações usem o aRts
69 como um sintetizador (ou fornecedor de filtros). Usado pelo KDE, entre
70 outros.
71
72 %package devel
73 Summary:        Sound server - header files
74 Summary(pl):    Serwer d¼wiêku - pliki nag³ówkowe
75 Summary(pt_BR): Arquivos para desenvolvimento com o o aRts
76 Group:          Development/Libraries
77 Requires:       %{name} = %{epoch}:%{version}-%{release}
78 # not necessary for all libs (e.g. mcop), but propagated by artsflow
79 %{?with_alsa:Requires:  alsa-lib-devel}
80 Requires:       audiofile-devel
81 Requires:       esound-devel
82 Requires:       glib2-devel >= 2.0.0
83 Requires:       libmad-devel
84 Requires:       libvorbis-devel
85 %{?with_nas:Requires:   nas-devel}
86
87 %description devel
88 Header files required to compile programs using arts.
89
90 %description devel -l pl
91 Pliki nag³ówkowe niezbêdne do budowania aplikacji korzystaj±cych z
92 arts.
93
94 %description devel -l pt_BR
95 Arquivos para desenvolvimento com o o aRts.
96
97 # separate from arts-devel because they are mostly independent and have very
98 # different deps
99 # there is no artsc base - it would be small and would require arts - so
100 # there is no reason to separate
101 %package -n artsc-devel
102 Summary:        Development files for artsc libraries
103 Summary(pl):    Pliki programistyczne bibliotek artsc
104 Group:          Development/Libraries
105 Requires:       %{name} = %{epoch}:%{version}-%{release}
106 Requires:       glib2-devel >= 2.0.0
107 Conflicts:      arts-devel < 12:1.2.0.031126-2
108
109 %description -n artsc-devel
110 Development files for artsc libraries (C interface to aRts sound
111 system).
112
113 %description -n artsc-devel -l pl
114 Pliki programistyczne bibliotek artsc (interfejsu w C do systemu
115 d¼wiêku aRts).
116
117 %package X11
118 Summary:        X11 dependent part of aRts
119 Summary(pl):    Czê¶æ aRts wymagaj±ca X11
120 Group:          X11/Libraries
121 Requires:       %{name} = %{epoch}:%{version}-%{release}
122
123 %description X11
124 X11 dependent part of aRts (x11globalcomm module).
125
126 %description X11 -l pl
127 Czê¶æ aRts wymagaj±ca X11 (modu³ x11globalcomm).
128
129 %package qt
130 Summary:        QT dependend part of aRts
131 Summary(pl):    Czê¶æ aRts wymagaj±ca QT
132 Group:          X11/Libraries
133 Requires:       %{name} = %{epoch}:%{version}-%{release}
134 Requires:       qt >= 6:3.2.1-4
135
136 %description qt
137 QT dependend part of aRts (qtmcop library).
138
139 %description qt -l pl
140 Czê¶æ aRts wymagaj±ca QT (biblioteka qtmcop).
141
142 %package qt-devel
143 Summary:        Development files for qtmcop library
144 Summary(pl):    Pliki programistyczne dla biblioteki qtmcop
145 Group:          X11/Development/Libraries
146 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
147 Requires:       %{name}-qt = %{epoch}:%{version}-%{release}
148 Requires:       qt-devel >= 6:3.2.1-4
149
150 %description qt-devel
151 Development files for qtmcop library.
152
153 %description qt-devel -l pl
154 Pliki programistyczne dla biblioteki qtmcop.
155
156 %prep
157 %setup -q
158
159 %build
160 cp -f /usr/share/automake/config.sub admin
161
162 export UNSERMAKE=/usr/share/unsermake/unsermake
163
164 %{__make} -f admin/Makefile.common cvs
165
166 %configure \
167         %{!?with_nas:ac_cv_header_audio_audiolib_h=no} \
168         --%{?debug:en}%{!?debug:dis}able-debug \
169         --disable-rpath \
170         --enable-final \
171         --with-qt-libraries=%{_libdir} \
172         --with%{!?with_alsa:out}-alsa
173
174 %{__make}
175
176 %install
177 rm -rf $RPM_BUILD_ROOT
178
179 %{__make} install \
180         DESTDIR=$RPM_BUILD_ROOT
181
182 # Debian manpages
183 install -d $RPM_BUILD_ROOT%{_mandir}/man1
184 cd debian/man
185 for f in *.sgml ; do
186         base="$(basename $f .sgml)"
187         upper="$(echo ${base} | tr a-z A-Z)"
188         db2man $f
189         install ${upper}.1 $RPM_BUILD_ROOT%{_mandir}/man1/${base}.1
190 done
191
192 %clean
193 rm -rf $RPM_BUILD_ROOT
194
195 %post   -p /sbin/ldconfig
196 %postun -p /sbin/ldconfig
197
198 %post   X11 -p /sbin/ldconfig
199 %postun X11 -p /sbin/ldconfig
200
201 %post   qt -p /sbin/ldconfig
202 %postun qt -p /sbin/ldconfig
203
204 %files
205 %defattr(644,root,root,755)
206 %attr(755,root,root) %{_bindir}/artscat
207 %attr(755,root,root) %{_bindir}/artsd
208 %attr(755,root,root) %{_bindir}/artsdsp
209 %attr(755,root,root) %{_bindir}/artsplay
210 %attr(755,root,root) %{_bindir}/artsrec
211 %attr(755,root,root) %{_bindir}/artsshell
212 %attr(755,root,root) %{_bindir}/artswrapper
213 # shared libraries
214 %attr(755,root,root) %{_libdir}/libartsc.so.*.*.*
215 %attr(755,root,root) %{_libdir}/libartsflow.so.*.*.*
216 %attr(755,root,root) %{_libdir}/libartsflow_idl.so.*.*.*
217 %attr(755,root,root) %{_libdir}/libgmcop.so.*.*.*
218 %attr(755,root,root) %{_libdir}/libkmedia2.so.*.*.*
219 %attr(755,root,root) %{_libdir}/libkmedia2_idl.so.*.*.*
220 %attr(755,root,root) %{_libdir}/libmcop.so.*.*.*
221 %attr(755,root,root) %{_libdir}/libmcop_mt.so.*.*.*
222 %attr(755,root,root) %{_libdir}/libsoundserver_idl.so.*.*.*
223 # lt_dlopened modules (*.la needed)
224 %attr(755,root,root) %{_libdir}/libartscbackend.so.*.*.*
225 %{_libdir}/libartscbackend.la
226 %attr(755,root,root) %{_libdir}/libartsdsp.so.*.*.*
227 %{_libdir}/libartsdsp.la
228 %attr(755,root,root) %{_libdir}/libartsdsp_st.so.*.*.*
229 %{_libdir}/libartsdsp_st.la
230 %attr(755,root,root) %{_libdir}/libartsgslplayobject.so.*.*.*
231 %{_libdir}/libartsgslplayobject.la
232 %attr(755,root,root) %{_libdir}/libartswavplayobject.so.*.*.*
233 %{_libdir}/libartswavplayobject.la
234 #
235 %{_libdir}/mcop
236 %{_mandir}/man1/artscat.1*
237 %{_mandir}/man1/artsd.1*
238 %{_mandir}/man1/artsdsp.1*
239 %{_mandir}/man1/artsplay.1*
240 %{_mandir}/man1/artsrec.1*
241 %{_mandir}/man1/artsshell.1*
242 %{_mandir}/man1/artswrapper.1*
243
244 %files devel
245 %defattr(644,root,root,755)
246 %attr(755,root,root) %{_bindir}/mcopidl
247 %attr(755,root,root) %{_libdir}/libartsflow.so
248 %attr(755,root,root) %{_libdir}/libartsflow_idl.so
249 %attr(755,root,root) %{_libdir}/libartsgslplayobject.so
250 %attr(755,root,root) %{_libdir}/libartswavplayobject.so
251 %attr(755,root,root) %{_libdir}/libgmcop.so
252 %attr(755,root,root) %{_libdir}/libkmedia2.so
253 %attr(755,root,root) %{_libdir}/libkmedia2_idl.so
254 %attr(755,root,root) %{_libdir}/libmcop.so
255 %attr(755,root,root) %{_libdir}/libmcop_mt.so
256 %attr(755,root,root) %{_libdir}/libsoundserver_idl.so
257 # it seems to be only (lt_)dlopened, nothing links with it - so not needed
258 # %attr(755,root,root) %{_libdir}/libx11globalcomm.so
259 # shared libraries
260 %{_libdir}/libartsflow.la
261 %{_libdir}/libartsflow_idl.la
262 %{_libdir}/libgmcop.la
263 %{_libdir}/libkmedia2.la
264 %{_libdir}/libkmedia2_idl.la
265 %{_libdir}/libmcop.la
266 %{_libdir}/libmcop_mt.la
267 %{_libdir}/libsoundserver_idl.la
268 #
269 %{_includedir}/arts
270 %exclude %{_includedir}/arts/qiomanager.h
271 %{_mandir}/man1/mcopidl.1*
272
273 %files -n artsc-devel
274 %defattr(644,root,root,755)
275 %attr(755,root,root) %{_bindir}/artsc-config
276 %attr(755,root,root) %{_libdir}/libartsc.so
277 %attr(755,root,root) %{_libdir}/libartscbackend.so
278 %attr(755,root,root) %{_libdir}/libartsdsp.so
279 %attr(755,root,root) %{_libdir}/libartsdsp_st.so
280 %{_libdir}/libartsc.la
281 %{_includedir}/artsc
282 %{_mandir}/man1/artsc-config.1*
283
284 %files X11
285 %defattr(644,root,root,755)
286 # lt_dlopened module (.la needed)
287 %attr(755,root,root) %{_libdir}/libx11globalcomm.so.*.*.*
288 %{_libdir}/libx11globalcomm.la
289
290 %files qt
291 %defattr(644,root,root,755)
292 # shared library
293 %attr(755,root,root) %{_libdir}/libqtmcop.so.*.*.*
294
295 %files qt-devel
296 %defattr(644,root,root,755)
297 %attr(755,root,root) %{_libdir}/libqtmcop.so
298 %{_libdir}/libqtmcop.la
299 %{_includedir}/arts/qiomanager.h
This page took 0.07347 seconds and 4 git commands to generate.