]> git.pld-linux.org Git - packages/arts.git/blob - arts.spec
- disable -fvisibility-inlines-hidden due to gcc bugs.
[packages/arts.git] / arts.spec
1 #
2 # Conditional build:
3 %bcond_without  alsa    # disable ALSA support
4 %bcond_with     nas     # enable NAS support
5 %bcond_without  esd     # disable esound support
6 #
7 %define         _state          stable
8 %define         _kdever         3.4
9 %define         _ver            1.4.0
10 #
11 Summary:        aRts sound server
12 Summary(pl):    Serwer d¼wiêku
13 Summary(pt_BR): Servidor de sons usado pelo KDE
14 Name:           arts
15 Version:        %{_ver}
16 Release:        3
17 Epoch:          13
18 License:        LGPL
19 Group:          Libraries
20 Source0:        ftp://ftp.kde.org/pub/kde/%{_state}/%{_kdever}/src/%{name}-%{version}.tar.bz2
21 # Source0-md5:  a155bb00f56c71bc475890249e2dcaa9
22 Patch100:       %{name}-branch.diff
23 URL:            http://www.arts-project.org/
24 %{?with_alsa:BuildRequires:     alsa-lib-devel}
25 BuildRequires:  audiofile-devel
26 BuildRequires:  autoconf
27 BuildRequires:  automake
28 BuildRequires:  docbook-dtd41-sgml
29 BuildRequires:  docbook-utils >= 0.6.14
30 %{?with_esd:BuildRequires:      esound-devel}
31 BuildRequires:  glib2-devel >= 2.0.0
32 BuildRequires:  jack-audio-connection-kit-devel
33 BuildRequires:  libmad-devel
34 BuildRequires:  libtool >= 2:1.5-2
35 BuildRequires:  libvorbis-devel
36 %{?with_nas:BuildRequires:      nas-devel}
37 BuildRequires:  pkgconfig
38 BuildRequires:  qt-devel >= 6:3.2.1-4
39 #BuildRequires: unsermake >= 040805-1
40 Obsoletes:      arts-glib
41 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43 %description
44 The Analog Real-Time Synthesizer, or aRts, is a modular system for
45 synthesizing sound and music on a digital computer. Using small
46 building blocks called modules, the user can easily build complex
47 audio processing tools. Modules typically provide functions such as
48 sound waveform generators, filters, audio effects, mixing, and
49 playback of digital audio in different file formats. The artsd sound
50 server mixes audio from several sources in real time, allowing
51 multiple sound applications to transparently share access to sound
52 hardware.
53
54 %description -l pl
55 Analog Real-Time Synthesizer (w skrócie aRts) to modularny system do
56 obs³ugi d¼wiêku i muzyki na komputerze. Za pomoc± modu³ów u¿ytkownik
57 mo¿e z powodzeniem budowaæ kompleksowe narzêdzia przetwarzania
58 d¼wiêku. Modu³y umo¿liwiaj± generacjê kszta³tu fali, filtrowanie,
59 efekty audio, miksowanie oraz odtwarzanie d¼wiêku cyfrowego w ró¿nych
60 formatach. Serwer d¼wiêku artsd umo¿liwia równie¿ jednoczesne
61 odtwarzanie d¼wiêku z wielu ¼róde³.
62
63 %description -l pt_BR
64 O aRts é um sintetizador analógico em tempo real que é completamente
65 modular. Você pode criar sons e músicas (síntese em tempo real de
66 midi) usando pequenos módulos como oscilador para criar waveforms,
67 vários filtros, mixers, faders, etc. Você pode configurar tudo através
68 de uma interface no KDE. O Servidor aRts é controlado via CORBA. Este
69 design foi escolhido para permitir que outras aplicações usem o aRts
70 como um sintetizador (ou fornecedor de filtros). Usado pelo KDE, entre
71 outros.
72
73 %package devel
74 Summary:        Sound server - header files
75 Summary(pl):    Serwer d¼wiêku - pliki nag³ówkowe
76 Summary(pt_BR): Arquivos para desenvolvimento com o o aRts
77 Group:          Development/Libraries
78 Requires:       %{name} = %{epoch}:%{version}-%{release}
79 # not necessary for all libs (e.g. mcop), but propagated by artsflow
80 %{?with_alsa:Requires:  alsa-lib-devel}
81 Requires:       audiofile-devel
82 Requires:       esound-devel
83 Requires:       glib2-devel >= 2.0.0
84 Requires:       jack-audio-connection-kit-devel
85 Requires:       libmad-devel
86 Requires:       libvorbis-devel
87 %{?with_nas:Requires:   nas-devel}
88
89 %description devel
90 Header files required to compile programs using arts.
91
92 %description devel -l pl
93 Pliki nag³ówkowe niezbêdne do budowania aplikacji korzystaj±cych z
94 arts.
95
96 %description devel -l pt_BR
97 Arquivos para desenvolvimento com o o aRts.
98
99 # separate from arts-devel because they are mostly independent and have very
100 # different deps
101 # there is no artsc base - it would be small and would require arts - so
102 # there is no reason to separate
103 %package -n artsc-devel
104 Summary:        Development files for artsc libraries
105 Summary(pl):    Pliki programistyczne bibliotek artsc
106 Group:          Development/Libraries
107 Requires:       %{name} = %{epoch}:%{version}-%{release}
108 Requires:       glib2-devel >= 2.0.0
109 Conflicts:      arts-devel < 12:1.2.0.031126-2
110
111 %description -n artsc-devel
112 Development files for artsc libraries (C interface to aRts sound
113 system).
114
115 %description -n artsc-devel -l pl
116 Pliki programistyczne bibliotek artsc (interfejsu w C do systemu
117 d¼wiêku aRts).
118
119 %package X11
120 Summary:        X11 dependent part of aRts
121 Summary(pl):    Czê¶æ aRts wymagaj±ca X11
122 Group:          X11/Libraries
123 Requires:       %{name} = %{epoch}:%{version}-%{release}
124
125 %description X11
126 X11 dependent part of aRts (x11globalcomm module).
127
128 %description X11 -l pl
129 Czê¶æ aRts wymagaj±ca X11 (modu³ x11globalcomm).
130
131 %package qt
132 Summary:        Qt dependend part of aRts
133 Summary(pl):    Czê¶æ aRts wymagaj±ca Qt
134 Group:          X11/Libraries
135 Requires:       %{name} = %{epoch}:%{version}-%{release}
136 Requires:       qt >= 6:3.2.1-4
137
138 %description qt
139 Qt dependend part of aRts (qtmcop library).
140
141 %description qt -l pl
142 Czê¶æ aRts wymagaj±ca Qt (biblioteka qtmcop).
143
144 %package qt-devel
145 Summary:        Development files for qtmcop library
146 Summary(pl):    Pliki programistyczne dla biblioteki qtmcop
147 Group:          X11/Development/Libraries
148 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
149 Requires:       %{name}-qt = %{epoch}:%{version}-%{release}
150 Requires:       qt-devel >= 6:3.2.1-4
151
152 %description qt-devel
153 Development files for qtmcop library.
154
155 %description qt-devel -l pl
156 Pliki programistyczne dla biblioteki qtmcop.
157
158 %prep
159 %setup -q
160 %patch100 -p1
161
162 %build
163 cp -f /usr/share/automake/config.sub admin
164
165 #export UNSERMAKE=/usr/share/unsermake/unsermake
166
167 %{__make} -f admin/Makefile.common cvs
168
169 %configure \
170         %{!?with_nas:ac_cv_header_audio_audiolib_h=no} \
171         kde_cv_val_gcc_visibility_bug=yes \
172 %if "%{_lib}" == "lib64"
173         --enable-libsuffix=64 \
174 %endif
175         --%{?debug:en}%{!?debug:dis}able-debug%{?debug:=full} \
176         %{!?debug:--disable-rpath} \
177         --enable-final \
178         --with-qt-libraries=%{_libdir} \
179         --with%{!?with_alsa:out}-alsa
180
181 %{__make}
182
183 %install
184 rm -rf $RPM_BUILD_ROOT
185
186 %{__make} install \
187         DESTDIR=$RPM_BUILD_ROOT
188
189 # Debian manpages
190 install -d $RPM_BUILD_ROOT%{_mandir}/man1
191 cd debian/man
192 for f in *.sgml ; do
193         base="$(basename $f .sgml)"
194         upper="$(echo ${base} | tr a-z A-Z)"
195         db2man $f
196         install ${upper}.1 $RPM_BUILD_ROOT%{_mandir}/man1/${base}.1
197 done
198
199 %clean
200 rm -rf $RPM_BUILD_ROOT
201
202 %post   -p /sbin/ldconfig
203 %postun -p /sbin/ldconfig
204
205 %post   X11 -p /sbin/ldconfig
206 %postun X11 -p /sbin/ldconfig
207
208 %post   qt -p /sbin/ldconfig
209 %postun qt -p /sbin/ldconfig
210
211 %files
212 %defattr(644,root,root,755)
213 %attr(755,root,root) %{_bindir}/artscat
214 %attr(755,root,root) %{_bindir}/artsd
215 %attr(755,root,root) %{_bindir}/artsdsp
216 %attr(755,root,root) %{_bindir}/artsplay
217 %attr(755,root,root) %{_bindir}/artsrec
218 %attr(755,root,root) %{_bindir}/artsshell
219 %attr(755,root,root) %{_bindir}/artswrapper
220 # shared libraries
221 %attr(755,root,root) %{_libdir}/libartsc.so.*.*.*
222 %attr(755,root,root) %{_libdir}/libartsflow.so.*.*.*
223 %attr(755,root,root) %{_libdir}/libartsflow_idl.so.*.*.*
224 %attr(755,root,root) %{_libdir}/libgmcop.so.*.*.*
225 %attr(755,root,root) %{_libdir}/libkmedia2.so.*.*.*
226 %attr(755,root,root) %{_libdir}/libkmedia2_idl.so.*.*.*
227 %attr(755,root,root) %{_libdir}/libmcop.so.*.*.*
228 %attr(755,root,root) %{_libdir}/libmcop_mt.so.*.*.*
229 %attr(755,root,root) %{_libdir}/libsoundserver_idl.so.*.*.*
230 # lt_dlopened modules (*.la needed)
231 %attr(755,root,root) %{_libdir}/libartscbackend.so.*.*.*
232 %{_libdir}/libartscbackend.la
233 %attr(755,root,root) %{_libdir}/libartsdsp.so.*.*.*
234 %{_libdir}/libartsdsp.la
235 %attr(755,root,root) %{_libdir}/libartsdsp_st.so.*.*.*
236 %{_libdir}/libartsdsp_st.la
237 %attr(755,root,root) %{_libdir}/libartsgslplayobject.so.*.*.*
238 %{_libdir}/libartsgslplayobject.la
239 %attr(755,root,root) %{_libdir}/libartswavplayobject.so.*.*.*
240 %{_libdir}/libartswavplayobject.la
241 #
242 %{_libdir}/mcop
243 %{_mandir}/man1/artscat.1*
244 %{_mandir}/man1/artsd.1*
245 %{_mandir}/man1/artsdsp.1*
246 %{_mandir}/man1/artsplay.1*
247 %{_mandir}/man1/artsrec.1*
248 %{_mandir}/man1/artsshell.1*
249 %{_mandir}/man1/artswrapper.1*
250
251 %files devel
252 %defattr(644,root,root,755)
253 %attr(755,root,root) %{_bindir}/mcopidl
254 %attr(755,root,root) %{_libdir}/libartsflow.so
255 %attr(755,root,root) %{_libdir}/libartsflow_idl.so
256 %attr(755,root,root) %{_libdir}/libartsgslplayobject.so
257 %attr(755,root,root) %{_libdir}/libartswavplayobject.so
258 %attr(755,root,root) %{_libdir}/libgmcop.so
259 %attr(755,root,root) %{_libdir}/libkmedia2.so
260 %attr(755,root,root) %{_libdir}/libkmedia2_idl.so
261 %attr(755,root,root) %{_libdir}/libmcop.so
262 %attr(755,root,root) %{_libdir}/libmcop_mt.so
263 %attr(755,root,root) %{_libdir}/libsoundserver_idl.so
264 # it seems to be only (lt_)dlopened, nothing links with it - so not needed
265 # %attr(755,root,root) %{_libdir}/libx11globalcomm.so
266 # shared libraries
267 %{_libdir}/libartsflow.la
268 %{_libdir}/libartsflow_idl.la
269 %{_libdir}/libgmcop.la
270 %{_libdir}/libkmedia2.la
271 %{_libdir}/libkmedia2_idl.la
272 %{_libdir}/libmcop.la
273 %{_libdir}/libmcop_mt.la
274 %{_libdir}/libsoundserver_idl.la
275 #
276 %{_includedir}/arts
277 %exclude %{_includedir}/arts/qiomanager.h
278 %{_mandir}/man1/mcopidl.1*
279
280 %files -n artsc-devel
281 %defattr(644,root,root,755)
282 %attr(755,root,root) %{_bindir}/artsc-config
283 %attr(755,root,root) %{_libdir}/libartsc.so
284 %attr(755,root,root) %{_libdir}/libartscbackend.so
285 %attr(755,root,root) %{_libdir}/libartsdsp.so
286 %attr(755,root,root) %{_libdir}/libartsdsp_st.so
287 %{_libdir}/libartsc.la
288 %{_includedir}/artsc
289 %{_mandir}/man1/artsc-config.1*
290
291 %files X11
292 %defattr(644,root,root,755)
293 # lt_dlopened module (.la needed)
294 %attr(755,root,root) %{_libdir}/libx11globalcomm.so.*.*.*
295 %{_libdir}/libx11globalcomm.la
296
297 %files qt
298 %defattr(644,root,root,755)
299 # shared library
300 %attr(755,root,root) %{_libdir}/libqtmcop.so.*.*.*
301
302 %files qt-devel
303 %defattr(644,root,root,755)
304 %attr(755,root,root) %{_libdir}/libqtmcop.so
305 %{_libdir}/libqtmcop.la
306 %{_includedir}/arts/qiomanager.h
This page took 0.057686 seconds and 4 git commands to generate.