]> git.pld-linux.org Git - packages/arts.git/blob - arts.spec
- kde 3.2 rc1 test sourceball, this is not the official rc1 tarball
[packages/arts.git] / arts.spec
1 #
2 # TODO: consider:
3 # - separating artsc and its -devel? (but what are artsc deps?)
4 #
5 # Conditional build:
6 %bcond_without  alsa    # disable ALSA support
7 %bcond_with     nas     # enable NAS support
8 #
9
10 %define         _state          unstable
11 %define         _ver            1.1.95
12 %define         _snap           040110
13
14 Summary:        aRts sound server
15 Summary(pl):    Serwer d¼wiêku
16 Summary(pt_BR): Servidor de sons usado pelo KDE
17 Name:           arts
18 Version:        1.1.95
19 Release:        0.1
20 Epoch:          13
21 License:        LGPL
22 Group:          Libraries
23 #Source0:       ftp://ftp.kde.org/pub/kde/%{_state}/%{name}-%{_ver}.tar.bz2
24 Source0:        http://ep09.pld-linux.org/~djurban/kde/%{name}-%{version}.tar.bz2
25 # Source0-md5:  76feb4e5d5559e3a97659cbc833dab3a
26 URL:            http://www.kde.org/
27 %{?with_alsa:BuildRequires:     alsa-lib-devel}
28 BuildRequires:  audiofile-devel
29 BuildRequires:  autoconf
30 BuildRequires:  automake
31 BuildRequires:  docbook-dtd41-sgml
32 BuildRequires:  docbook-utils >= 0.6.13-3
33 BuildRequires:  esound-devel
34 BuildRequires:  glib2-devel >= 2.0.0
35 BuildRequires:  libmad-devel
36 BuildRequires:  libtool >= 2:1.5-2
37 BuildRequires:  libvorbis-devel
38 %{?with_nas:BuildRequires:      nas-devel}
39 BuildRequires:  pkgconfig
40 BuildRequires:  qt-devel >= 6:3.2.1-4
41 Obsoletes:      arts-glib
42 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44 %description
45 aRts sound server.
46
47 %description -l pl
48 Serwer d¼wiêku aRts.
49
50 %description -l pt_BR
51 O aRts é um sintetizador analógico em tempo real que é completamente
52 modular. Você pode criar sons e músicas (síntese em tempo real de
53 midi) usando pequenos módulos como oscilador para criar waveforms,
54 vários filtros, mixers, faders, etc. Você pode configurar tudo através
55 de uma interface no KDE. O Servidor aRts é controlado via CORBA. Este
56 design foi escolhido para permitir que outras aplicações usem o aRts
57 como um sintetizador (ou fornecedor de filtros). Usado pelo KDE, entre
58 outros.
59
60 %package devel
61 Summary:        Sound server - header files
62 Summary(pl):    Serwer d¼wiêku - pliki nag³ówkowe
63 Summary(pt_BR): Arquivos para desenvolvimento com o o aRts
64 Group:          Development/Libraries
65 Requires:       %{name} = %{epoch}:%{version}-%{release}
66 # not necessary for all libs (e.g. mcop), but propagated by artsflow
67 %{?with_alsa:Requires:  alsa-lib-devel}
68 Requires:       audiofile-devel
69 Requires:       esound-devel
70 Requires:       glib2-devel >= 2.0.0
71 Requires:       libmad-devel
72 Requires:       libvorbis-devel
73 %{?with_nas:Requires:   nas-devel}
74
75 %description devel
76 Header files required to compile programs using arts.
77
78 %description devel -l pl
79 Pliki nag³ówkowe niezbêdne do budowania aplikacji korzystaj±cych z
80 arts.
81
82 %description devel -l pt_BR
83 Arquivos para desenvolvimento com o o aRts.
84
85 # separate from arts-devel because they are mostly independent and have very
86 # different deps
87 # there is no artsc base - it would be small and would require arts - so there
88 # is no reason to separate
89 %package -n artsc-devel
90 Summary:        Development files for artsc libraries
91 Summary(pl):    Pliki programistyczne bibliotek artsc
92 Group:          Development/Libraries
93 Requires:       %{name} = %{epoch}:%{version}-%{release}
94 Requires:       glib2-devel >= 2.0.0
95 Conflicts:      arts-devel < 12:1.2.0.031126-2
96
97 %description -n artsc-devel
98 Development files for artsc libraries (C interface to aRts sound
99 system).
100
101 %description -n artsc-devel -l pl
102 Pliki programistyczne bibliotek artsc (interfejsu w C do systemu
103 d¼wiêku aRts).
104
105 %package X11
106 Summary:        X11 dependent part of aRts
107 Summary(pl):    Czê¶æ aRts wymagaj±ca X11
108 Group:          X11/Libraries
109 Requires:       %{name} = %{epoch}:%{version}-%{release}
110
111 %description X11
112 X11 dependent part of aRts (x11globalcomm module).
113
114 %description X11 -l pl
115 Czê¶æ aRts wymagaj±ca X11 (modu³ x11globalcomm).
116
117 %package qt
118 Summary:        QT dependend part of aRts
119 Summary(pl):    Czê¶æ aRts wymagaj±ca QT
120 Group:          X11/Libraries
121 Requires:       %{name} = %{epoch}:%{version}-%{release}
122 Requires:       qt >= 6:3.2.1-4
123
124 %description qt
125 QT dependend part of aRts (qtmcop library).
126
127 %description qt -l pl
128 Czê¶æ aRts wymagaj±ca QT (biblioteka qtmcop).
129
130 %package qt-devel
131 Summary:        Development files for qtmcop library
132 Summary(pl):    Pliki programistyczne dla biblioteki qtmcop
133 Group:          X11/Development/Libraries
134 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
135 Requires:       %{name}-qt = %{epoch}:%{version}-%{release}
136 Requires:       qt-devel >= 6:3.2.1-4
137
138 %description qt-devel
139 Development files for qtmcop library.
140
141 %description qt-devel -l pl
142 Pliki programistyczne dla biblioteki qtmcop.
143
144 %prep
145 %setup -q -n %{name}-%{version}
146
147 %build
148 cp /usr/share/automake/config.sub admin
149 %{__make} -f admin/Makefile.common cvs
150
151 %configure \
152         %{!?with_nas:ac_cv_header_audio_audiolib_h=no} \
153         --%{?debug:en}%{!?debug:dis}able-debug \
154         --disable-rpath \
155         --enable-final \
156         --with-qt-libraries=%{_libdir} \
157         --with%{!?with_alsa:out}-alsa
158
159 %{__make}
160
161 %install
162 rm -rf $RPM_BUILD_ROOT
163
164 %{__make} install \
165         DESTDIR=$RPM_BUILD_ROOT
166
167 # Debian manpages
168 install -d $RPM_BUILD_ROOT%{_mandir}/man1
169 cd debian
170 for f in *.sgml ; do
171         base="$(basename $f .sgml)"
172         upper="$(echo ${base} | tr a-z A-Z)"
173         db2man $f
174         install ${upper}.1 $RPM_BUILD_ROOT%{_mandir}/man1/${base}.1
175 done
176
177 %clean
178 rm -rf $RPM_BUILD_ROOT
179
180 %post   -p /sbin/ldconfig
181 %postun -p /sbin/ldconfig
182
183 %post   X11 -p /sbin/ldconfig
184 %postun X11 -p /sbin/ldconfig
185
186 %post   qt -p /sbin/ldconfig
187 %postun qt -p /sbin/ldconfig
188
189 %files
190 %defattr(644,root,root,755)
191 %attr(755,root,root) %{_bindir}/artscat
192 %attr(755,root,root) %{_bindir}/artsd
193 %attr(755,root,root) %{_bindir}/artsdsp
194 %attr(755,root,root) %{_bindir}/artsplay
195 %attr(755,root,root) %{_bindir}/artsrec
196 %attr(755,root,root) %{_bindir}/artsshell
197 %attr(755,root,root) %{_bindir}/artswrapper
198 # shared libraries
199 %attr(755,root,root) %{_libdir}/libartsc.so.*.*.*
200 %attr(755,root,root) %{_libdir}/libartsflow.so.*.*.*
201 %attr(755,root,root) %{_libdir}/libartsflow_idl.so.*.*.*
202 %attr(755,root,root) %{_libdir}/libgmcop.so.*.*.*
203 %attr(755,root,root) %{_libdir}/libkmedia2.so.*.*.*
204 %attr(755,root,root) %{_libdir}/libkmedia2_idl.so.*.*.*
205 %attr(755,root,root) %{_libdir}/libmcop.so.*.*.*
206 %attr(755,root,root) %{_libdir}/libmcop_mt.so.*.*.*
207 %attr(755,root,root) %{_libdir}/libsoundserver_idl.so.*.*.*
208 # lt_dlopened modules (*.la needed)
209 %attr(755,root,root) %{_libdir}/libartscbackend.so.*.*.*
210 %{_libdir}/libartscbackend.la
211 %attr(755,root,root) %{_libdir}/libartsdsp.so.*.*.*
212 %{_libdir}/libartsdsp.la
213 %attr(755,root,root) %{_libdir}/libartsdsp_st.so.*.*.*
214 %{_libdir}/libartsdsp_st.la
215 %attr(755,root,root) %{_libdir}/libartsgslplayobject.so.*.*.*
216 %{_libdir}/libartsgslplayobject.la
217 %attr(755,root,root) %{_libdir}/libartswavplayobject.so.*.*.*
218 %{_libdir}/libartswavplayobject.la
219 #
220 %{_libdir}/mcop
221 %{_mandir}/man1/artscat.1*
222 %{_mandir}/man1/artsd.1*
223 %{_mandir}/man1/artsdsp.1*
224 %{_mandir}/man1/artsplay.1*
225 %{_mandir}/man1/artsrec.1*
226 %{_mandir}/man1/artsshell.1*
227 %{_mandir}/man1/artswrapper.1*
228
229 %files devel
230 %defattr(644,root,root,755)
231 %attr(755,root,root) %{_bindir}/mcopidl
232 %attr(755,root,root) %{_libdir}/libartsflow.so
233 %attr(755,root,root) %{_libdir}/libartsflow_idl.so
234 %attr(755,root,root) %{_libdir}/libartsgslplayobject.so
235 %attr(755,root,root) %{_libdir}/libartswavplayobject.so
236 %attr(755,root,root) %{_libdir}/libgmcop.so
237 %attr(755,root,root) %{_libdir}/libkmedia2.so
238 %attr(755,root,root) %{_libdir}/libkmedia2_idl.so
239 %attr(755,root,root) %{_libdir}/libmcop.so
240 %attr(755,root,root) %{_libdir}/libmcop_mt.so
241 %attr(755,root,root) %{_libdir}/libsoundserver_idl.so
242 # it seems to be only (lt_)dlopened, nothing links with it - so not needed
243 # %attr(755,root,root) %{_libdir}/libx11globalcomm.so
244 # shared libraries
245 %{_libdir}/libartsflow.la
246 %{_libdir}/libartsflow_idl.la
247 %{_libdir}/libgmcop.la
248 %{_libdir}/libkmedia2.la
249 %{_libdir}/libkmedia2_idl.la
250 %{_libdir}/libmcop.la
251 %{_libdir}/libmcop_mt.la
252 %{_libdir}/libsoundserver_idl.la
253 #
254 %{_includedir}/arts
255 %exclude %{_includedir}/arts/qiomanager.h
256 %{_mandir}/man1/mcopidl.1*
257
258 %files -n artsc-devel
259 %defattr(644,root,root,755)
260 %attr(755,root,root) %{_bindir}/artsc-config
261 %attr(755,root,root) %{_libdir}/libartsc.so
262 %attr(755,root,root) %{_libdir}/libartscbackend.so
263 %attr(755,root,root) %{_libdir}/libartsdsp.so
264 %attr(755,root,root) %{_libdir}/libartsdsp_st.so
265 %{_libdir}/libartsc.la
266 %{_includedir}/artsc
267 %{_mandir}/man1/artsc-config.1*
268
269 %files X11
270 %defattr(644,root,root,755)
271 # lt_dlopened module (.la needed)
272 %attr(755,root,root) %{_libdir}/libx11globalcomm.so.*.*.*
273 %{_libdir}/libx11globalcomm.la
274
275 %files qt
276 %defattr(644,root,root,755)
277 # shared library
278 %attr(755,root,root) %{_libdir}/libqtmcop.so.*.*.*
279
280 %files qt-devel
281 %defattr(644,root,root,755)
282 %attr(755,root,root) %{_libdir}/libqtmcop.so
283 %{_libdir}/libqtmcop.la
284 %{_includedir}/arts/qiomanager.h
This page took 2.296315 seconds and 4 git commands to generate.