]> git.pld-linux.org Git - packages/arts.git/blob - arts.spec
- BR: nas-devel to reduce entropy (nas is used if found on builder)
[packages/arts.git] / arts.spec
1 # _without_alsa - disable alsa
2
3 %define         _state          stable
4 %define         _kdever         3.1
5
6 Summary:        aRts sound server
7 Summary(pl):    Serwer d¼wiêku
8 Summary(pt_BR): Servidor de sons usado pelo KDE
9 Name:           arts
10 Version:        1.1
11 Release:        5
12 Epoch:          12
13 License:        LGPL
14 Vendor:         The KDE Team
15 Group:          Libraries
16 Source0:        ftp://ftp.kde.org/pub/kde/%{_state}/%{_kdever}/src/%{name}-%{version}.tar.bz2
17 %ifnarch sparc sparcv9 sparc64
18 %{!?_without_alsa:BuildRequires:        alsa-lib-devel}
19 %endif
20 BuildRequires:  audiofile-devel
21 BuildRequires:  glib2-devel >= 2.0.0
22 BuildRequires:  libjpeg-devel
23 BuildRequires:  libpng-devel
24 # not needed, only ./configure check for this
25 #BuildRequires: libvorbis-devel
26 #BuildRequires: mad-devel
27 BuildRequires:  nas-devel
28 BuildRequires:  pkgconfig
29 BuildRequires:  qt-devel >= 3.1
30 URL:            http://www.kde.org/
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %define         _htmldir        /usr/share/doc/kde/HTML
34
35 %define         no_install_post_chrpath         1
36
37 %description
38 aRts sound server.
39
40 %description -l pl
41 Serwer d¼wiêku aRts.
42
43 %description -l pt_BR
44 O aRts é um sintetizador analógico em tempo real que é completamente
45 modular. Você pode criar sons e músicas (síntese em tempo real de
46 midi) usando pequenos módulos como oscilador para criar waveforms,
47 vários filtros, mixers, faders, etc. Você pode configurar tudo através
48 de uma interface no KDE. O Servidor aRts é controlado via CORBA. Este
49 design foi escolhido para permitir que outras aplicações usem o aRts
50 como um sintetizador (ou fornecedor de filtros). Usado pelo KDE, entre
51 outros.
52
53 %package X11
54 Summary:        X11 dependent part of aRts
55 Summary(pl):    Czê¶æ aRts wymagaj±ca X11
56 Group:          X11/Libraries
57
58 %description X11
59 X11 dependent part of aRts.
60
61 %description X11 -l pl
62 Czê¶æ aRts wymagaj±ca X11.
63
64 %package qt
65 Summary:        QT dependend part of aRts
66 Summary(pl):    Czê¶æ aRts wymagaj±ca QT
67 Group:          X11/Libraries
68 Requires:       %{name} >= %{version}
69 Requires:       qt >= 3.1
70
71 %description qt
72 QT dependend part of aRts.
73
74 %description qt -l pl
75 Czê¶æ aRts wymagaj±ca QT.
76
77 %package devel
78 Summary:        Sound server - header files
79 Summary(pl):    Serwer d¼wiêku - pliki nag³ówkowe
80 Summary(pt_BR): Arquivos para desenvolvimento com o o aRts
81 Group:          Development/Libraries
82 Requires:       qt-devel >= 3.1
83 Requires:       %{name} >= %{version}
84
85 %description devel
86 Header files required to compile programs using arts.
87
88 %description devel -l pl
89 Pliki nag³ówkowe niezbêdne do budowania aplikacji korzystaj±cych z
90 arts.
91
92 %description devel -l pt_BR
93 Arquivos para desenvolvimento com o o aRts.
94
95 %package glib
96 Summary:        GLib dependend part of aRts
97 Summary(pl):    Czê¶æ aRts wymagaj±ca GLib
98 Group:          X11/Libraries
99 Requires:       glib >= 1.2.6
100
101 %description glib
102 GLib dependend part of aRts.
103
104 %description glib -l pl
105 Czê¶æ aRts wymagaj±ca GLib.
106
107 %prep
108 %setup -q
109
110 %build
111 kde_htmldir="%{_htmldir}"; export kde_htmldir
112 kde_icondir="%{_pixmapsdir}"; export kde_icondir
113
114 %configure \
115         --%{?debug:en}%{!?debug:dis}able-debug \
116         --enable-final \
117         --with-xinerama \
118         --with%{?_without_alsa:out}-alsa
119
120 %{__make}
121
122 %install
123 rm -rf $RPM_BUILD_ROOT
124
125 %{__make} install DESTDIR=$RPM_BUILD_ROOT
126
127 %post   -p /sbin/ldconfig
128 %postun -p /sbin/ldconfig
129
130 %post X11   -p /sbin/ldconfig
131 %postun X11 -p /sbin/ldconfig
132
133 %post qt   -p /sbin/ldconfig
134 %postun qt -p /sbin/ldconfig
135
136 %post glib   -p /sbin/ldconfig
137 %postun glib -p /sbin/ldconfig
138
139 %clean
140 rm -rf $RPM_BUILD_ROOT
141
142 %files
143 %defattr(644,root,root,755)
144 %attr(755,root,root) %{_bindir}/artscat
145 %attr(755,root,root) %{_bindir}/artsd
146 %attr(755,root,root) %{_bindir}/artsdsp
147 %attr(755,root,root) %{_bindir}/artsplay
148 %attr(755,root,root) %{_bindir}/artsrec
149 %attr(755,root,root) %{_bindir}/artsshell
150 %attr(755,root,root) %{_bindir}/artswrapper
151 %attr(755,root,root) %{_bindir}/testdhandle
152 %{_libdir}/lib[!gqx]*.la
153 %attr(755,root,root) %{_libdir}/lib[!gqx]*.so.*
154 %{_libdir}/mcop
155
156 %files devel
157 %defattr(644,root,root,755)
158 %attr(755,root,root) %{_bindir}/artsc-config
159 %attr(755,root,root) %{_bindir}/mcopidl
160 %{_libdir}/*.so
161 %{_includedir}/arts
162 %{_includedir}/artsc
163
164 %files X11
165 %defattr(644,root,root,755)
166 %{_libdir}/libx11globalcomm.la
167 %attr(755,root,root) %{_libdir}/libx11globalcomm.so.*
168
169 %files glib
170 %defattr(644,root,root,755)
171 %{_libdir}/libgmcop.la
172 %attr(755,root,root) %{_libdir}/libgmcop.so.*
173
174 %files qt
175 %defattr(644,root,root,755)
176 %{_libdir}/libqtmcop.la
177 %attr(755,root,root) %{_libdir}/libqtmcop.so.*
This page took 0.410262 seconds and 3 git commands to generate.