]> git.pld-linux.org Git - packages/arts.git/blob - arts.spec
- updated to 030317 snapshot
[packages/arts.git] / arts.spec
1 #
2 # _with_nas             - enable NAS audio support
3 # _without_alsa         - disable ALSA support
4 #
5
6 %define         _state          snapshots
7 %define         _ver            030317
8
9 Summary:        aRts sound server
10 Summary(pl):    Serwer d¼wiêku
11 Summary(pt_BR): Servidor de sons usado pelo KDE
12 Name:           arts
13 Version:        1.2
14 Release:        0.%{_ver}.1
15 Epoch:          12
16 License:        LGPL
17 Vendor:         The KDE Team
18 Group:          Libraries
19 Source0:        ftp://ftp.kde.org/pub/kde/%{_state}/%{name}-%{_ver}.tar.bz2
20 Patch0:         http://rambo.its.tudelft.nl/~ewald/xine/arts-1.1.1-video-20030314.patch
21 %ifnarch sparc sparcv9 sparc64
22 %{!?_without_alsa:BuildRequires:        alsa-lib-devel}
23 %endif
24 BuildRequires:  audiofile-devel
25 BuildRequires:  glib2-devel >= 2.0.0
26 BuildRequires:  libjpeg-devel
27 BuildRequires:  libpng-devel
28 # not needed, only ./configure check for this
29 #BuildRequires: libvorbis-devel
30 #BuildRequires: mad-devel
31 %{?_with_nas:BuildRequires:     nas-devel}
32 %{!?_with_nas:BuildConflicts:   nas-devel}
33 BuildRequires:  pkgconfig
34 BuildRequires:  qt-devel >= 3.1
35 URL:            http://www.kde.org/
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %define         _htmldir        /usr/share/doc/kde/HTML
39
40 %define         no_install_post_chrpath         1
41
42 %description
43 aRts sound server.
44
45 %description -l pl
46 Serwer d¼wiêku aRts.
47
48 %description -l pt_BR
49 O aRts é um sintetizador analógico em tempo real que é completamente
50 modular. Você pode criar sons e músicas (síntese em tempo real de
51 midi) usando pequenos módulos como oscilador para criar waveforms,
52 vários filtros, mixers, faders, etc. Você pode configurar tudo através
53 de uma interface no KDE. O Servidor aRts é controlado via CORBA. Este
54 design foi escolhido para permitir que outras aplicações usem o aRts
55 como um sintetizador (ou fornecedor de filtros). Usado pelo KDE, entre
56 outros.
57
58 %package X11
59 Summary:        X11 dependent part of aRts
60 Summary(pl):    Czê¶æ aRts wymagaj±ca X11
61 Group:          X11/Libraries
62
63 %description X11
64 X11 dependent part of aRts.
65
66 %description X11 -l pl
67 Czê¶æ aRts wymagaj±ca X11.
68
69 %package qt
70 Summary:        QT dependend part of aRts
71 Summary(pl):    Czê¶æ aRts wymagaj±ca QT
72 Group:          X11/Libraries
73 Requires:       %{name} >= %{version}
74 Requires:       qt >= 3.1
75
76 %description qt
77 QT dependend part of aRts.
78
79 %description qt -l pl
80 Czê¶æ aRts wymagaj±ca QT.
81
82 %package devel
83 Summary:        Sound server - header files
84 Summary(pl):    Serwer d¼wiêku - pliki nag³ówkowe
85 Summary(pt_BR): Arquivos para desenvolvimento com o o aRts
86 Group:          Development/Libraries
87 Requires:       qt-devel >= 3.1
88 Requires:       %{name} >= %{version}
89
90 %description devel
91 Header files required to compile programs using arts.
92
93 %description devel -l pl
94 Pliki nag³ówkowe niezbêdne do budowania aplikacji korzystaj±cych z
95 arts.
96
97 %description devel -l pt_BR
98 Arquivos para desenvolvimento com o o aRts.
99
100 %package glib
101 Summary:        GLib dependend part of aRts
102 Summary(pl):    Czê¶æ aRts wymagaj±ca GLib
103 Group:          X11/Libraries
104 Requires:       glib >= 1.2.6
105
106 %description glib
107 GLib dependend part of aRts.
108
109 %description glib -l pl
110 Czê¶æ aRts wymagaj±ca GLib.
111
112 %prep
113 %setup -q -n %{name}-%{_ver}
114 %patch0 -p1
115 %build
116 kde_htmldir="%{_htmldir}"; export kde_htmldir
117 kde_icondir="%{_pixmapsdir}"; export kde_icondir
118
119 %configure \
120         --%{?debug:en}%{!?debug:dis}able-debug \
121         --enable-final \
122         --with-xinerama \
123         --with%{?_without_alsa:out}-alsa
124
125 %{__make}
126
127 %install
128 rm -rf $RPM_BUILD_ROOT
129
130 %{__make} install DESTDIR=$RPM_BUILD_ROOT
131
132 %post   -p /sbin/ldconfig
133 %postun -p /sbin/ldconfig
134
135 %post X11   -p /sbin/ldconfig
136 %postun X11 -p /sbin/ldconfig
137
138 %post qt   -p /sbin/ldconfig
139 %postun qt -p /sbin/ldconfig
140
141 %post glib   -p /sbin/ldconfig
142 %postun glib -p /sbin/ldconfig
143
144 %clean
145 rm -rf $RPM_BUILD_ROOT
146
147 %files
148 %defattr(644,root,root,755)
149 %attr(755,root,root) %{_bindir}/artscat
150 %attr(755,root,root) %{_bindir}/artsd
151 %attr(755,root,root) %{_bindir}/artsdsp
152 %attr(755,root,root) %{_bindir}/artsplay
153 %attr(755,root,root) %{_bindir}/artsrec
154 %attr(755,root,root) %{_bindir}/artsshell
155 %attr(755,root,root) %{_bindir}/artswrapper
156 ##%attr(755,root,root) %{_bindir}/testdhandle
157 %{_libdir}/lib[!gqx]*.la
158 %attr(755,root,root) %{_libdir}/lib[!gqx]*.so.*
159 %{_libdir}/mcop
160
161 %files devel
162 %defattr(644,root,root,755)
163 %attr(755,root,root) %{_bindir}/artsc-config
164 %attr(755,root,root) %{_bindir}/mcopidl
165 %{_libdir}/*.so
166 %{_includedir}/arts
167 %{_includedir}/artsc
168
169 %files X11
170 %defattr(644,root,root,755)
171 %{_libdir}/libx11globalcomm.la
172 %attr(755,root,root) %{_libdir}/libx11globalcomm.so.*
173
174 %files glib
175 %defattr(644,root,root,755)
176 %{_libdir}/libgmcop.la
177 %attr(755,root,root) %{_libdir}/libgmcop.so.*
178
179 %files qt
180 %defattr(644,root,root,755)
181 %{_libdir}/libqtmcop.la
182 %attr(755,root,root) %{_libdir}/libqtmcop.so.*
This page took 0.037581 seconds and 3 git commands to generate.