]> git.pld-linux.org Git - packages/arts.git/blob - arts.spec
8d8cf0439c43c50909fdf514b59f5f0df8c037e7
[packages/arts.git] / arts.spec
1 #
2 # _with_nas             - enable NAS audio support
3 # _without_alsa         - disable ALSA support
4 #
5
6 %define         _state          snapshots
7 %define         _ver            1.2
8 %define         _snap           030507
9
10 Summary:        aRts sound server
11 Summary(pl):    Serwer d¼wiêku
12 Summary(pt_BR): Servidor de sons usado pelo KDE
13 Name:           arts
14 Version:        1.2
15 Release:        0.%{_snap}.1
16 Epoch:          12
17 License:        LGPL
18 Group:          Libraries
19 #Source0:       ftp://ftp.kde.org/pub/kde/%{_state}/%{name}-%{_ver}.tar.bz2
20 Source0:        http://team.pld.org.pl/~adgor/kde/%{name}-%{_snap}.tar.bz2
21 #Patch0:                http://rambo.its.tudelft.nl/~ewald/xine/arts-1.1.1-video-20030314.patch
22 #Patch1:                http://rambo.its.tudelft.nl/~ewald/xine/arts-1.1.1-streaming-20030317.patch
23 %ifnarch sparc sparcv9 sparc64
24 %{!?_without_alsa:BuildRequires:        alsa-lib-devel}
25 %endif
26 BuildRequires:  audiofile-devel
27 BuildRequires:  glib2-devel >= 2.0.0
28 BuildRequires:  libjpeg-devel
29 BuildRequires:  libpng-devel
30 BuildRequires:  libvorbis-devel
31 BuildRequires:  mad-devel
32 %{?_with_nas:BuildRequires:     nas-devel}
33 %{!?_with_nas:BuildConflicts:   nas-devel}
34 BuildRequires:  pkgconfig
35 BuildRequires:  qt-devel >= 3.2-0.030428.1
36 URL:            http://www.kde.org/
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %define         no_install_post_chrpath         1
40
41 %description
42 aRts sound server.
43
44 %description -l pl
45 Serwer d¼wiêku aRts.
46
47 %description -l pt_BR
48 O aRts é um sintetizador analógico em tempo real que é completamente
49 modular. Você pode criar sons e músicas (síntese em tempo real de
50 midi) usando pequenos módulos como oscilador para criar waveforms,
51 vários filtros, mixers, faders, etc. Você pode configurar tudo através
52 de uma interface no KDE. O Servidor aRts é controlado via CORBA. Este
53 design foi escolhido para permitir que outras aplicações usem o aRts
54 como um sintetizador (ou fornecedor de filtros). Usado pelo KDE, entre
55 outros.
56
57 %package devel
58 Summary:        Sound server - header files
59 Summary(pl):    Serwer d¼wiêku - pliki nag³ówkowe
60 Summary(pt_BR): Arquivos para desenvolvimento com o o aRts
61 Group:          Development/Libraries
62 Requires:       qt-devel >= 3.1
63 Requires:       %{name} = %{version}-%{release}
64 Requires:       %{name}-X11 = %{version}-%{release}
65 Requires:       %{name}-glib = %{version}-%{release}
66 Requires:       %{name}-qt = %{version}-%{release}
67
68 %description devel
69 Header files required to compile programs using arts.
70
71 %description devel -l pl
72 Pliki nag³ówkowe niezbêdne do budowania aplikacji korzystaj±cych z
73 arts.
74
75 %description devel -l pt_BR
76 Arquivos para desenvolvimento com o o aRts.
77
78 %package X11
79 Summary:        X11 dependent part of aRts
80 Summary(pl):    Czê¶æ aRts wymagaj±ca X11
81 Group:          X11/Libraries
82
83 %description X11
84 X11 dependent part of aRts.
85
86 %description X11 -l pl
87 Czê¶æ aRts wymagaj±ca X11.
88
89 %package glib
90 Summary:        GLib dependend part of aRts
91 Summary(pl):    Czê¶æ aRts wymagaj±ca GLib
92 Group:          X11/Libraries
93 Requires:       glib >= 1.2.6
94
95 %description glib
96 GLib dependend part of aRts.
97
98 %description glib -l pl
99 Czê¶æ aRts wymagaj±ca GLib.
100
101 %package qt
102 Summary:        QT dependend part of aRts
103 Summary(pl):    Czê¶æ aRts wymagaj±ca QT
104 Group:          X11/Libraries
105 Requires:       %{name} >= %{version}
106 Requires:       qt >= 3.1
107
108 %description qt
109 QT dependend part of aRts.
110
111 %description qt -l pl
112 Czê¶æ aRts wymagaj±ca QT.
113
114 %prep
115 %setup -q -n %{name}-%{_snap}
116 #%patch0 -p1
117 #%patch1 -p1
118
119 %build
120
121 %configure \
122         --%{?debug:en}%{!?debug:dis}able-debug \
123         --enable-final \
124         --with%{?_without_alsa:out}-alsa
125
126 %{__make}
127
128 %install
129 rm -rf $RPM_BUILD_ROOT
130
131 %{__make} install DESTDIR=$RPM_BUILD_ROOT
132
133 %post           -p /sbin/ldconfig
134 %postun         -p /sbin/ldconfig
135
136 %post   X11     -p /sbin/ldconfig
137 %postun X11     -p /sbin/ldconfig
138
139 %post   glib    -p /sbin/ldconfig
140 %postun glib    -p /sbin/ldconfig
141
142 %post   qt      -p /sbin/ldconfig
143 %postun qt      -p /sbin/ldconfig
144
145 %clean
146 rm -rf $RPM_BUILD_ROOT
147
148 %files
149 %defattr(644,root,root,755)
150 %attr(755,root,root) %{_bindir}/artscat
151 %attr(755,root,root) %{_bindir}/artsd
152 %attr(755,root,root) %{_bindir}/artsdsp
153 %attr(755,root,root) %{_bindir}/artsplay
154 %attr(755,root,root) %{_bindir}/artsrec
155 %attr(755,root,root) %{_bindir}/artsshell
156 %attr(755,root,root) %{_bindir}/artswrapper
157 %{_libdir}/libartsc.la
158 %attr(755,root,root) %{_libdir}/libartsc.so.*.*.*
159 %{_libdir}/libartscbackend.la
160 %attr(755,root,root) %{_libdir}/libartscbackend.so.*.*.*
161 %{_libdir}/libartsdsp.la
162 %attr(755,root,root) %{_libdir}/libartsdsp.so.*.*.*
163 %{_libdir}/libartsdsp_st.la
164 %attr(755,root,root) %{_libdir}/libartsdsp_st.so.*.*.*
165 %{_libdir}/libartsflow.la
166 %attr(755,root,root) %{_libdir}/libartsflow.so.*.*.*
167 %{_libdir}/libartsflow_idl.la
168 %attr(755,root,root) %{_libdir}/libartsflow_idl.so.*.*.*
169 %{_libdir}/libartsgslplayobject.la
170 %attr(755,root,root) %{_libdir}/libartsgslplayobject.so.*.*.*
171 %{_libdir}/libartswavplayobject.la
172 %attr(755,root,root) %{_libdir}/libartswavplayobject.so.*.*.*
173 %{_libdir}/libkmedia2.la
174 %attr(755,root,root) %{_libdir}/libkmedia2.so.*.*.*
175 %{_libdir}/libkmedia2_idl.la
176 %attr(755,root,root) %{_libdir}/libkmedia2_idl.so.*.*.*
177 %{_libdir}/libmcop.la
178 %attr(755,root,root) %{_libdir}/libmcop.so.*.*.*
179 %{_libdir}/libmcop_mt.la
180 %attr(755,root,root) %{_libdir}/libmcop_mt.so.*.*.*
181 %{_libdir}/libsoundserver_idl.la
182 %attr(755,root,root) %{_libdir}/libsoundserver_idl.so.*.*.*
183 %{_libdir}/mcop
184
185 %files devel
186 %defattr(644,root,root,755)
187 %attr(755,root,root) %{_bindir}/artsc-config
188 %attr(755,root,root) %{_bindir}/mcopidl
189 %{_libdir}/*.so
190 %{_includedir}/arts
191 %{_includedir}/artsc
192
193 %files X11
194 %defattr(644,root,root,755)
195 %{_libdir}/libx11globalcomm.la
196 %attr(755,root,root) %{_libdir}/libx11globalcomm.so.*.*.*
197
198 %files glib
199 %defattr(644,root,root,755)
200 %{_libdir}/libgmcop.la
201 %attr(755,root,root) %{_libdir}/libgmcop.so.*.*.*
202
203 %files qt
204 %defattr(644,root,root,755)
205 %{_libdir}/libqtmcop.la
206 %attr(755,root,root) %{_libdir}/libqtmcop.so.*.*.*
This page took 0.060999 seconds and 2 git commands to generate.